Home | History | Annotate | Download | only in dcl.spec.auto

Lines Matching defs:only

1 // RUN: %clang_cc1 -fsyntax-only -verify %s -std=c++11
2 // RUN: %clang_cc1 -fsyntax-only -verify %s -std=c++98 -Wno-c++11-extensions
5 struct only {
6 only(T);
7 template<typename U> only(U) = delete;
14 only<const char [16]> testA = a;
15 only<const char **> testP = p;
20 only<unsigned long long> testB = b;
23 only<int> testC = c;
32 only<int> testX = x;
33 only<const int*> testV = v;
34 only<const int> testU = u;
35 only<double> testY = y;
40 only<bool> testA = a;
45 only<int> testA = a;
49 only<bool> testA = a;
53 only<const char[5]> testA = a;
77 only<void (S::*)()> test1 = p1;
78 only<void (S::*)()> test2 = p2;
79 only<void (S::*)()> test3 = p3;
80 only<char (S::*)(int)> test6 = p6;
81 only<int (S::*)> test7 = p7;
82 only<int (S::*)> test8 = p8;