Lines Matching refs:Element
20 The functions below can be used to query the characteristics of an Allocation, Element,
38 The term "element" is used a bit ambiguously in RenderScript, as both type information
41 <li>In functions like @rsGetElementAt(), "element" means the instantiation of the type,
46 An Element can specify a simple data types as found in C, e.g. an integer, float, or
58 Elements like <a href='http://developer.android.com/reference/android/renderscript/Element.html#F32_2(android.renderscript.RenderScript)'>F32_2</a>.
60 To create complex Elements, use the <a href='http://developer.android.com/reference/android/renderscript/Element.Builder.html'>Element.Builder</a> Java class.
128 ret: rs_element, "Element describing Allocation layout."
132 Get the Element object describing the type, kind, and other characteristics of a cell
161 This function can be used to check the Element returned by @rsElementGetSubElement()
170 summary: Size of an Element
172 Returns the size in bytes that an instantiation of this Element will occupy.
180 summary: Kind of an Element
182 Returns the Element's data kind. This is used to interpret pixel data.
192 summary: Data type of an Element
194 Returns the Element's base data type. This can be a type similar to C/C++ (e.g.
199 If the Element describes a vector, this function returns the data type of one of its items.
202 If the Element describes a structure, RS_TYPE_NONE is returned. Use the rsElementGetSub*
203 functions to explore this complex Element.
209 ret: rs_element, "Sub-element at the given index."
210 arg: rs_element e, "Element to query."
211 arg: uint32_t index, "Index of the sub-element to return."
212 summary: Sub-element of a complex Element
214 For Elements that represents a structure, this function returns the sub-element at the
217 If the Element is not a structure or the index is greater or equal to the number of
224 ret: uint32_t, "Array size of the sub-element."
225 arg: rs_element e, "Element to query."
226 arg: uint32_t index, "Index of the sub-element."
227 summary: Array size of a sub-element of a complex Element
230 returns the array size of the sub-element at the index. This sub-element repetition
238 arg: rs_element e, "Element to get data from."
250 arg: rs_element e, "Element to get data from."
251 arg: uint32_t index, "Index of the sub-element."
254 summary: Name of a sub-element
256 For complex Elements, this function returns the name of the sub-element at the
263 ret: uint32_t, "Length of the sub-element name including the null terminator."
264 arg: rs_element e, "Element to get data from."
265 arg: uint32_t index, "Index of the sub-element."
266 summary: Length of the name of a sub-element
268 For complex Elements, this function returns the length of the name of the sub-element
276 arg: rs_element e, "Element to get data from."
277 arg: uint32_t index, "Index of the sub-element."
278 summary: Offset of the instantiated sub-element
281 sub-element within the instantiation of the Element.
283 For example, if the Element describes a 32 bit float followed by a 32 bit integer,
290 ret: uint32_t, "Length of the element vector."
291 arg: rs_element e, "Element to get data from."
292 summary: Vector size of the Element
294 Returns the Element's vector size. If the Element does not represent a vector,