Home | History | Annotate | Download | only in dcl.fct.spec

Lines Matching refs:explicit

7   explicit A();
9 explicit operator int();
11 // expected-warning@-2 {{explicit conversion functions are a C++11 extension}}
14 explicit void f0(); // expected-error {{'explicit' can only be applied to a constructor or conversion function}}
19 explicit A::A() { } // expected-error {{'explicit' can only be specified inside the class definition}}
20 explicit A::operator bool() { return false; }
22 // expected-warning@-2 {{explicit conversion functions are a C++11 extension}}
24 // expected-error@-4 {{'explicit' can only be specified inside the class definition}}
27 friend explicit A::A(); // expected-error {{'explicit' is invalid in friend declarations}}