Home | History | Annotate | Download | only in script_api

Lines Matching refs:Matrix

18 summary: Matrix Functions
28 a vector is done by postmultiplying the vector, e.g. <code>(matrix * vector)</code>,
31 To create a transformation matrix that performs two transformations at once,
33 argument. E.g. to create a transformation matrix that applies the
39 style simply stores the transformation matrix in the first argument. The latter
40 modifies a pre-existing transformation matrix so that the new transformation
41 happens first. E.g. if you call @rsMatrixTranslate() on a matrix that already
42 does a scaling, the resulting matrix when applied to a vector will first do the
51 arg: const rs_matrix4x4* viewProj, "Matrix to extract planes from."
60 Computes 6 frustum planes from the view projection matrix
182 arg: const #1* m, "Matrix to extract the element from."
187 Returns one element of a matrix.
195 arg: rs_matrix4x4* m, "Matrix to invert."
196 summary: Inverts a matrix in place
198 Returns true if the matrix was successfully inverted.
204 arg: rs_matrix4x4* m, "Matrix to modify."
205 summary: Inverts and transpose a matrix in place
207 The matrix is first inverted then transposed. Returns true if the matrix was
215 arg: #1* destination, "Matrix to set."
216 arg: const float* array, "Array of values to set the matrix to. These arrays should be 4, 9, or 16 floats long, depending on the matrix size."
217 summary: Load or copy a matrix
219 Set the elements of a matrix from an array of floats or from another matrix.
225 If loading from a matrix and the source is smaller than the destination, the rest
226 of the destination is filled with elements of the identity matrix. E.g.
241 arg: const #1* source, "Source matrix."
255 arg: rs_matrix4x4* m, "Matrix to set."
262 summary: Load a frustum projection matrix
264 Constructs a frustum projection matrix, transforming the box identified by
268 matrix using @rsMatrixMultiply().
275 arg: #1* m, "Matrix to set."
276 summary: Load identity matrix
278 Set the elements of a matrix to the identity matrix.
285 arg: #1* m, "Matrix to set."
286 arg: const #1* lhs, "Left matrix of the product."
287 arg: const #1* rhs, "Right matrix of the product."
290 Sets m to the matrix product of <code>lhs * rhs</code>.
292 To combine two 4x4 transformaton matrices, multiply the second transformation matrix
293 by the first transformation matrix. E.g. to create a transformation matrix that applies
296 <b>Warning:</b> Prior to version 21, storing the result back into right matrix is not supported and
305 arg: rs_matrix4x4* m, "Matrix to set."
312 summary: Load an orthographic projection matrix
314 Constructs an orthographic projection matrix, transforming the box identified by the
318 To apply this projection to a vector, multiply the vector by the created matrix
327 arg: rs_matrix4x4* m, "Matrix to set."
332 summary: Load a perspective projection matrix
334 Constructs a perspective projection matrix, assuming a symmetrical field of view.
336 To apply this projection to a vector, multiply the vector by the created matrix
343 arg: rs_matrix4x4* m, "Matrix to set."
348 summary: Load a rotation matrix
350 This function creates a rotation matrix. The axis of rotation is the <code>(x, y, z)</code> vector.
352 To rotate a vector, multiply the vector by the created matrix using @rsMatrixMultiply().
360 arg: rs_matrix4x4* m, "Matrix to set."
364 summary: Load a scaling matrix
366 This function creates a scaling matrix, where each component of a vector is multiplied
369 To scale a vector, multiply the vector by the created matrix using @rsMatrixMultiply().
375 arg: rs_matrix4x4* m, "Matrix to set."
379 summary: Load a translation matrix
381 This function creates a translation matrix, where a number is added to each element of
384 To translate a vector, multiply the vector by the created matrix using
392 arg: #1* m, "Left matrix of the product and the matrix to be set."
393 arg: const #1* rhs, "Right matrix of the product."
394 summary: Multiply a matrix by a vector or another matrix
396 For the matrix by matrix variant, sets m to the matrix product <code>m * rhs</code>.
399 matrix will correspond to performing the rhs transformation first followed by
402 For the matrix by vector variant, returns the post-multiplication of the vector
403 by the matrix, ie. <code>m * in</code>.
411 Starting with API 14, this function takes a const matrix as the first argument.
513 arg: rs_matrix4x4* m, "Matrix to modify."
518 summary: Apply a rotation to a transformation matrix
520 Multiply the matrix m with a rotation matrix.
522 This function modifies a transformation matrix to first do a rotation. The axis of
526 matrix using @rsMatrixMultiply().
532 arg: rs_matrix4x4* m, "Matrix to modify."
536 summary: Apply a scaling to a transformation matrix
538 Multiply the matrix m with a scaling matrix.
540 This function modifies a transformation matrix to first do a scaling. When scaling,
544 matrix using @rsMatrixMultiply().
551 arg: #1* m, "Matrix that will be modified."
557 Set an element of a matrix.
565 arg: rs_matrix4x4* m, "Matrix to modify."
569 summary: Apply a translation to a transformation matrix
571 Multiply the matrix m with a translation matrix.
573 This function modifies a transformation matrix to first do a translation. When
577 created matrix using @rsMatrixMultiply().
584 arg: #1 m, "Matrix to transpose."
585 summary: Transpose a matrix place
587 Transpose the matrix m in place.