Home | History | Annotate | Download | only in dcl.constexpr

Lines Matching full:definition

28 // The definition of a constexpr function shall satisfy the following
49 constexpr F NonLiteralReturn2; // ok until definition
54 constexpr G NonLiteralParam2; // ok until definition
69 // expected-error@-5 {{defaulted definition of copy assignment operator is not constexpr}}
122 // - an asm-definition
138 // - a definition of a variable of non-literal type
143 // - a definition of a variable of static storage duration
148 // - a definition of a variable of thread storage duration
153 // - a definition of a variable for which no initialization is performed
205 // expected-error@-2 {{type definition in a constexpr function is a C++14 extension}}
212 // expected-error@-2 {{type definition in a constexpr function is a C++14 extension}}
219 // expected-error@-2 {{type definition in a constexpr function is a C++14 extension}}