Home | History | Annotate | Download | only in dcl.spec.auto

Lines Matching defs:auto

6   auto a; // expected-error{{'auto' not allowed in non-static struct member}}
7 auto *b; // expected-error{{'auto' not allowed in non-static struct member}}
8 const auto c; // expected-error{{'auto' not allowed in non-static struct member}}
10 void f() throw (auto); // expected-error{{'auto' not allowed here}}
12 friend auto; // expected-error{{'auto' not allowed in non-static struct member}}
14 operator auto(); // expected-error{{'auto' not allowed in conversion function type}}
17 // PR 9278: auto is not allowed in typedefs, except with a trailing return type.
18 typedef auto *AutoPtr; // expected-error{{'auto' not allowed in typedef}}
19 typedef auto (*PFun)(int a); // expected-error{{'auto' not allowed in typedef}}
20 typedef auto Fun(int a) -> decltype(a + a);
22 void g(auto a) { // expected-error{{'auto' not allowed in function prototype}}
24 catch (auto &a) { } // expected-error{{'auto' not allowed in exception declaration}}
25 catch (const auto a) { } // expected-error{{'auto' not allowed in exception declaration}}
26 try { } catch (auto a) { } // expected-error{{'auto' not allowed in exception declaration}}
29 void h(auto a[10]) { // expected-error{{'auto' not allowed in function prototype}}
32 void i(const auto a) { // expected-error{{'auto' not allowed in function prototype}}
42 (void)typeid(auto); // expected-error{{'auto' not allowed here}}
43 (void)sizeof(auto); // expected-error{{'auto' not allowed here}}
44 (void)__alignof(auto); // expected-error{{'auto' not allowed here}}
46 U<auto> v; // expected-error{{'auto' not allowed in template argument}}
49 (void)dynamic_cast<auto&>(n); // expected-error{{'auto' not allowed here}}
50 (void)static_cast<auto*>(&n); // expected-error{{'auto' not allowed here}}
51 (void)reinterpret_cast<auto*>(&n); // expected-error{{'auto' not allowed here}}
52 (void)const_cast<auto>(n); // expected-error{{'auto' not allowed here}}
53 (void)*(auto*)(&n); // expected-error{{'auto' not allowed here}}
54 (void)auto(n); // expected-error{{expected expression}}
55 (void)auto{n}; // expected-error{{expected expression}}
58 template <auto a = 10> class C { }; // expected-error{{'auto' not allowed in template parameter}}
60 template <const auto (*a)[3] = &ints> class D { }; // expected-error{{'auto' not allowed in template parameter}}
61 enum E : auto {}; // expected-error{{'auto' not allowed here}}
62 struct F : auto {}; // expected-error{{expected class name}}
63 template<typename T = auto> struct G { }; // expected-error{{'auto' not allowed in template argument}}
65 using A = auto; // expected-error{{'auto' not allowed in type alias}}
67 auto k() -> auto; // expected-error{{'auto' not allowed in function return type}}