Home | History | Annotate | Download | only in temp.deduct.type

Lines Matching defs:value

8   static const unsigned value = 0;
13 static const unsigned value = 1;
18 static const unsigned value = 2;
23 static const unsigned value = 3;
28 static const unsigned value = 4;
33 static const unsigned value = 5;
38 static const unsigned value = 6;
43 static_assert(member_pointer_kind<int (X::*)(int)>::value == 1, "");
44 static_assert(member_pointer_kind<int (X::*)(int) &>::value == 2, "");
45 static_assert(member_pointer_kind<int (X::*)(int) &&>::value == 3, "");
46 static_assert(member_pointer_kind<int (X::*)(int) const>::value == 4, "");
47 static_assert(member_pointer_kind<int (X::*)(int) const&>::value == 5, "");
48 static_assert(member_pointer_kind<int (X::*)(int) const&&>::value == 6, "");