Lines Matching full:definition
215 // explicit instantiation Declaration, and explicit instantiation defInition.
227 template class BasicStringPiece<int>; // expected-note {{explicit instantiation definition is here}}
228 extern template class BasicStringPiece<int>; // expected-error {{explicit instantiation declaration (with 'extern') follows explicit instantiation definition (without 'extern')}}
240 template class BasicStringPiece<int>; // expected-error {{explicit instantiation of undefined template 'spec_vs_expl_inst::IDS::BasicStringPiece<int>'}} // expected-note {{explicit instantiation definition is here}}
241 extern template class BasicStringPiece<int>; // expected-error {{explicit instantiation declaration (with 'extern') follows explicit instantiation definition (without 'extern')}}
271 template class BasicStringPiece<int>; // expected-note {{explicit instantiation definition is here}}
272 extern template class BasicStringPiece<int>; // expected-error {{explicit instantiation declaration (with 'extern') follows explicit instantiation definition (without 'extern')}}
284 template class BasicStringPiece<int>; // expected-note {{explicit instantiation definition is here}} expected-note {{previous definition is here}}
285 extern template class BasicStringPiece<int>; // expected-error {{explicit instantiation declaration (with 'extern') follows explicit instantiation definition (without 'extern')}}
314 template <> class BasicStringPiece<int> { }; // expected-note {{previous definition is here}}
321 template <> class BasicStringPiece<int> { }; // expected-note {{previous definition is here}}
328 template <> class BasicStringPiece<int> { }; // expected-note {{previous definition is here}}