Home | History | Annotate | Download | only in temp.expl.spec

Lines Matching defs:IntHolder

3 struct IntHolder { // expected-note{{here}} // expected-note 2{{candidate constructor (the implicit copy constructor)}}
4 IntHolder(int); // expected-note 2{{candidate constructor}}
25 IntHolder &test_X_IntHolderInt(X<IntHolder, int> xih) {
29 X<IntHolder, int>::Inner inner; // expected-note {{first required here}}
31 return X<IntHolder, int>::value; // expected-note{{instantiation}}
34 // Explicitly specialize the members of X<IntHolder, long> to not cause
37 void X<IntHolder, long>::f() { }
40 struct X<IntHolder, long>::Inner {
42 IntHolder value;
46 IntHolder X<IntHolder, long>::value = 17;
48 IntHolder &test_X_IntHolderInt(X<IntHolder, long> xih) {
52 X<IntHolder, long>::Inner inner; // okay, uses specialization
54 return X<IntHolder, long>::value; // okay, uses specialization
58 X<IntHolder, long>::X() { } // expected-error{{instantiated member}}