Home | History | Annotate | Download | only in debian
      1 #!/usr/bin/make -f
      2 # -*- makefile -*-
      3 
      4 # Uncomment this to turn on verbose mode.
      5 #export DH_VERBOSE=1
      6 
      7 DEBIAN_VERSION := $(shell dpkg-parsechangelog | sed -rne "s,^Version: (.*),\1,p")
      8 DEBIAN_REVISION := $(shell dpkg-parsechangelog | sed -rne "s,^Version: ([0-9.]+)(~|-)(.*),\3,p")
      9 UPSTREAM_VERSION := $(shell dpkg-parsechangelog | sed -rne "s,^Version: ([0-9.]+)(~|-)(.*),\1,p")
     10 
     11 %:
     12 	dh $@ --buildsystem=cmake --parallel --with python2,python3
     13 
     14 # tests cannot be run in parallel
     15 override_dh_auto_test:
     16 	dh_auto_test -O--buildsystem=cmake -O--no-parallel
     17 
     18 # FIXME: LLVM_DEFINITIONS is broken somehow in LLVM cmake upstream
     19 override_dh_auto_configure:
     20 	dh_auto_configure -- -DREVISION_LAST=$(UPSTREAM_VERSION) -DREVISION=$(UPSTREAM_VERSION) -DLLVM_DEFINITIONS="-D_GNU_SOURCE -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS" -DPYTHON_CMD="python2;python3"
     21