Home | History | Annotate | Download | only in strace
      1 Summary: Tracks and displays system calls associated with a running process
      2 Name: strace
      3 Version: 4.25
      4 Release: 1%{?dist}
      5 License: BSD%{?suse_version:-3-Clause}
      6 Group: Development%{?suse_version:/Tools}/Debuggers
      7 URL: https://strace.io
      8 Source: https://strace.io/files/%{version}/strace-%{version}.tar.xz
      9 BuildRequires: gcc gzip
     10 
     11 # Install Bluetooth headers for AF_BLUETOOTH sockets decoding.
     12 %if 0%{?fedora} >= 18 || 0%{?centos} >= 8 || 0%{?rhel} >= 8 || 0%{?suse_version} >= 1200
     13 BuildRequires: pkgconfig(bluez)
     14 %endif
     15 
     16 # Install elfutils-devel or libdw-devel to enable strace -k option.
     17 # Install binutils-devel to enable symbol demangling.
     18 %if 0%{?fedora} >= 20 || 0%{?centos} >= 6 || 0%{?rhel} >= 6
     19 %define buildrequires_stacktrace BuildRequires: elfutils-devel binutils-devel
     20 %endif
     21 %if 0%{?suse_version} >= 1100
     22 %define buildrequires_stacktrace BuildRequires: libdw-devel binutils-devel
     23 %endif
     24 %{?buildrequires_stacktrace}
     25 
     26 # OBS compatibility
     27 %{?!buildroot:BuildRoot: %_tmppath/buildroot-%name-%version-%release}
     28 %define maybe_use_defattr %{?suse_version:%%defattr(-,root,root)}
     29 
     30 %description
     31 The strace program intercepts and records the system calls called and
     32 received by a running process.  Strace can print a record of each
     33 system call, its arguments and its return value.  Strace is useful for
     34 diagnosing problems and debugging, as well as for instructional
     35 purposes.
     36 
     37 Install strace if you need a tool to track the system calls made and
     38 received by a process.
     39 
     40 %prep
     41 %setup -q
     42 echo -n %version-%release > .tarball-version
     43 echo -n 2018 > .year
     44 echo -n 2018-07-07 > .strace.1.in.date
     45 
     46 %build
     47 echo 'BEGIN OF BUILD ENVIRONMENT INFORMATION'
     48 uname -a |head -1
     49 libc="$(ldd /bin/sh |sed -n 's|^[^/]*\(/[^ ]*/libc\.so[^ ]*\).*|\1|p' |head -1)"
     50 $libc |head -1
     51 file -L /bin/sh
     52 gcc --version |head -1
     53 ld --version |head -1
     54 kver="$(printf '%%s\n%%s\n' '#include <linux/version.h>' 'LINUX_VERSION_CODE' | gcc -E -P -)"
     55 printf 'kernel-headers %%s.%%s.%%s\n' $(($kver/65536)) $(($kver/256%%256)) $(($kver%%256))
     56 echo 'END OF BUILD ENVIRONMENT INFORMATION'
     57 
     58 CFLAGS_FOR_BUILD="$RPM_OPT_FLAGS"; export CFLAGS_FOR_BUILD
     59 %configure --enable-mpers=check
     60 make %{?_smp_mflags}
     61 
     62 %install
     63 make DESTDIR=%{buildroot} install
     64 
     65 # remove unpackaged files from the buildroot
     66 rm -f %{buildroot}%{_bindir}/strace-graph
     67 
     68 # some say uncompressed changelog files are too big
     69 for f in ChangeLog ChangeLog-CVS; do
     70 	gzip -9n < "$f" > "$f".gz &
     71 done
     72 wait
     73 
     74 %check
     75 %{buildroot}%{_bindir}/strace -V
     76 make %{?_smp_mflags} -k check VERBOSE=1
     77 echo 'BEGIN OF TEST SUITE INFORMATION'
     78 tail -n 99999 -- tests*/test-suite.log tests*/ksysent.log
     79 find tests* -type f -name '*.log' -print0 |
     80 	xargs -r0 grep -H '^KERNEL BUG:' -- ||:
     81 echo 'END OF TEST SUITE INFORMATION'
     82 
     83 %files
     84 %maybe_use_defattr
     85 %doc CREDITS ChangeLog.gz ChangeLog-CVS.gz COPYING NEWS README
     86 %{_bindir}/strace
     87 %{_bindir}/strace-log-merge
     88 %{_mandir}/man1/*
     89 
     90 %changelog
     91 * Tue Oct 30 2018 strace-devel@lists.strace.io - 4.25-1
     92 - strace 4.25 snapshot.
     93 
     94 * Tue Aug 14 2018 Dmitry V. Levin <ldv@altlinux.org> - 4.24-1
     95 - v4.23 -> v4.24.
     96 
     97 * Thu Jun 14 2018 Dmitry V. Levin <ldv@altlinux.org> - 4.23-1
     98 - v4.22 -> v4.23.
     99 - Enabled libdw backend for -k option (#1568647).
    100 
    101 * Thu Apr 05 2018 Dmitry V. Levin <ldv@altlinux.org> - 4.22-1
    102 - v4.21 -> v4.22.
    103 
    104 * Tue Feb 13 2018 Dmitry V. Levin <ldv@altlinux.org> - 4.21-1
    105 - v4.20 -> v4.21.
    106 
    107 * Mon Nov 13 2017 Dmitry V. Levin <ldv@altlinux.org> - 4.20-1
    108 - v4.19 -> v4.20.
    109 
    110 * Tue Sep 05 2017 Dmitry V. Levin <ldv@altlinux.org> - 4.19-1
    111 - v4.18 -> v4.19.
    112 
    113 * Wed Jul 05 2017 Dmitry V. Levin <ldv@altlinux.org> - 4.18-1
    114 - v4.17 -> v4.18.
    115 
    116 * Wed May 24 2017 Dmitry V. Levin <ldv@altlinux.org> - 4.17-1
    117 - v4.16 -> v4.17.
    118 
    119 * Tue Feb 14 2017 Dmitry V. Levin <ldv@altlinux.org> - 4.16-1
    120 - v4.15 -> v4.16.
    121 
    122 * Wed Dec 14 2016 Dmitry V. Levin <ldv@altlinux.org> - 4.15-1
    123 - v4.14-100-g622af42 -> v4.15.
    124 
    125 * Wed Nov 16 2016 Dmitry V. Levin <ldv@altlinux.org> - 4.14.0.100.622a-1
    126 - v4.14 -> v4.14-100-g622af42:
    127   + implemented syscall fault injection.
    128 
    129 * Tue Oct 04 2016 Dmitry V. Levin <ldv@altlinux.org> - 4.14-1
    130 - v4.13 -> v4.14:
    131   + added printing of the mode argument of open and openat syscalls
    132     when O_TMPFILE flag is set (#1377846).
    133 
    134 * Tue Jul 26 2016 Dmitry V. Levin <ldv@altlinux.org> - 4.13-1
    135 - v4.12 -> v4.13.
    136 
    137 * Tue May 31 2016 Dmitry V. Levin <ldv@altlinux.org> - 4.12-1
    138 - v4.11-163-g972018f -> v4.12.
    139 
    140 * Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 4.11.0.163.9720-2
    141 - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
    142 
    143 * Fri Jan 15 2016 Dmitry V. Levin <ldv@altlinux.org> - 4.11.0.163.9720-1
    144 - New upstream snapshot v4.11-163-g972018f:
    145   + fixed decoding of syscalls unknown to the kernel on s390/s390x (#1298294).
    146 
    147 * Wed Dec 23 2015 Dmitry V. Levin <ldv@altlinux.org> - 4.11-2
    148 - Enabled experimental -k option on x86_64 (#1170296).
    149 
    150 * Mon Dec 21 2015 Dmitry V. Levin <ldv@altlinux.org> - 4.11-1
    151 - New upstream release:
    152   + print nanoseconds along with seconds in stat family syscalls (#1251176).
    153 
    154 * Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.10-3
    155 - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
    156 
    157 * Mon May 11 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 4.10-2
    158 - Backport set of upstream patches to get it buildable on AArch64
    159 
    160 * Fri Mar 06 2015 Dmitry V. Levin <ldv@altlinux.org> - 4.10-1
    161 - New upstream release:
    162   + enhanced ioctl decoding (#902788).
    163 
    164 * Mon Nov 03 2014 Lubomir Rintel <lkundrak@v3.sk> - 4.9-3
    165 - Regenerate ioctl entries with proper kernel headers
    166 
    167 * Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.9-2
    168 - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
    169 
    170 * Fri Aug 15 2014 Dmitry V. Levin <ldv@altlinux.org> - 4.9-1
    171 - New upstream release:
    172   + fixed build when <sys/ptrace.h> and <linux/ptrace.h> conflict (#993384);
    173   + updated CLOCK_* constants (#1088455);
    174   + enabled ppc64le support (#1122323);
    175   + fixed attach to a process on ppc64le (#1129569).
    176 
    177 * Fri Jul 25 2014 Dan Hork <dan[at]danny.cz> - 4.8-5
    178 - update for ppc64
    179 
    180 * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.8-4
    181 - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
    182 
    183 * Fri Dec  6 2013 Peter Robinson <pbrobinson@fedoraproject.org> 4.8-3
    184 - Fix FTBFS
    185 
    186 * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.8-2
    187 - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
    188 
    189 * Mon Jun 03 2013 Dmitry V. Levin <ldv@altlinux.org> - 4.8-1
    190 - New upstream release:
    191   + fixed ERESTARTNOINTR leaking to userspace on ancient kernels (#659382);
    192   + fixed decoding of *xattr syscalls (#885233);
    193   + fixed handling of files with 64-bit inode numbers by 32-bit strace (#912790);
    194   + added aarch64 support (#969858).
    195 
    196 * Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.7-3
    197 - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
    198 
    199 * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.7-2
    200 - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
    201 
    202 * Wed May 02 2012 Dmitry V. Levin <ldv@altlinux.org> 4.7-1
    203 - New upstream release.
    204   + implemented proper handling of real SIGTRAPs (#162774).
    205 
    206 * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.6-2
    207 - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
    208 
    209 * Mon Mar 14 2011 Dmitry V. Levin <ldv@altlinux.org> - 4.6-1
    210 - New upstream release.
    211   + fixed a corner case in waitpid handling (#663547).
    212 
    213 * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.20-2
    214 - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
    215 
    216 * Tue Apr 13 2010 Roland McGrath <roland@redhat.com> - 4.5.20-1
    217 - New upstream release, work mostly by Andreas Schwab and Dmitry V. Levin.
    218   + fixed potential stack buffer overflow in select decoder (#556678);
    219   + fixed FTBFS (#539044).
    220 
    221 * Wed Oct 21 2009 Roland McGrath <roland@redhat.com> - 4.5.19-1
    222 - New upstream release, work mostly by Dmitry V. Levin <ldv@altlinux.org>
    223   + exit/kill strace with traced process exitcode/signal (#105371);
    224   + fixed build on ARM EABI (#507576);
    225   + fixed display of 32-bit argv array on 64-bit architectures (#519480);
    226   + fixed display of 32-bit fcntl(F_SETLK) on 64-bit architectures (#471169);
    227   + fixed several bugs in strings decoder, including potential heap
    228     memory corruption (#470529, #478324, #511035).
    229 
    230 * Thu Aug 28 2008 Roland McGrath <roland@redhat.com> - 4.5.18-1
    231 - build fix for newer kernel headers (#457291)
    232 - fix CLONE_VFORK handling (#455078)
    233 - Support new Linux/PPC system call subpage_prot and PROT_SAO flag.
    234 - In sigaction system call, display sa_flags value along with SIG_DFL/SIG_IGN.
    235 
    236 * Mon Jul 21 2008 Roland McGrath <roland@redhat.com> - 4.5.17-1
    237 - handle O_CLOEXEC, MSG_CMSG_CLOEXEC (#365781)
    238 - fix biarch stat64 decoding (#222275)
    239 - fix spurious "..." in printing of environment strings (#358241)
    240 - improve prctl decoding (#364401)
    241 - fix hang wait on exited child with exited child (#354261)
    242 - fix biarch fork/vfork (-f) tracing (#447475)
    243 - fix biarch printing of negative argument kill (#430585)
    244 - fix biarch decoding of error return values (#447587)
    245 - fix -f tracing of CLONE_VFORK (#455078)
    246 - fix ia64 register clobberation in -f tracing (#453438)
    247 - print SO_NODEFER, SA_RESETHAND instead of SA_NOMASK, SA_ONESHOT (#455821)
    248 - fix futex argument decoding (#448628, #448629)
    249 
    250 * Fri Aug  3 2007 Roland McGrath <roland@redhat.com> - 4.5.16-1
    251 - fix multithread issues (#240962, #240961, #247907)
    252 - fix spurious SIGSTOP on early interrupt (#240986)
    253 - fix utime for biarch (#247185)
    254 - fix -u error message (#247170)
    255 - better futex syscall printing (##241467)
    256 - fix argv/envp printing with small -s settings, and for biarch
    257 - new syscalls: getcpu, eventfd, timerfd, signalfd, epoll_pwait,
    258   move_pages, utimensat
    259 
    260 * Tue Jan 16 2007 Roland McGrath <roland@redhat.com> - 4.5.15-1
    261 - biarch fixes (#179740, #192193, #171626, #173050, #218433, #218043)
    262 - fix -ff -o behavior (#204950, #218435, #193808, #219423)
    263 - better quotactl printing (#118696)
    264 - *at, inotify*, pselect6, ppoll and unshare syscalls (#178633, #191275)
    265 - glibc-2.5 build fixes (#209856)
    266 - memory corruption fixes (#200621
    267 - fix race in child setup under -f (#180293)
    268 - show ipc key values in hex (#198179, #192182)
    269 - disallow -c with -ff (#187847)
    270 - Resolves: RHBZ #179740, RHBZ #192193, RHBZ #204950, RHBZ #218435
    271 - Resolves: RHBZ #193808, RHBZ #219423, RHBZ #171626, RHBZ #173050
    272 - Resolves: RHBZ #218433, RHBZ #218043, RHBZ #118696, RHBZ #178633
    273 - Resolves: RHBZ #191275, RHBZ #209856, RHBZ #200621, RHBZ #180293
    274 - Resolves: RHBZ #198179, RHBZ #198182, RHBZ #187847
    275 
    276 * Mon Nov 20 2006 Jakub Jelinek <jakub@redhat.com> - 4.5.14-4
    277 - Fix ia64 syscall decoding (#206768)
    278 - Fix build with glibc-2.4.90-33 and up on all arches but ia64
    279 - Fix build against 2.6.18+ headers
    280 
    281 * Tue Aug 22 2006 Roland McGrath <roland@redhat.com> - 4.5.14-3
    282 - Fix bogus decoding of syscalls >= 300 (#201462, #202620).
    283 
    284 * Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-2
    285 - rebuild
    286 
    287 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.2
    288 - bump again for long double bug on ppc{,64}
    289 
    290 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.5.14-1.1
    291 - rebuilt for new gcc4.1 snapshot and glibc changes
    292 
    293 * Mon Jan 16 2006 Roland McGrath <roland@redhat.com> - 4.5.14-1
    294 - Fix biarch decoding of socket syscalls (#174354).
    295 - Fix biarch -e support (#173986).
    296 - Accept numeric syscalls in -e (#174798).
    297 - Fix ipc syscall decoding (#164755).
    298 - Improve msgrcv printing (#164757).
    299 - Man page updates (#165375).
    300 - Improve mount syscall printing (#165377).
    301 - Correct printing of restarting syscalls (#165469).
    302 
    303 * Wed Aug  3 2005 Roland McGrath <roland@redhat.com> - 4.5.13-1
    304 - Fix setsockopt decoding on 64-bit (#162449).
    305 - Fix typos in socket option name strings (#161578).
    306 - Display more IPV6 socket options by name (#162450).
    307 - Don't display inappropriate syscalls for -e trace=file (#159340).
    308 - New selector type -e trace=desc for file-descriptor using calls (#159400).
    309 - Fix 32-bit old_mmap syscall decoding on x86-64 (#162467, #164215).
    310 - Fix errors detaching from multithreaded process on interrupt (#161919).
    311 - Note 4.5.12 fix for crash handling bad signal numbers (#162739).
    312 
    313 * Wed Jun  8 2005 Roland McGrath <roland (at] redhat.com> - 4.5.12-1
    314 - Fix known syscall recognition for IA32 processes on x86-64 (#158934).
    315 - Fix bad output for ptrace on x86-64 (#159787).
    316 - Fix potential buffer overruns (#151570, #159196).
    317 - Make some diagnostics more consistent (#159308).
    318 - Update PowerPC system calls.
    319 - Better printing for Linux aio system calls.
    320 - Don't truncate statfs64 fields to 32 bits in output (#158243).
    321 - Cosmetic code cleanups (#159688).
    322 
    323 * Tue Mar 22 2005 Roland McGrath <roland@redhat.com> - 4.5.11-1
    324 - Build tweaks.
    325 - Note 4.5.10 select fix (#151570).
    326 
    327 * Mon Mar 14 2005 Roland McGrath <roland@redhat.com> - 4.5.10-1
    328 - Fix select handling on nonstandard fd_set sizes.
    329 - Don't print errors for null file name pointers.
    330 - Fix initial execve output with -i (#143365).
    331 
    332 * Fri Feb  4 2005 Roland McGrath <roland (at] redhat.com> - 4.5.9-2
    333 - update ia64 syscall list (#146245)
    334 - fix x86_64 syscall argument extraction for 32-bit processes (#146093)
    335 - fix -e signal=NAME parsing (#143362)
    336 - fix x86_64 exit_group syscall handling
    337 - improve socket ioctl printing (#138223)
    338 - code cleanups (#143369, #143370)
    339 - improve mount flags printing (#141932)
    340 - support symbolic printing of x86_64 arch_prctl parameters (#142667)
    341 - fix potential crash in getxattr printing
    342 
    343 * Tue Oct 19 2004 Roland McGrath <roland (at] redhat.com> - 4.5.8-1
    344 - fix multithreaded exit handling (#132150, #135254)
    345 - fix ioctl name matching (#129808)
    346 - print RTC_* ioctl structure contents (#58606)
    347 - grok epoll_* syscalls (#134463)
    348 - grok new RLIMIT_* values (#133594)
    349 - print struct cmsghdr contents for sendmsg (#131689)
    350 - fix clock_* and timer_* argument output (#131420)
    351 
    352 * Tue Aug 31 2004 Roland McGrath <roland (at] redhat.com> - 4.5.7-2
    353 - new upstream version, misc fixes and updates (#128091, #129166, #128391, #129378, #130965, #131177)
    354 
    355 * Mon Jul 12 2004 Roland McGrath <roland (at] redhat.com> 4.5.6-1
    356 - new upstream version, updates ioctl lists (#127398), fixes quotactl (#127393), more ioctl decoding (#126917)
    357 
    358 * Sun Jun 27 2004 Roland McGrath <roland (at] redhat.com> 4.5.5-1
    359 - new upstream version, fixes x86-64 biarch support (#126547)
    360 
    361 * Tue Jun 15 2004 Elliot Lee <sopwith (at] redhat.com> 4.5.4-2
    362 - rebuilt
    363 
    364 * Thu Jun  3 2004 Roland McGrath <roland (at] redhat.com> 4.5.4-0.FC1
    365 - rebuilt for FC1 update
    366 
    367 * Thu Jun  3 2004 Roland McGrath <roland (at] redhat.com> 4.5.4-1
    368 - new upstream version, more ioctls (#122257), minor fixes
    369 
    370 * Fri Apr 16 2004 Roland McGrath <roland (at] redhat.com> 4.5.3-1
    371 - new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685)
    372 
    373 * Tue Mar 02 2004 Elliot Lee <sopwith (at] redhat.com> 4.5.2-1.1
    374 - rebuilt
    375 
    376 * Mon Mar  1 2004 Roland McGrath <roland (at] redhat.com> 4.5.2-1
    377 - new upstream version, sched_* calls (#116990), show core flag (#112117)
    378 
    379 * Fri Feb 13 2004 Elliot Lee <sopwith (at] redhat.com>
    380 - rebuilt
    381 
    382 * Thu Nov 13 2003 Roland McGrath <roland (at] redhat.com> 4.5.1-1
    383 - new upstream version, more fixes (#108012, #105366, #105359, #105358)
    384 
    385 * Tue Sep 30 2003 Roland McGrath <roland (at] redhat.com> 4.5-3
    386 - revert bogus s390 fix
    387 
    388 * Thu Sep 25 2003 Roland McGrath <roland (at] redhat.com> 4.5-1.2.1AS
    389 - rebuilt for 2.1AS erratum
    390 
    391 * Wed Sep 24 2003 Roland McGrath <roland (at] redhat.com> 4.5-2
    392 - rebuilt
    393 
    394 * Wed Sep 24 2003 Roland McGrath <roland (at] redhat.com> 4.5-1
    395 - new upstream version, more fixes (#101499, #104365)
    396 
    397 * Thu Jul 17 2003 Roland McGrath <roland (at] redhat.com> 4.4.99-2
    398 - rebuilt
    399 
    400 * Thu Jul 17 2003 Roland McGrath <roland (at] redhat.com> 4.4.99-1
    401 - new upstream version, groks more new system calls, PF_INET6 sockets
    402 
    403 * Tue Jun 10 2003 Roland McGrath <roland (at] redhat.com> 4.4.98-1
    404 - new upstream version, more fixes (#90754, #91085)
    405 
    406 * Wed Jun 04 2003 Elliot Lee <sopwith (at] redhat.com>
    407 - rebuilt
    408 
    409 * Sun Mar 30 2003 Roland McGrath <roland (at] redhat.com> 4.4.96-1
    410 - new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
    411 
    412 * Mon Feb 24 2003 Elliot Lee <sopwith (at] redhat.com> 4.4.95-2
    413 - rebuilt
    414 
    415 * Mon Feb 24 2003 Roland McGrath <roland (at] redhat.com> 4.4.95-1
    416 - new upstream version, fixed getresuid/getresgid (#84959)
    417 
    418 * Wed Feb 19 2003 Roland McGrath <roland (at] redhat.com> 4.4.94-1
    419 - new upstream version, new option -E to set environment variables (#82392)
    420 
    421 * Wed Jan 22 2003 Tim Powers <timp (at] redhat.com> 4.4.93-2
    422 - rebuilt
    423 
    424 * Tue Jan 21 2003 Roland McGrath <roland (at] redhat.com> 4.4.93-1
    425 - new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
    426 
    427 * Fri Jan 10 2003 Roland McGrath <roland (at] redhat.com> 4.4.91-1
    428 - new upstream version, fixes -f on x86-64
    429 
    430 * Fri Jan 10 2003 Roland McGrath <roland (at] redhat.com> 4.4.90-1
    431 - new upstream version, fixes all known bugs modulo ia64 and s390 issues
    432 
    433 * Fri Jan 03 2003 Florian La Roche <Florian.LaRoche (at] redhat.de> 4.4-11
    434 - add further s390 patch from IBM
    435 
    436 * Wed Nov 27 2002 Tim Powers <timp (at] redhat.com> 4.4-10
    437 - remove unpackaged files from the buildroot
    438 
    439 * Mon Oct 07 2002 Phil Knirsch <pknirsch (at] redhat.com> 4.4-9.1
    440 - Added latest s390(x) patch.
    441 
    442 * Fri Sep 06 2002 Karsten Hopp <karsten (at] redhat.de> 4.4-9
    443 - preliminary x86_64 support with an ugly patch to help
    444   debugging. Needs cleanup!
    445 
    446 * Mon Sep  2 2002 Jakub Jelinek <jakub (at] redhat.com> 4.4-8
    447 - newer version of the clone fixing patch (Roland McGrath)
    448 - aio syscalls for i386/ia64/ppc (Ben LaHaise)
    449 
    450 * Wed Aug 28 2002 Jakub Jelinek <jakub (at] redhat.com> 4.4-7
    451 - fix strace -f (Roland McGrath, #68994)
    452 - handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
    453 
    454 * Fri Jun 21 2002 Jakub Jelinek <jakub (at] redhat.com> 4.4-6
    455 - handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
    456 - handle modify_ldt (#66894)
    457 
    458 * Thu May 23 2002 Tim Powers <timp (at] redhat.com>
    459 - automated rebuild
    460 
    461 * Tue Apr 16 2002 Jakub Jelinek <jakub (at] redhat.com> 4.4-4
    462 - fix for the last patch by Jeff Law (#62591)
    463 
    464 * Mon Mar  4 2002 Preston Brown <pbrown (at] redhat.com> 4.4-3
    465 - integrate patch from Jeff Law to eliminate hang tracing threads
    466 
    467 * Sat Feb 23 2002 Florian La Roche <Florian.LaRoche (at] redhat.de>
    468 - minor update from debian tar-ball
    469 
    470 * Wed Jan 02 2002 Florian La Roche <Florian.LaRoche (at] redhat.de>
    471 - update to 4.4
    472 
    473 * Sun Jul 22 2001 Florian La Roche <Florian.LaRoche (at] redhat.de>
    474 - disable s390 patches, they are already included
    475 
    476 * Wed Jul 18 2001 Preston Brown <pbrown (at] redhat.com> 4.3-1
    477 - new upstream version.  Seems to have integrated most new syscalls
    478 - tracing threaded programs is now functional.
    479 
    480 * Mon Jun 11 2001 Than Ngo <than (at] redhat.com>
    481 - port s390 patches from IBM
    482 
    483 * Wed May 16 2001 Nalin Dahyabhai <nalin (at] redhat.com>
    484 - modify new syscall patch to allocate enough heap space in setgroups32()
    485 
    486 * Wed Feb 14 2001 Jakub Jelinek <jakub (at] redhat.com>
    487 - #include <time.h> in addition to <sys/time.h>
    488 
    489 * Fri Jan 26 2001 Karsten Hopp <karsten (at] redhat.com>
    490 - clean up conflicting patches. This happened only
    491   when building on S390
    492 
    493 * Fri Jan 19 2001 Bill Nottingham <notting (at] redhat.com>
    494 - update to CVS, reintegrate ia64 support
    495 
    496 * Fri Dec  8 2000 Bernhard Rosenkraenzer <bero (at] redhat.com>
    497 - Get S/390 support into the normal package
    498 
    499 * Sat Nov 18 2000 Florian La Roche <Florian.LaRoche (at] redhat.de>
    500 - added S/390 patch from IBM, adapting it to not conflict with
    501   IA64 patch
    502 
    503 * Sat Aug 19 2000 Jakub Jelinek <jakub (at] redhat.com>
    504 - doh, actually apply the 2.4 syscalls patch
    505 - make it compile with 2.4.0-test7-pre4+ headers, add
    506   getdents64 and fcntl64
    507 
    508 * Thu Aug  3 2000 Jakub Jelinek <jakub (at] redhat.com>
    509 - add a bunch of new 2.4 syscalls (#14036)
    510 
    511 * Wed Jul 12 2000 Prospector <bugzilla (at] redhat.com>
    512 - automatic rebuild
    513 - excludearch ia64
    514 
    515 * Fri Jun  2 2000 Matt Wilson <msw (at] redhat.com>
    516 - use buildinstall for FHS
    517 
    518 * Wed May 24 2000 Jakub Jelinek <jakub (at] redhat.com>
    519 - make things compile on sparc
    520 - fix sigreturn on sparc
    521 
    522 * Fri Mar 31 2000 Bill Nottingham <notting (at] redhat.com>
    523 - fix stat64 misdef (#10485)
    524 
    525 * Tue Mar 21 2000 Michael K. Johnson <johnsonm (at] redhat.com>
    526 - added ia64 patch
    527 
    528 * Thu Feb 03 2000 Cristian Gafton <gafton (at] redhat.com>
    529 - man pages are compressed
    530 - version 4.2 (why are we keeping all these patches around?)
    531 
    532 * Sat Nov 27 1999 Jeff Johnson <jbj (at] redhat.com>
    533 - update to 4.1 (with sparc socketcall patch).
    534 
    535 * Fri Nov 12 1999 Jakub Jelinek <jakub (at] redhat.com>
    536 - fix socketcall on sparc.
    537 
    538 * Thu Sep 02 1999 Cristian Gafton <gafton (at] redhat.com>
    539 - fix KERN_SECURELVL compile problem
    540 
    541 * Tue Aug 31 1999 Cristian Gafton <gafton (at] redhat.com>
    542 - added alpha patch from HJLu to fix the osf_sigprocmask interpretation
    543 
    544 * Sat Jun 12 1999 Jeff Johnson <jbj (at] redhat.com>
    545 - update to 3.99.1.
    546 
    547 * Wed Jun  2 1999 Jeff Johnson <jbj (at] redhat.com>
    548 - add (the other :-) jj's sparc patch.
    549 
    550 * Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
    551 - upgrade to 3.99 in order to
    552 -    add new 2.2.x open flags (#2955).
    553 -    add new 2.2.x syscalls (#2866).
    554 - strace 3.1 patches carried along for now.
    555 
    556 * Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
    557 - don't rely on (broken!) rpm %%patch (#2735)
    558 
    559 * Tue Apr 06 1999 Preston Brown <pbrown (at] redhat.com>
    560 - strip binary
    561 
    562 * Sun Mar 21 1999 Cristian Gafton <gafton (at] redhat.com>
    563 - auto rebuild in the new build environment (release 16)
    564 
    565 * Tue Feb  9 1999 Jeff Johnson <jbj (at] redhat.com>
    566 - vfork est arrive!
    567 
    568 * Tue Feb  9 1999 Christopher Blizzard <blizzard (at] redhat.com>
    569 - Add patch to follow clone() syscalls, too.
    570 
    571 * Sun Jan 17 1999 Jeff Johnson <jbj (at] redhat.com>
    572 - patch to build alpha/sparc with glibc 2.1.
    573 
    574 * Thu Dec 03 1998 Cristian Gafton <gafton (at] redhat.com>
    575 - patch to build on ARM
    576 
    577 * Wed Sep 30 1998 Jeff Johnson <jbj (at] redhat.com>
    578 - fix typo (printf, not tprintf).
    579 
    580 * Sat Sep 19 1998 Jeff Johnson <jbj (at] redhat.com>
    581 - fix compile problem on sparc.
    582 
    583 * Tue Aug 18 1998 Cristian Gafton <gafton (at] redhat.com>
    584 - buildroot
    585 
    586 * Mon Jul 20 1998 Cristian Gafton <gafton (at] redhat.com>
    587 - added the umoven patch from James Youngman <jay (at] gnu.org>
    588 - fixed build problems on newer glibc releases
    589 
    590 * Mon Jun 08 1998 Prospector System <bugs (at] redhat.com>
    591 - translations modified for de, fr, tr
    592