Home | History | Annotate | Download | only in e2fsprogs
      1 %define	_root_sbindir	/sbin
      2 %define	_root_libdir	/%{_lib}
      3 %define	_root_localedir	/usr/share/locale
      4 %define	_root_etcdir	/etc
      5 
      6 Summary: Utilities for managing the second extended (ext2) filesystem.
      7 Name: e2fsprogs
      8 Version: 1.40.8
      9 Release: 0
     10 License: GPLv2
     11 Group: System Environment/Base
     12 Source:  ftp://download.sourceforge.net/pub/sourceforge/e2fsprogs/e2fsprogs-%{version}.tar.gz
     13 Url: http://e2fsprogs.sourceforge.net/
     14 Prereq: /sbin/ldconfig
     15 BuildRoot: %{_tmppath}/%{name}-root
     16 
     17 %description
     18 The e2fsprogs package contains a number of utilities for creating,
     19 checking, modifying, and correcting any inconsistencies in second
     20 extended (ext2) filesystems.  E2fsprogs contains e2fsck (used to
     21 repair filesystem inconsistencies after an unclean shutdown), mke2fs
     22 (used to initialize a partition to contain an empty ext2 filesystem),
     23 debugfs (used to examine the internal structure of a filesystem, to
     24 manually repair a corrupted filesystem or to create test cases for
     25 e2fsck), tune2fs (used to modify filesystem parameters), resize2fs to
     26 grow and shrink unmounted ext2 filesystems, and most of the other core
     27 ext2fs filesystem utilities.
     28 
     29 You should install the e2fsprogs package if you are using any ext2
     30 filesystems (if you're not sure, you probably should install this
     31 package).  You may also need to install it (even if you don't use
     32 ext2) for the libuuid and libblkid libraries and fsck tool that are
     33 included here.
     34 
     35 %package devel
     36 Summary: Ext2 filesystem-specific static libraries and headers.
     37 Group: Development/Libraries
     38 Requires: e2fsprogs = %{version}
     39 Prereq: /sbin/install-info
     40 
     41 %description devel
     42 E2fsprogs-devel contains the libraries and header files needed to
     43 develop second extended (ext2) filesystem-specific programs.
     44 
     45 You should install e2fsprogs-devel if you want to develop ext2
     46 filesystem-specific programs.  If you install e2fsprogs-devel, you'll
     47 also want to install e2fsprogs.
     48 
     49 %package -n uuidd
     50 Summary: helper daemon to guarantee uniqueness of time-based UUIDs
     51 Group: System Environment/Daemons
     52 License: GPLv2
     53 Requires: e2fsprogs = %{version}
     54 Requires(pre): shadow-utils
     55 
     56 %description -n uuidd
     57 The uuidd package contains a userspace daemon (uuidd) which guarantees
     58 uniqueness of time-based UUID generation even at very high rates on
     59 SMP systems.
     60 
     61 %prep
     62 %setup
     63 
     64 %build
     65 %configure --enable-elf-shlibs --enable-nls
     66 make
     67 make check
     68 
     69 %install
     70 rm -rf $RPM_BUILD_ROOT
     71 export PATH=/sbin:$PATH
     72 make install install-libs DESTDIR="$RPM_BUILD_ROOT" \
     73 	root_sbindir=%{_root_sbindir} root_libdir=%{_root_libdir}
     74 /sbin/ldconfig -n ${RPM_BUILD_ROOT}%{_libdir}
     75 
     76 # Add a dir that uuidd needs that the Makefiles don't create
     77 install -d $RPM_BUILD_ROOT/var/lib/libuuid
     78 
     79 %find_lang %{name}
     80 
     81 %clean
     82 rm -rf $RPM_BUILD_ROOT
     83 
     84 %post -p /sbin/ldconfig
     85 
     86 %postun -p /sbin/ldconfig
     87 
     88 %post devel
     89 if [ -x /sbin/install-info -a -f %{_infodir}/libext2fs.info.gz ]; then
     90     /sbin/install-info %{_infodir}/libext2fs.info.gz %{_infodir}/dir
     91 fi
     92 exit 0
     93 
     94 %postun devel
     95 if [ $1 = 0 -a -x /sbin/install-info -a -f %{_infodir}/libext2fs.info.gz ]; then
     96    /sbin/install-info --delete %{_infodir}/libext2fs.info.gz %{_infodir}/dir
     97 fi
     98 exit 0
     99 
    100 %pre -n uuidd
    101 getent group uuidd >/dev/null || groupadd -r uuidd
    102 getent passwd uuidd >/dev/null || \
    103 useradd -r -g uuidd -d /var/lib/libuuid -s /sbin/nologin \
    104     -c "UUID generator helper daemon" uuidd
    105 exit 0
    106 
    107 %files -f %{name}.lang
    108 %defattr(-,root,root)
    109 %doc README RELEASE-NOTES
    110 
    111 %{_root_sbindir}/badblocks
    112 %{_root_sbindir}/blkid
    113 %{_root_sbindir}/debugfs
    114 %{_root_sbindir}/dumpe2fs
    115 %{_root_sbindir}/e2fsck
    116 %{_root_sbindir}/e2image
    117 %{_root_sbindir}/e2label
    118 %{_root_sbindir}/findfs
    119 %{_root_sbindir}/fsck
    120 %{_root_sbindir}/fsck.ext2
    121 %{_root_sbindir}/fsck.ext3
    122 %{_root_sbindir}/logsave
    123 %{_root_sbindir}/mke2fs
    124 %{_root_etcdir}/mke2fs.conf
    125 %{_root_sbindir}/mkfs.ext2
    126 %{_root_sbindir}/mkfs.ext3
    127 %{_root_sbindir}/resize2fs
    128 %{_root_sbindir}/tune2fs
    129 %{_sbindir}/filefrag
    130 %{_sbindir}/mklost+found
    131 
    132 %{_root_libdir}/libblkid.so.*
    133 %{_root_libdir}/libcom_err.so.*
    134 %{_root_libdir}/libe2p.so.*
    135 %{_root_libdir}/libext2fs.so.*
    136 %{_root_libdir}/libss.so.*
    137 %{_root_libdir}/libuuid.so.*
    138 
    139 %{_libdir}/e2initrd_helper
    140 
    141 %{_bindir}/chattr
    142 %{_bindir}/lsattr
    143 %{_bindir}/uuidgen
    144 %{_mandir}/man1/chattr.1*
    145 %{_mandir}/man1/lsattr.1*
    146 %{_mandir}/man1/uuidgen.1*
    147 
    148 %{_mandir}/man5/e2fsck.conf.5*
    149 %{_mandir}/man5/mke2fs.conf.5*
    150 
    151 %{_mandir}/man8/badblocks.8*
    152 %{_mandir}/man8/blkid.8*
    153 %{_mandir}/man8/debugfs.8*
    154 %{_mandir}/man8/dumpe2fs.8*
    155 %{_mandir}/man8/e2fsck.8*
    156 %{_mandir}/man8/findfs.8*
    157 %{_mandir}/man8/fsck.ext2.8*
    158 %{_mandir}/man8/fsck.ext3.8*
    159 %{_mandir}/man8/e2image.8*
    160 %{_mandir}/man8/e2label.8*
    161 %{_mandir}/man8/fsck.8*
    162 %{_mandir}/man8/logsave.8*
    163 %{_mandir}/man8/mke2fs.8*
    164 %{_mandir}/man8/mkfs.ext2.8*
    165 %{_mandir}/man8/mkfs.ext3.8*
    166 %{_mandir}/man8/mklost+found.8*
    167 %{_mandir}/man8/resize2fs.8*
    168 %{_mandir}/man8/tune2fs.8*
    169 %{_mandir}/man8/filefrag.8*
    170 
    171 %files devel
    172 %defattr(-,root,root)
    173 %{_infodir}/libext2fs.info*
    174 %{_bindir}/compile_et
    175 %{_bindir}/mk_cmds
    176 
    177 %{_libdir}/libblkid.a
    178 %{_libdir}/libblkid.so
    179 %{_libdir}/libcom_err.a
    180 %{_libdir}/libcom_err.so
    181 %{_libdir}/libe2p.a
    182 %{_libdir}/libe2p.so
    183 %{_libdir}/libext2fs.a
    184 %{_libdir}/libext2fs.so
    185 %{_libdir}/libss.a
    186 %{_libdir}/libss.so
    187 %{_libdir}/libuuid.a
    188 %{_libdir}/libuuid.so
    189 
    190 %{_libdir}/pkgconfig/blkid.pc
    191 %{_libdir}/pkgconfig/com_err.pc
    192 %{_libdir}/pkgconfig/e2p.pc
    193 %{_libdir}/pkgconfig/ext2fs.pc
    194 %{_libdir}/pkgconfig/ss.pc
    195 %{_libdir}/pkgconfig/uuid.pc
    196 
    197 %{_datadir}/et
    198 %{_datadir}/ss
    199 %{_includedir}/blkid
    200 %{_includedir}/e2p
    201 %{_includedir}/et
    202 %{_includedir}/ext2fs
    203 %{_includedir}/ss
    204 %{_includedir}/uuid
    205 %{_mandir}/man1/compile_et.1*
    206 %{_mandir}/man1/mk_cmds.1*
    207 %{_mandir}/man3/com_err.3*
    208 %{_mandir}/man3/libblkid.3*
    209 %{_mandir}/man3/uuid.3*
    210 %{_mandir}/man3/uuid_clear.3*
    211 %{_mandir}/man3/uuid_compare.3*
    212 %{_mandir}/man3/uuid_copy.3*
    213 %{_mandir}/man3/uuid_generate.3*
    214 %{_mandir}/man3/uuid_generate_random.3*
    215 %{_mandir}/man3/uuid_generate_time.3*
    216 %{_mandir}/man3/uuid_is_null.3*
    217 %{_mandir}/man3/uuid_parse.3*
    218 %{_mandir}/man3/uuid_time.3*
    219 %{_mandir}/man3/uuid_unparse.3*
    220 
    221 %files -n uuidd
    222 %defattr(-,root,root)
    223 # if you want to run via init
    224 # /etc/init.d/uuidd
    225 %{_mandir}/man8/uuidd.8*
    226 %attr(6755, uuidd, uuidd) %{_sbindir}/uuidd
    227 %dir %attr(2775, uuidd, uuidd) /var/lib/libuuid
    228 
    229