Home | History | Annotate | Download | only in except.spec
      1 // RUN: %clang_cc1 -fcxx-exceptions -fexceptions -verify -std=c++0x %s
      2 struct A { };
      3 struct B { };
      4 struct C { };
      5 
      6 // Destructor
      7 struct X0 {
      8   virtual ~X0() throw(A); // expected-note{{overridden virtual function is here}}
      9 };
     10 struct X1 {
     11   virtual ~X1() throw(B); // expected-note{{overridden virtual function is here}}
     12 };
     13 struct X2 : public X0, public X1 { }; // expected-error 2{{exception specification of overriding function is more lax than base version}}
     14 
     15 // Copy-assignment operator.
     16 struct CA0 {
     17   CA0 &operator=(const CA0&) throw(A);
     18 };
     19 struct CA1 {
     20   CA1 &operator=(const CA1&) throw(B);
     21 };
     22 struct CA2 : CA0, CA1 { };
     23 
     24 void test_CA() {
     25   CA2 &(CA2::*captr1)(const CA2&) throw(A, B) = &CA2::operator=;
     26   CA2 &(CA2::*captr2)(const CA2&) throw(A, B, C) = &CA2::operator=;
     27   CA2 &(CA2::*captr3)(const CA2&) throw(A) = &CA2::operator=; // expected-error{{target exception specification is not superset of source}}
     28   CA2 &(CA2::*captr4)(const CA2&) throw(B) = &CA2::operator=; // expected-error{{target exception specification is not superset of source}}
     29 }
     30 
     31 // In-class member initializers.
     32 struct IC0 {
     33   int inClassInit = 0;
     34 };
     35 struct IC1 {
     36   int inClassInit = (throw B(), 0);
     37 };
     38 // FIXME: the exception specification on the default constructor is wrong:
     39 // we cannot currently compute the set of thrown types.
     40 static_assert(noexcept(IC0()), "IC0() does not throw");
     41 static_assert(!noexcept(IC1()), "IC1() throws");
     42