Home | History | Annotate | Download | only in temp.explicit
      1 // RUN: %clang_cc1 -fsyntax-only -std=c++0x -verify %s
      2 
      3 template<typename T>
      4 struct X {
      5   void f() {}
      6 };
      7 
      8 template inline void X<int>::f(); // expected-error{{'inline'}}
      9 
     10 // FIXME: test constexpr
     11