Home | History | Annotate | Download | only in temp.deduct.partial
      1 // RUN: %clang_cc1 -std=c++11 -fsyntax-only -verify %s
      2 
      3 // Note: Partial ordering of function templates containing template
      4 // parameter packs is independent of the number of deduced arguments
      5 // for those template parameter packs.
      6 template<class ...> struct Tuple { };
      7 template<class ... Types> int &g(Tuple<Types ...>); // #1
      8 template<class T1, class ... Types> float &g(Tuple<T1, Types ...>); // #2
      9 template<class T1, class ... Types> double &g(Tuple<T1, Types& ...>); // #3
     10 
     11 void test_g() {
     12   int &ir1 = g(Tuple<>());
     13   float &fr1 = g(Tuple<int, float>());
     14   double &dr1 = g(Tuple<int, float&>());
     15   double &dr2 = g(Tuple<int>());
     16 }
     17 
     18 template<class ... Types> int &h(int (*)(Types ...)); // #1
     19 template<class T1, class ... Types> float &h(int (*)(T1, Types ...)); // #2
     20 template<class T1, class ... Types> double &h(int (*)(T1, Types& ...)); // #3
     21 
     22 void test_h() {
     23   int &ir1 = h((int(*)())0);
     24   float &fr1 = h((int(*)(int, float))0);
     25   double &dr1 = h((int(*)(int, float&))0);
     26   double &dr2 = h((int(*)(int))0);
     27 }
     28