Home | History | Annotate | Download | only in strace
      1 Summary: Tracks and displays system calls associated with a running process.
      2 Name: strace
      3 Version: 4.5.12
      4 Release: 1
      5 License: BSD
      6 Group: Development/Debuggers
      7 URL: http://sourceforge.net/projects/strace/
      8 Source0: %{name}-%{version}.tar.bz2
      9 BuildRoot: %{_tmppath}/%{name}-root
     10 
     11 %define strace64_arches ppc64
     12 
     13 %description
     14 The strace program intercepts and records the system calls called and
     15 received by a running process.  Strace can print a record of each
     16 system call, its arguments and its return value.  Strace is useful for
     17 diagnosing problems and debugging, as well as for instructional
     18 purposes.
     19 
     20 Install strace if you need a tool to track the system calls made and
     21 received by a process.
     22 
     23 %ifarch %{strace64_arches}
     24 %package -n strace64
     25 Summary: Tracks and displays system calls associated with a running process.
     26 Group: Development/Debuggers
     27 
     28 %description -n strace64
     29 The strace program intercepts and records the system calls called and
     30 received by a running process.  Strace can print a record of each
     31 system call, its arguments and its return value.  Strace is useful for
     32 diagnosing problems and debugging, as well as for instructional
     33 purposes.
     34 
     35 Install strace if you need a tool to track the system calls made and
     36 received by a process.
     37 
     38 This package provides the `strace64' program to trace 64-bit processes.
     39 The `strace' program in the `strace' package is for 32-bit processes.
     40 %endif
     41 
     42 %prep
     43 %setup -q
     44 
     45 %build
     46 %configure
     47 make
     48 
     49 %install
     50 rm -rf %{buildroot}
     51 mkdir -p %{buildroot}%{_mandir}/man1
     52 mkdir -p %{buildroot}%{_bindir}
     53 %makeinstall man1dir=%{buildroot}%{_mandir}/man1
     54 
     55 # remove unpackaged files from the buildroot
     56 rm -f %{buildroot}%{_bindir}/strace-graph
     57 
     58 %ifarch %{strace64_arches}
     59 ln %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
     60 %endif
     61 
     62 %clean
     63 rm -rf %{buildroot}
     64 
     65 %files
     66 %defattr(-,root,root)
     67 %{_bindir}/strace
     68 %{_mandir}/man1/*
     69 
     70 %ifarch %{strace64_arches}
     71 %files -n strace64
     72 %defattr(-,root,root)
     73 %{_bindir}/strace64
     74 %endif
     75 
     76 
     77 %changelog
     78 * Wed Jun  8 2005 Roland McGrath <roland (at] redhat.com> - 4.5.12-1
     79 - Fix known syscall recognition for IA32 processes on x86-64 (#158934).
     80 - Fix bad output for ptrace on x86-64 (#159787).
     81 - Fix potential buffer overruns (#151570, #159196).
     82 - Make some diagnostics more consistent (#159308).
     83 - Update PowerPC system calls.
     84 - Better printing for Linux aio system calls.
     85 - Don't truncate statfs64 fields to 32 bits in output (#158243).
     86 - Cosmetic code cleanups (#159688).
     87 
     88 * Tue Mar 22 2005 Roland McGrath <roland@redhat.com> - 4.5.11-1
     89 - Build tweaks.
     90 - Note 4.5.10 select fix (#151570).
     91 
     92 * Mon Mar 14 2005 Roland McGrath <roland@redhat.com> - 4.5.10-1
     93 - Fix select handling on nonstandard fd_set sizes.
     94 - Don't print errors for null file name pointers.
     95 - Fix initial execve output with -i (#143365).
     96 
     97 * Fri Feb  4 2005 Roland McGrath <roland (at] redhat.com> - 4.5.9-2
     98 - update ia64 syscall list (#146245)
     99 - fix x86_64 syscall argument extraction for 32-bit processes (#146093)
    100 - fix -e signal=NAME parsing (#143362)
    101 - fix x86_64 exit_group syscall handling
    102 - improve socket ioctl printing (#138223)
    103 - code cleanups (#143369, #143370)
    104 - improve mount flags printing (#141932)
    105 - support symbolic printing of x86_64 arch_prctl parameters (#142667)
    106 - fix potential crash in getxattr printing
    107 
    108 * Tue Oct 19 2004 Roland McGrath <roland (at] redhat.com> - 4.5.8-1
    109 - fix multithreaded exit handling (#132150, #135254)
    110 - fix ioctl name matching (#129808)
    111 - print RTC_* ioctl structure contents (#58606)
    112 - grok epoll_* syscalls (#134463)
    113 - grok new RLIMIT_* values (#133594)
    114 - print struct cmsghdr contents for sendmsg (#131689)
    115 - fix clock_* and timer_* argument output (#131420)
    116 
    117 * Tue Aug 31 2004 Roland McGrath <roland (at] redhat.com> - 4.5.7-2
    118 - new upstream version, misc fixes and updates (#128091, #129166, #128391, #129378, #130965, #131177)
    119 
    120 * Mon Jul 12 2004 Roland McGrath <roland (at] redhat.com> 4.5.6-1
    121 - new upstream version, updates ioctl lists (#127398), fixes quotactl (#127393), more ioctl decoding (#126917)
    122 
    123 * Sun Jun 27 2004 Roland McGrath <roland (at] redhat.com> 4.5.5-1
    124 - new upstream version, fixes x86-64 biarch support (#126547)
    125 
    126 * Tue Jun 15 2004 Elliot Lee <sopwith (at] redhat.com> 4.5.4-2
    127 - rebuilt
    128 
    129 * Thu Jun  3 2004 Roland McGrath <roland (at] redhat.com> 4.5.4-0.FC1
    130 - rebuilt for FC1 update
    131 
    132 * Thu Jun  3 2004 Roland McGrath <roland (at] redhat.com> 4.5.4-1
    133 - new upstream version, more ioctls (#122257), minor fixes
    134 
    135 * Fri Apr 16 2004 Roland McGrath <roland (at] redhat.com> 4.5.3-1
    136 - new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685)
    137 
    138 * Tue Mar 02 2004 Elliot Lee <sopwith (at] redhat.com> 4.5.2-1.1
    139 - rebuilt
    140 
    141 * Mon Mar  1 2004 Roland McGrath <roland (at] redhat.com> 4.5.2-1
    142 - new upstream version, sched_* calls (#116990), show core flag (#112117)
    143 
    144 * Fri Feb 13 2004 Elliot Lee <sopwith (at] redhat.com>
    145 - rebuilt
    146 
    147 * Thu Nov 13 2003 Roland McGrath <roland (at] redhat.com> 4.5.1-1
    148 - new upstream version, more fixes (#108012, #105366, #105359, #105358)
    149 
    150 * Tue Sep 30 2003 Roland McGrath <roland (at] redhat.com> 4.5-3
    151 - revert bogus s390 fix
    152 
    153 * Thu Sep 25 2003 Roland McGrath <roland (at] redhat.com> 4.5-1.2.1AS
    154 - rebuilt for 2.1AS erratum
    155 
    156 * Wed Sep 24 2003 Roland McGrath <roland (at] redhat.com> 4.5-2
    157 - rebuilt
    158 
    159 * Wed Sep 24 2003 Roland McGrath <roland (at] redhat.com> 4.5-1
    160 - new upstream version, more fixes (#101499, #104365)
    161 
    162 * Thu Jul 17 2003 Roland McGrath <roland (at] redhat.com> 4.4.99-2
    163 - rebuilt
    164 
    165 * Thu Jul 17 2003 Roland McGrath <roland (at] redhat.com> 4.4.99-1
    166 - new upstream version, groks more new system calls, PF_INET6 sockets
    167 
    168 * Mon Jun 10 2003 Roland McGrath <roland (at] redhat.com> 4.4.98-1
    169 - new upstream version, more fixes (#90754, #91085)
    170 
    171 * Wed Jun 04 2003 Elliot Lee <sopwith (at] redhat.com>
    172 - rebuilt
    173 
    174 * Sun Mar 30 2003 Roland McGrath <roland (at] redhat.com> 4.4.96-1
    175 - new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
    176 
    177 * Mon Feb 24 2003 Elliot Lee <sopwith (at] redhat.com> 4.4.95-2
    178 - rebuilt
    179 
    180 * Mon Feb 24 2003 Roland McGrath <roland (at] redhat.com> 4.4.95-1
    181 - new upstream version, fixed getresuid/getresgid (#84959)
    182 
    183 * Wed Feb 19 2003 Roland McGrath <roland (at] redhat.com> 4.4.94-1
    184 - new upstream version, new option -E to set environment variables (#82392)
    185 
    186 * Wed Jan 22 2003 Tim Powers <timp (at] redhat.com> 4.4.93-2
    187 - rebuilt
    188 
    189 * Tue Jan 21 2003 Roland McGrath <roland (at] redhat.com> 4.4.93-1
    190 - new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
    191 
    192 * Fri Jan 10 2003 Roland McGrath <roland (at] redhat.com> 4.4.91-1
    193 - new upstream version, fixes -f on x86-64
    194 
    195 * Fri Jan 10 2003 Roland McGrath <roland (at] redhat.com> 4.4.90-1
    196 - new upstream version, fixes all known bugs modulo ia64 and s390 issues
    197 
    198 * Fri Jan 03 2003 Florian La Roche <Florian.LaRoche (at] redhat.de> 4.4-11
    199 - add further s390 patch from IBM
    200 
    201 * Wed Nov 27 2002 Tim Powers <timp (at] redhat.com> 4.4-10
    202 - remove unpackaged files from the buildroot
    203 
    204 * Mon Oct 07 2002 Phil Knirsch <pknirsch (at] redhat.com> 4.4-9.1
    205 - Added latest s390(x) patch.
    206 
    207 * Fri Sep 06 2002 Karsten Hopp <karsten (at] redhat.de> 4.4-9
    208 - preliminary x86_64 support with an ugly patch to help
    209   debugging. Needs cleanup!
    210 
    211 * Mon Sep  2 2002 Jakub Jelinek <jakub (at] redhat.com> 4.4-8
    212 - newer version of the clone fixing patch (Roland McGrath)
    213 - aio syscalls for i386/ia64/ppc (Ben LaHaise)
    214 
    215 * Wed Aug 28 2002 Jakub Jelinek <jakub (at] redhat.com> 4.4-7
    216 - fix strace -f (Roland McGrath, #68994)
    217 - handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
    218 
    219 * Fri Jun 21 2002 Jakub Jelinek <jakub (at] redhat.com> 4.4-6
    220 - handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
    221 - handle modify_ldt (#66894)
    222 
    223 * Thu May 23 2002 Tim Powers <timp (at] redhat.com>
    224 - automated rebuild
    225 
    226 * Tue Apr 16 2002 Jakub Jelinek <jakub (at] redhat.com> 4.4-4
    227 - fix for the last patch by Jeff Law (#62591)
    228 
    229 * Mon Mar  4 2002 Preston Brown <pbrown (at] redhat.com> 4.4-3
    230 - integrate patch from Jeff Law to eliminate hang tracing threads
    231 
    232 * Sat Feb 23 2002 Florian La Roche <Florian.LaRoche (at] redhat.de>
    233 - minor update from debian tar-ball
    234 
    235 * Wed Jan 02 2002 Florian La Roche <Florian.LaRoche (at] redhat.de>
    236 - update to 4.4
    237 
    238 * Sun Jul 22 2001 Florian La Roche <Florian.LaRoche (at] redhat.de>
    239 - disable s390 patches, they are already included
    240 
    241 * Wed Jul 18 2001 Preston Brown <pbrown (at] redhat.com> 4.3-1
    242 - new upstream version.  Seems to have integrated most new syscalls
    243 - tracing threaded programs is now functional.
    244 
    245 * Mon Jun 11 2001 Than Ngo <than (at] redhat.com>
    246 - port s390 patches from IBM
    247 
    248 * Wed May 16 2001 Nalin Dahyabhai <nalin (at] redhat.com>
    249 - modify new syscall patch to allocate enough heap space in setgroups32()
    250 
    251 * Wed Feb 14 2001 Jakub Jelinek <jakub (at] redhat.com>
    252 - #include <time.h> in addition to <sys/time.h>
    253 
    254 * Fri Jan 26 2001 Karsten Hopp <karsten (at] redhat.com>
    255 - clean up conflicting patches. This happened only
    256   when building on S390
    257 
    258 * Fri Jan 19 2001 Bill Nottingham <notting (at] redhat.com>
    259 - update to CVS, reintegrate ia64 support
    260 
    261 * Sat Dec  8 2000 Bernhard Rosenkraenzer <bero (at] redhat.com>
    262 - Get S/390 support into the normal package
    263 
    264 * Sat Nov 18 2000 Florian La Roche <Florian.LaRoche (at] redhat.de>
    265 - added S/390 patch from IBM, adapting it to not conflict with
    266   IA64 patch
    267 
    268 * Sat Aug 19 2000 Jakub Jelinek <jakub (at] redhat.com>
    269 - doh, actually apply the 2.4 syscalls patch
    270 - make it compile with 2.4.0-test7-pre4+ headers, add
    271   getdents64 and fcntl64
    272 
    273 * Thu Aug  3 2000 Jakub Jelinek <jakub (at] redhat.com>
    274 - add a bunch of new 2.4 syscalls (#14036)
    275 
    276 * Wed Jul 12 2000 Prospector <bugzilla (at] redhat.com>
    277 - automatic rebuild
    278 - excludearch ia64
    279 
    280 * Fri Jun  2 2000 Matt Wilson <msw (at] redhat.com>
    281 - use buildinstall for FHS
    282 
    283 * Wed May 24 2000 Jakub Jelinek <jakub (at] redhat.com>
    284 - make things compile on sparc
    285 - fix sigreturn on sparc
    286 
    287 * Fri Mar 31 2000 Bill Nottingham <notting (at] redhat.com>
    288 - fix stat64 misdef (#10485)
    289 
    290 * Tue Mar 21 2000 Michael K. Johnson <johnsonm (at] redhat.com>
    291 - added ia64 patch
    292 
    293 * Thu Feb 03 2000 Cristian Gafton <gafton (at] redhat.com>
    294 - man pages are compressed
    295 - version 4.2 (why are we keeping all these patches around?)
    296 
    297 * Sat Nov 27 1999 Jeff Johnson <jbj (at] redhat.com>
    298 - update to 4.1 (with sparc socketcall patch).
    299 
    300 * Fri Nov 12 1999 Jakub Jelinek <jakub (at] redhat.com>
    301 - fix socketcall on sparc.
    302 
    303 * Thu Sep 02 1999 Cristian Gafton <gafton (at] redhat.com>
    304 - fix KERN_SECURELVL compile problem
    305 
    306 * Tue Aug 31 1999 Cristian Gafton <gafton (at] redhat.com>
    307 - added alpha patch from HJLu to fix the osf_sigprocmask interpretation
    308 
    309 * Sat Jun 12 1999 Jeff Johnson <jbj (at] redhat.com>
    310 - update to 3.99.1.
    311 
    312 * Wed Jun  2 1999 Jeff Johnson <jbj (at] redhat.com>
    313 - add (the other :-) jj's sparc patch.
    314 
    315 * Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
    316 - upgrade to 3.99 in order to
    317 -    add new 2.2.x open flags (#2955).
    318 -    add new 2.2.x syscalls (#2866).
    319 - strace 3.1 patches carried along for now.
    320 
    321 * Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
    322 - don't rely on (broken!) rpm %patch (#2735)
    323 
    324 * Tue Apr 06 1999 Preston Brown <pbrown (at] redhat.com>
    325 - strip binary
    326 
    327 * Sun Mar 21 1999 Cristian Gafton <gafton (at] redhat.com>
    328 - auto rebuild in the new build environment (release 16)
    329 
    330 * Tue Feb  9 1999 Jeff Johnson <jbj (at] redhat.com>
    331 - vfork est arrive!
    332 
    333 * Tue Feb  9 1999 Christopher Blizzard <blizzard (at] redhat.com>
    334 - Add patch to follow clone() syscalls, too.
    335 
    336 * Sun Jan 17 1999 Jeff Johnson <jbj (at] redhat.com>
    337 - patch to build alpha/sparc with glibc 2.1.
    338 
    339 * Thu Dec 03 1998 Cristian Gafton <gafton (at] redhat.com>
    340 - patch to build on ARM
    341 
    342 * Wed Sep 30 1998 Jeff Johnson <jbj (at] redhat.com>
    343 - fix typo (printf, not tprintf).
    344 
    345 * Sat Sep 19 1998 Jeff Johnson <jbj (at] redhat.com>
    346 - fix compile problem on sparc.
    347 
    348 * Tue Aug 18 1998 Cristian Gafton <gafton (at] redhat.com>
    349 - buildroot
    350 
    351 * Mon Jul 20 1998 Cristian Gafton <gafton (at] redhat.com>
    352 - added the umoven patch from James Youngman <jay (at] gnu.org>
    353 - fixed build problems on newer glibc releases
    354 
    355 * Mon Jun 08 1998 Prospector System <bugs (at] redhat.com>
    356 - translations modified for de, fr, tr
    357