Home | History | Annotate | Download | only in temp.deduct.type
      1 // RUN: %clang_cc1 -std=c++11 -fsyntax-only -verify %s
      2 
      3 // FIXME: More bullets to go!
      4 
      5 template<typename T, typename U>
      6 struct has_nondeduced_pack_test {
      7   static const bool value = false;
      8 };
      9 
     10 template<typename R, typename FirstType, typename ...Types>
     11 struct has_nondeduced_pack_test<R(FirstType, Types..., int),
     12                                 R(FirstType, Types...)> {
     13   static const bool value = true;
     14 };
     15 
     16 // - A function parameter pack that does not occur at the end of the
     17 //   parameter-declaration-clause.
     18 int check_nondeduced_pack_test0[
     19                    has_nondeduced_pack_test<int(float, double, int),
     20                                             int(float, double)>::value? 1 : -1];
     21 
     22 
     23