Home | History | Annotate | Download | only in temp.arg.explicit
      1 // RUN: %clang_cc1 -fsyntax-only %s
      2 
      3 template<typename T> struct A { };
      4 
      5 template<typename T> T make();
      6 template<typename T> T make2(const T&);
      7 
      8 void test_make() {
      9   int& ir0 = make<int&>();
     10   A<int> a0 = make< A<int> >();
     11   A<int> a1 = make2< A<int> >(A<int>());
     12 }
     13