Home | History | Annotate | Download | only in temp.deduct.partial
      1 // RUN: %clang_cc1 -std=c++11 -fsyntax-only -verify %s
      2 
      3 template<typename T> int &f0(T&);
      4 template<typename T> float &f0(T&&);
      5 
      6 // Core issue 1164
      7 void test_f0(int i) {
      8   int &ir0 = f0(i);
      9   float &fr0 = f0(5);
     10 }
     11