Home | History | Annotate | Download | only in strace
      1 Summary: Tracks and displays system calls associated with a running process
      2 Name: strace
      3 Version: 4.6
      4 Release: 1%{?dist}
      5 License: BSD
      6 Group: Development/Debuggers
      7 URL: http://sourceforge.net/projects/strace/
      8 Source: http://downloads.sourceforge.net/strace/%{name}-%{version}.tar.xz
      9 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
     10 
     11 BuildRequires: libacl-devel, libaio-devel, time
     12 
     13 %define strace64_arches ppc64 sparc64
     14 
     15 %description
     16 The strace program intercepts and records the system calls called and
     17 received by a running process.  Strace can print a record of each
     18 system call, its arguments and its return value.  Strace is useful for
     19 diagnosing problems and debugging, as well as for instructional
     20 purposes.
     21 
     22 Install strace if you need a tool to track the system calls made and
     23 received by a process.
     24 
     25 %ifarch %{strace64_arches}
     26 %package -n strace64
     27 Summary: Tracks and displays system calls associated with a running process.
     28 Group: Development/Debuggers
     29 
     30 %description -n strace64
     31 The strace program intercepts and records the system calls called and
     32 received by a running process.  Strace can print a record of each
     33 system call, its arguments and its return value.  Strace is useful for
     34 diagnosing problems and debugging, as well as for instructional
     35 purposes.
     36 
     37 Install strace if you need a tool to track the system calls made and
     38 received by a process.
     39 
     40 This package provides the `strace64' program to trace 64-bit processes.
     41 The `strace' program in the `strace' package is for 32-bit processes.
     42 %endif
     43 
     44 %prep
     45 %setup -q
     46 
     47 %build
     48 %configure
     49 make %{?_smp_mflags}
     50 
     51 %install
     52 rm -rf %{buildroot}
     53 make DESTDIR=%{buildroot} install
     54 
     55 # remove unpackaged files from the buildroot
     56 rm -f %{buildroot}%{_bindir}/strace-graph
     57 
     58 %define copy64 ln
     59 %if 0%{?rhel}
     60 %if 0%{?rhel} < 6
     61 %endif
     62 %define copy64 cp -p
     63 %endif
     64 
     65 %ifarch %{strace64_arches}
     66 %{copy64} %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
     67 %endif
     68 
     69 %check
     70 make check
     71 
     72 %clean
     73 rm -rf %{buildroot}
     74 
     75 %files
     76 %defattr(-,root,root)
     77 %doc CREDITS ChangeLog ChangeLog-CVS COPYRIGHT NEWS PORTING README
     78 %{_bindir}/strace
     79 %{_mandir}/man1/*
     80 
     81 %ifarch %{strace64_arches}
     82 %files -n strace64
     83 %defattr(-,root,root)
     84 %{_bindir}/strace64
     85 %endif
     86 
     87 %changelog
     88 * Mon Mar 14 2011 Dmitry V. Levin <ldv (at] altlinux.org> - 4.6-1
     89 - New upstream release.
     90   + fixed a corner case in waitpid handling (#663547).
     91 
     92 * Wed Feb 09 2011 Fedora Release Engineering <rel-eng (at] lists.fedoraproject.org> - 4.5.20-2
     93 - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
     94 
     95 * Tue Apr 13 2010 Roland McGrath <roland (at] redhat.com> - 4.5.20-1
     96 - New upstream release, work mostly by Andreas Schwab and Dmitry V. Levin.
     97   + fixed potential stack buffer overflow in select decoder (#556678);
     98   + fixed FTBFS (#539044).
     99 
    100 * Wed Oct 21 2009 Roland McGrath <roland (at] redhat.com> - 4.5.19-1
    101 - New upstream release, work mostly by Dmitry V. Levin <ldv (at] altlinux.org>
    102   + exit/kill strace with traced process exitcode/signal (#105371);
    103   + fixed build on ARM EABI (#507576);
    104   + fixed display of 32-bit argv array on 64-bit architectures (#519480);
    105   + fixed display of 32-bit fcntl(F_SETLK) on 64-bit architectures (#471169);
    106   + fixed several bugs in strings decoder, including potential heap
    107     memory corruption (#470529, #478324, #511035).
    108 
    109 * Thu Aug 28 2008 Roland McGrath <roland (at] redhat.com> - 4.5.18-1
    110 - build fix for newer kernel headers (#457291)
    111 - fix CLONE_VFORK handling (#455078)
    112 - Support new Linux/PPC system call subpage_prot and PROT_SAO flag.
    113 - In sigaction system call, display sa_flags value along with SIG_DFL/SIG_IGN.
    114 
    115 * Mon Jul 21 2008 Roland McGrath <roland (at] redhat.com> - 4.5.17-1
    116 - handle O_CLOEXEC, MSG_CMSG_CLOEXEC (#365781)
    117 - fix biarch stat64 decoding (#222275)
    118 - fix spurious "..." in printing of environment strings (#358241)
    119 - improve prctl decoding (#364401)
    120 - fix hang wait on exited child with exited child (#354261)
    121 - fix biarch fork/vfork (-f) tracing (#447475)
    122 - fix biarch printing of negative argument kill (#430585)
    123 - fix biarch decoding of error return values (#447587)
    124 - fix -f tracing of CLONE_VFORK (#455078)
    125 - fix ia64 register clobberation in -f tracing (#453438)
    126 - print SO_NODEFER, SA_RESETHAND instead of SA_NOMASK, SA_ONESHOT (#455821)
    127 - fix futex argument decoding (#448628, #448629)
    128 
    129 * Fri Aug  3 2007 Roland McGrath <roland (at] redhat.com> - 4.5.16-1
    130 - fix multithread issues (#240962, #240961, #247907)
    131 - fix spurious SIGSTOP on early interrupt (#240986)
    132 - fix utime for biarch (#247185)
    133 - fix -u error message (#247170)
    134 - better futex syscall printing (##241467)
    135 - fix argv/envp printing with small -s settings, and for biarch
    136 - new syscalls: getcpu, eventfd, timerfd, signalfd, epoll_pwait,
    137   move_pages, utimensat
    138 
    139 * Tue Jan 16 2007 Roland McGrath <roland (at] redhat.com> - 4.5.15-1
    140 - biarch fixes (#179740, #192193, #171626, #173050, #218433, #218043)
    141 - fix -ff -o behavior (#204950, #218435, #193808, #219423)
    142 - better quotactl printing (#118696)
    143 - *at, inotify*, pselect6, ppoll and unshare syscalls (#178633, #191275)
    144 - glibc-2.5 build fixes (#209856)
    145 - memory corruption fixes (#200621
    146 - fix race in child setup under -f (#180293)
    147 - show ipc key values in hex (#198179, #192182)
    148 - disallow -c with -ff (#187847)
    149 - Resolves: RHBZ #179740, RHBZ #192193, RHBZ #204950, RHBZ #218435
    150 - Resolves: RHBZ #193808, RHBZ #219423, RHBZ #171626, RHBZ #173050
    151 - Resolves: RHBZ #218433, RHBZ #218043, RHBZ #118696, RHBZ #178633
    152 - Resolves: RHBZ #191275, RHBZ #209856, RHBZ #200621, RHBZ #180293
    153 - Resolves: RHBZ #198179, RHBZ #198182, RHBZ #187847
    154 
    155 * Mon Nov 20 2006 Jakub Jelinek <jakub (at] redhat.com> - 4.5.14-4
    156 - Fix ia64 syscall decoding (#206768)
    157 - Fix build with glibc-2.4.90-33 and up on all arches but ia64
    158 - Fix build against 2.6.18+ headers
    159 
    160 * Tue Aug 22 2006 Roland McGrath <roland (at] redhat.com> - 4.5.14-3
    161 - Fix bogus decoding of syscalls >= 300 (#201462, #202620).
    162 
    163 * Fri Jul 14 2006 Jesse Keating <jkeating (at] redhat.com> - 4.5.14-2
    164 - rebuild
    165 
    166 * Fri Feb 10 2006 Jesse Keating <jkeating (at] redhat.com> - 4.5.14-1.2
    167 - bump again for long double bug on ppc{,64}
    168 
    169 * Tue Feb 07 2006 Jesse Keating <jkeating (at] redhat.com> - 4.5.14-1.1
    170 - rebuilt for new gcc4.1 snapshot and glibc changes
    171 
    172 * Mon Jan 16 2006 Roland McGrath <roland (at] redhat.com> - 4.5.14-1
    173 - Fix biarch decoding of socket syscalls (#174354).
    174 - Fix biarch -e support (#173986).
    175 - Accept numeric syscalls in -e (#174798).
    176 - Fix ipc syscall decoding (#164755).
    177 - Improve msgrcv printing (#164757).
    178 - Man page updates (#165375).
    179 - Improve mount syscall printing (#165377).
    180 - Correct printing of restarting syscalls (#165469).
    181 
    182 * Wed Aug  3 2005 Roland McGrath <roland (at] redhat.com> - 4.5.13-1
    183 - Fix setsockopt decoding on 64-bit (#162449).
    184 - Fix typos in socket option name strings (#161578).
    185 - Display more IPV6 socket options by name (#162450).
    186 - Don't display inappropriate syscalls for -e trace=file (#159340).
    187 - New selector type -e trace=desc for file-descriptor using calls (#159400).
    188 - Fix 32-bit old_mmap syscall decoding on x86-64 (#162467, #164215).
    189 - Fix errors detaching from multithreaded process on interrupt (#161919).
    190 - Note 4.5.12 fix for crash handling bad signal numbers (#162739).
    191 
    192 * Wed Jun  8 2005 Roland McGrath <roland@redhat.com> - 4.5.12-1
    193 - Fix known syscall recognition for IA32 processes on x86-64 (#158934).
    194 - Fix bad output for ptrace on x86-64 (#159787).
    195 - Fix potential buffer overruns (#151570, #159196).
    196 - Make some diagnostics more consistent (#159308).
    197 - Update PowerPC system calls.
    198 - Better printing for Linux aio system calls.
    199 - Don't truncate statfs64 fields to 32 bits in output (#158243).
    200 - Cosmetic code cleanups (#159688).
    201 
    202 * Tue Mar 22 2005 Roland McGrath <roland (at] redhat.com> - 4.5.11-1
    203 - Build tweaks.
    204 - Note 4.5.10 select fix (#151570).
    205 
    206 * Mon Mar 14 2005 Roland McGrath <roland (at] redhat.com> - 4.5.10-1
    207 - Fix select handling on nonstandard fd_set sizes.
    208 - Don't print errors for null file name pointers.
    209 - Fix initial execve output with -i (#143365).
    210 
    211 * Fri Feb  4 2005 Roland McGrath <roland@redhat.com> - 4.5.9-2
    212 - update ia64 syscall list (#146245)
    213 - fix x86_64 syscall argument extraction for 32-bit processes (#146093)
    214 - fix -e signal=NAME parsing (#143362)
    215 - fix x86_64 exit_group syscall handling
    216 - improve socket ioctl printing (#138223)
    217 - code cleanups (#143369, #143370)
    218 - improve mount flags printing (#141932)
    219 - support symbolic printing of x86_64 arch_prctl parameters (#142667)
    220 - fix potential crash in getxattr printing
    221 
    222 * Tue Oct 19 2004 Roland McGrath <roland@redhat.com> - 4.5.8-1
    223 - fix multithreaded exit handling (#132150, #135254)
    224 - fix ioctl name matching (#129808)
    225 - print RTC_* ioctl structure contents (#58606)
    226 - grok epoll_* syscalls (#134463)
    227 - grok new RLIMIT_* values (#133594)
    228 - print struct cmsghdr contents for sendmsg (#131689)
    229 - fix clock_* and timer_* argument output (#131420)
    230 
    231 * Tue Aug 31 2004 Roland McGrath <roland@redhat.com> - 4.5.7-2
    232 - new upstream version, misc fixes and updates (#128091, #129166, #128391, #129378, #130965, #131177)
    233 
    234 * Mon Jul 12 2004 Roland McGrath <roland@redhat.com> 4.5.6-1
    235 - new upstream version, updates ioctl lists (#127398), fixes quotactl (#127393), more ioctl decoding (#126917)
    236 
    237 * Sun Jun 27 2004 Roland McGrath <roland@redhat.com> 4.5.5-1
    238 - new upstream version, fixes x86-64 biarch support (#126547)
    239 
    240 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 4.5.4-2
    241 - rebuilt
    242 
    243 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-0.FC1
    244 - rebuilt for FC1 update
    245 
    246 * Thu Jun  3 2004 Roland McGrath <roland@redhat.com> 4.5.4-1
    247 - new upstream version, more ioctls (#122257), minor fixes
    248 
    249 * Fri Apr 16 2004 Roland McGrath <roland@redhat.com> 4.5.3-1
    250 - new upstream version, mq_* calls (#120701), -p vs NPTL (#120462), more fixes (#118694, #120541, #118685)
    251 
    252 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 4.5.2-1.1
    253 - rebuilt
    254 
    255 * Mon Mar  1 2004 Roland McGrath <roland@redhat.com> 4.5.2-1
    256 - new upstream version, sched_* calls (#116990), show core flag (#112117)
    257 
    258 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
    259 - rebuilt
    260 
    261 * Thu Nov 13 2003 Roland McGrath <roland@redhat.com> 4.5.1-1
    262 - new upstream version, more fixes (#108012, #105366, #105359, #105358)
    263 
    264 * Tue Sep 30 2003 Roland McGrath <roland@redhat.com> 4.5-3
    265 - revert bogus s390 fix
    266 
    267 * Thu Sep 25 2003 Roland McGrath <roland@redhat.com> 4.5-1.2.1AS
    268 - rebuilt for 2.1AS erratum
    269 
    270 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-2
    271 - rebuilt
    272 
    273 * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 4.5-1
    274 - new upstream version, more fixes (#101499, #104365)
    275 
    276 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-2
    277 - rebuilt
    278 
    279 * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
    280 - new upstream version, groks more new system calls, PF_INET6 sockets
    281 
    282 * Mon Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
    283 - new upstream version, more fixes (#90754, #91085)
    284 
    285 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
    286 - rebuilt
    287 
    288 * Sun Mar 30 2003 Roland McGrath <roland@redhat.com> 4.4.96-1
    289 - new upstream version, handles yet more 2.5 syscalls, x86_64 & ia64 fixes
    290 
    291 * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 4.4.95-2
    292 - rebuilt
    293 
    294 * Mon Feb 24 2003 Roland McGrath <roland@redhat.com> 4.4.95-1
    295 - new upstream version, fixed getresuid/getresgid (#84959)
    296 
    297 * Wed Feb 19 2003 Roland McGrath <roland@redhat.com> 4.4.94-1
    298 - new upstream version, new option -E to set environment variables (#82392)
    299 
    300 * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.4.93-2
    301 - rebuilt
    302 
    303 * Tue Jan 21 2003 Roland McGrath <roland@redhat.com> 4.4.93-1
    304 - new upstream version, fixes ppc and s390 bugs, adds missing ptrace requests
    305 
    306 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.91-1
    307 - new upstream version, fixes -f on x86-64
    308 
    309 * Fri Jan 10 2003 Roland McGrath <roland@redhat.com> 4.4.90-1
    310 - new upstream version, fixes all known bugs modulo ia64 and s390 issues
    311 
    312 * Fri Jan 03 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.4-11
    313 - add further s390 patch from IBM
    314 
    315 * Wed Nov 27 2002 Tim Powers <timp@redhat.com> 4.4-10
    316 - remove unpackaged files from the buildroot
    317 
    318 * Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.4-9.1
    319 - Added latest s390(x) patch.
    320 
    321 * Fri Sep 06 2002 Karsten Hopp <karsten@redhat.de> 4.4-9
    322 - preliminary x86_64 support with an ugly patch to help
    323   debugging. Needs cleanup!
    324 
    325 * Mon Sep  2 2002 Jakub Jelinek <jakub@redhat.com> 4.4-8
    326 - newer version of the clone fixing patch (Roland McGrath)
    327 - aio syscalls for i386/ia64/ppc (Ben LaHaise)
    328 
    329 * Wed Aug 28 2002 Jakub Jelinek <jakub@redhat.com> 4.4-7
    330 - fix strace -f (Roland McGrath, #68994)
    331 - handle ?et_thread_area, SA_RESTORER (Ulrich Drepper)
    332 
    333 * Fri Jun 21 2002 Jakub Jelinek <jakub@redhat.com> 4.4-6
    334 - handle futexes, *xattr, sendfile64, etc. (Ulrich Drepper)
    335 - handle modify_ldt (#66894)
    336 
    337 * Thu May 23 2002 Tim Powers <timp@redhat.com>
    338 - automated rebuild
    339 
    340 * Tue Apr 16 2002 Jakub Jelinek <jakub@redhat.com> 4.4-4
    341 - fix for the last patch by Jeff Law (#62591)
    342 
    343 * Mon Mar  4 2002 Preston Brown <pbrown@redhat.com> 4.4-3
    344 - integrate patch from Jeff Law to eliminate hang tracing threads
    345 
    346 * Sat Feb 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
    347 - minor update from debian tar-ball
    348 
    349 * Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
    350 - update to 4.4
    351 
    352 * Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
    353 - disable s390 patches, they are already included
    354 
    355 * Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
    356 - new upstream version.  Seems to have integrated most new syscalls
    357 - tracing threaded programs is now functional.
    358 
    359 * Mon Jun 11 2001 Than Ngo <than@redhat.com>
    360 - port s390 patches from IBM
    361 
    362 * Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
    363 - modify new syscall patch to allocate enough heap space in setgroups32()
    364 
    365 * Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
    366 - #include <time.h> in addition to <sys/time.h>
    367 
    368 * Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
    369 - clean up conflicting patches. This happened only
    370   when building on S390
    371 
    372 * Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
    373 - update to CVS, reintegrate ia64 support
    374 
    375 * Sat Dec  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
    376 - Get S/390 support into the normal package
    377 
    378 * Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
    379 - added S/390 patch from IBM, adapting it to not conflict with
    380   IA64 patch
    381 
    382 * Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
    383 - doh, actually apply the 2.4 syscalls patch
    384 - make it compile with 2.4.0-test7-pre4+ headers, add
    385   getdents64 and fcntl64
    386 
    387 * Thu Aug  3 2000 Jakub Jelinek <jakub@redhat.com>
    388 - add a bunch of new 2.4 syscalls (#14036)
    389 
    390 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
    391 - automatic rebuild
    392 - excludearch ia64
    393 
    394 * Fri Jun  2 2000 Matt Wilson <msw@redhat.com>
    395 - use buildinstall for FHS
    396 
    397 * Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
    398 - make things compile on sparc
    399 - fix sigreturn on sparc
    400 
    401 * Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
    402 - fix stat64 misdef (#10485)
    403 
    404 * Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
    405 - added ia64 patch
    406 
    407 * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
    408 - man pages are compressed
    409 - version 4.2 (why are we keeping all these patches around?)
    410 
    411 * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
    412 - update to 4.1 (with sparc socketcall patch).
    413 
    414 * Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
    415 - fix socketcall on sparc.
    416 
    417 * Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
    418 - fix KERN_SECURELVL compile problem
    419 
    420 * Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
    421 - added alpha patch from HJLu to fix the osf_sigprocmask interpretation
    422 
    423 * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
    424 - update to 3.99.1.
    425 
    426 * Wed Jun  2 1999 Jeff Johnson <jbj@redhat.com>
    427 - add (the other :-) jj's sparc patch.
    428 
    429 * Wed May 26 1999 Jeff Johnson <jbj (at] redhat.com>
    430 - upgrade to 3.99 in order to
    431 -    add new 2.2.x open flags (#2955).
    432 -    add new 2.2.x syscalls (#2866).
    433 - strace 3.1 patches carried along for now.
    434 
    435 * Sun May 16 1999 Jeff Johnson <jbj (at] redhat.com>
    436 - don't rely on (broken!) rpm %%patch (#2735)
    437 
    438 * Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
    439 - strip binary
    440 
    441 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
    442 - auto rebuild in the new build environment (release 16)
    443 
    444 * Tue Feb  9 1999 Jeff Johnson <jbj@redhat.com>
    445 - vfork est arrive!
    446 
    447 * Tue Feb  9 1999 Christopher Blizzard <blizzard@redhat.com>
    448 - Add patch to follow clone() syscalls, too.
    449 
    450 * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
    451 - patch to build alpha/sparc with glibc 2.1.
    452 
    453 * Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
    454 - patch to build on ARM
    455 
    456 * Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
    457 - fix typo (printf, not tprintf).
    458 
    459 * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
    460 - fix compile problem on sparc.
    461 
    462 * Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
    463 - buildroot
    464 
    465 * Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
    466 - added the umoven patch from James Youngman <jay@gnu.org>
    467 - fixed build problems on newer glibc releases
    468 
    469 * Mon Jun 08 1998 Prospector System <bugs@redhat.com>
    470 - translations modified for de, fr, tr
    471