Home | History | Annotate | Download | only in gles11
      1 void glActiveTexture ( GLenum texture )
      2 void glAlphaFunc ( GLenum func, GLclampf ref )
      3 void glAlphaFuncx ( GLenum func, GLclampx ref )
      4 void glBindTexture ( GLenum target, GLuint texture )
      5 void glBlendFunc ( GLenum sfactor, GLenum dfactor )
      6 void glClear ( GLbitfield mask )
      7 void glClearColor ( GLclampf red, GLclampf green, GLclampf blue, GLclampf alpha )
      8 void glClearColorx ( GLclampx red, GLclampx green, GLclampx blue, GLclampx alpha )
      9 void glClearDepthf ( GLclampf depth )
     10 void glClearDepthx ( GLclampx depth )
     11 void glClearStencil ( GLint s )
     12 void glClientActiveTexture ( GLenum texture )
     13 void glColor4f ( GLfloat red, GLfloat green, GLfloat blue, GLfloat alpha )
     14 void glColor4x ( GLfixed red, GLfixed green, GLfixed blue, GLfixed alpha )
     15 void glColorMask ( GLboolean red, GLboolean green, GLboolean blue, GLboolean alpha )
     16 void glColorPointer ( GLint size, GLenum type, GLsizei stride, const GLvoid *pointer )
     17 void glCompressedTexImage2D ( GLenum target, GLint level, GLenum internalformat, GLsizei width, GLsizei height, GLint border, GLsizei imageSize, const GLvoid *data )
     18 void glCompressedTexSubImage2D ( GLenum target, GLint level, GLint xoffset, GLint yoffset, GLsizei width, GLsizei height, GLenum format, GLsizei imageSize, const GLvoid *data )
     19 void glCopyTexImage2D ( GLenum target, GLint level, GLenum internalformat, GLint x, GLint y, GLsizei width, GLsizei height, GLint border )
     20 void glCopyTexSubImage2D ( GLenum target, GLint level, GLint xoffset, GLint yoffset, GLint x, GLint y, GLsizei width, GLsizei height )
     21 void glCullFace ( GLenum mode )
     22 void glDeleteTextures ( GLsizei n, const GLuint *textures )
     23 void glDepthFunc ( GLenum func )
     24 void glDepthMask ( GLboolean flag )
     25 void glDepthRangef ( GLclampf zNear, GLclampf zFar )
     26 void glDepthRangex ( GLclampx zNear, GLclampx zFar )
     27 void glDisable ( GLenum cap )
     28 void glDisableClientState ( GLenum array )
     29 void glDrawArrays ( GLenum mode, GLint first, GLsizei count )
     30 void glDrawElements ( GLenum mode, GLsizei count, GLenum type, const GLvoid *indices )
     31 void glEnable ( GLenum cap )
     32 void glEnableClientState ( GLenum array )
     33 void glFinish ( void )
     34 void glFlush ( void )
     35 void glFogf ( GLenum pname, GLfloat param )
     36 void glFogfv ( GLenum pname, const GLfloat *params )
     37 void glFogx ( GLenum pname, GLfixed param )
     38 void glFogxv ( GLenum pname, const GLfixed *params )
     39 void glFrontFace ( GLenum mode )
     40 void glFrustumf ( GLfloat left, GLfloat right, GLfloat bottom, GLfloat top, GLfloat zNear, GLfloat zFar )
     41 void glFrustumx ( GLfixed left, GLfixed right, GLfixed bottom, GLfixed top, GLfixed zNear, GLfixed zFar )
     42 void glGenTextures ( GLsizei n, GLuint *textures )
     43 GLenum glGetError ( void )
     44 void glGetIntegerv ( GLenum pname, GLint *params )
     45 const GLubyte * glGetString ( GLenum name )
     46 void glHint ( GLenum target, GLenum mode )
     47 void glLightModelf ( GLenum pname, GLfloat param )
     48 void glLightModelfv ( GLenum pname, const GLfloat *params )
     49 void glLightModelx ( GLenum pname, GLfixed param )
     50 void glLightModelxv ( GLenum pname, const GLfixed *params )
     51 void glLightf ( GLenum light, GLenum pname, GLfloat param )
     52 void glLightfv ( GLenum light, GLenum pname, const GLfloat *params )
     53 void glLightx ( GLenum light, GLenum pname, GLfixed param )
     54 void glLightxv ( GLenum light, GLenum pname, const GLfixed *params )
     55 void glLineWidth ( GLfloat width )
     56 void glLineWidthx ( GLfixed width )
     57 void glLoadIdentity ( void )
     58 void glLoadMatrixf ( const GLfloat *m )
     59 void glLoadMatrixx ( const GLfixed *m )
     60 void glLogicOp ( GLenum opcode )
     61 void glMaterialf ( GLenum face, GLenum pname, GLfloat param )
     62 void glMaterialfv ( GLenum face, GLenum pname, const GLfloat *params )
     63 void glMaterialx ( GLenum face, GLenum pname, GLfixed param )
     64 void glMaterialxv ( GLenum face, GLenum pname, const GLfixed *params )
     65 void glMatrixMode ( GLenum mode )
     66 void glMultMatrixf ( const GLfloat *m )
     67 void glMultMatrixx ( const GLfixed *m )
     68 void glMultiTexCoord4f ( GLenum target, GLfloat s, GLfloat t, GLfloat r, GLfloat q )
     69 void glMultiTexCoord4x ( GLenum target, GLfixed s, GLfixed t, GLfixed r, GLfixed q )
     70 void glNormal3f ( GLfloat nx, GLfloat ny, GLfloat nz )
     71 void glNormal3x ( GLfixed nx, GLfixed ny, GLfixed nz )
     72 void glNormalPointer ( GLenum type, GLsizei stride, const GLvoid *pointer )
     73 void glOrthof ( GLfloat left, GLfloat right, GLfloat bottom, GLfloat top, GLfloat zNear, GLfloat zFar )
     74 void glOrthox ( GLfixed left, GLfixed right, GLfixed bottom, GLfixed top, GLfixed zNear, GLfixed zFar )
     75 void glPixelStorei ( GLenum pname, GLint param )
     76 void glPointSize ( GLfloat size )
     77 void glPointSizex ( GLfixed size )
     78 void glPolygonOffset ( GLfloat factor, GLfloat units )
     79 void glPolygonOffsetx ( GLfixed factor, GLfixed units )
     80 void glPopMatrix ( void )
     81 void glPushMatrix ( void )
     82 void glReadPixels ( GLint x, GLint y, GLsizei width, GLsizei height, GLenum format, GLenum type, GLvoid *pixels )
     83 void glRotatef ( GLfloat angle, GLfloat x, GLfloat y, GLfloat z )
     84 void glRotatex ( GLfixed angle, GLfixed x, GLfixed y, GLfixed z )
     85 void glSampleCoverage ( GLclampf value, GLboolean invert )
     86 void glSampleCoveragex ( GLclampx value, GLboolean invert )
     87 void glScalef ( GLfloat x, GLfloat y, GLfloat z )
     88 void glScalex ( GLfixed x, GLfixed y, GLfixed z )
     89 void glScissor ( GLint x, GLint y, GLsizei width, GLsizei height )
     90 void glShadeModel ( GLenum mode )
     91 void glStencilFunc ( GLenum func, GLint ref, GLuint mask )
     92 void glStencilMask ( GLuint mask )
     93 void glStencilOp ( GLenum fail, GLenum zfail, GLenum zpass )
     94 void glTexCoordPointer ( GLint size, GLenum type, GLsizei stride, const GLvoid *pointer )
     95 void glTexEnvf ( GLenum target, GLenum pname, GLfloat param )
     96 void glTexEnvfv ( GLenum target, GLenum pname, const GLfloat *params )
     97 void glTexEnvx ( GLenum target, GLenum pname, GLfixed param )
     98 void glTexEnvxv ( GLenum target, GLenum pname, const GLfixed *params )
     99 void glTexImage2D ( GLenum target, GLint level, GLint internalformat, GLsizei width, GLsizei height, GLint border, GLenum format, GLenum type, const GLvoid *pixels )
    100 void glTexParameterf ( GLenum target, GLenum pname, GLfloat param )
    101 void glTexParameterx ( GLenum target, GLenum pname, GLfixed param )
    102 void glTexSubImage2D ( GLenum target, GLint level, GLint xoffset, GLint yoffset, GLsizei width, GLsizei height, GLenum format, GLenum type, const GLvoid *pixels )
    103 void glTranslatef ( GLfloat x, GLfloat y, GLfloat z )
    104 void glTranslatex ( GLfixed x, GLfixed y, GLfixed z )
    105 void glVertexPointer ( GLint size, GLenum type, GLsizei stride, const GLvoid *pointer )
    106 void glViewport ( GLint x, GLint y, GLsizei width, GLsizei height )
    107