Home | History | Annotate | Download | only in dcl.stc
      1 // RUN: %clang_cc1 -verify %s
      2 // XFAIL: *
      3 
      4 typedef const int T0;
      5 typedef int& T1;
      6 
      7 struct s0 {
      8   mutable const int f0; // expected-error{{'mutable' and 'const' cannot be mixed}}
      9   mutable T0 f1; // expected-error{{'mutable' and 'const' cannot be mixed}}
     10   mutable int &f2; // expected-error{{'mutable' cannot be applied to references}}
     11   mutable T1 f3; // expected-error{{'mutable' cannot be applied to references}}
     12   mutable struct s1 {}; // expected-error{{'mutable' cannot be applied to non-data members}}
     13   mutable void im0(); // expected-error{{'mutable' cannot be applied to functions}}
     14 };
     15