Home | History | Annotate | Download | only in elfutils
      1 # -*- rpm-spec-*-
      2 Summary: A collection of utilities and DSOs to handle compiled objects
      3 Name: elfutils
      4 Version: 0.138
      5 Release: 1
      6 License: GPLv2 with exceptions
      7 Group: Development/Tools
      8 Source: elfutils-%{version}.tar.bz2
      9 Obsoletes: libelf libelf-devel
     10 Requires: elfutils-libelf = %{version}-%{release}
     11 Requires: glibc >= 2.7
     12 
     13 # ExcludeArch: xxx
     14 
     15 BuildRoot: %{_tmppath}/%{name}-root
     16 BuildRequires: gcc >= 4.1.2-33
     17 BuildRequires: glibc >= 2.7
     18 BuildRequires: bison >= 1.875
     19 BuildRequires: flex >= 2.5.4a
     20 BuildRequires: bzip2
     21 BuildRequires: m4
     22 
     23 %define _gnu %{nil}
     24 %define _programprefix eu-
     25 
     26 %description
     27 Elfutils is a collection of utilities, including ld (a linker),
     28 nm (for listing symbols from object files), size (for listing the
     29 section sizes of an object or archive file), strip (for discarding
     30 symbols), readelf (to see the raw ELF file structures), and elflint
     31 (to check for well-formed ELF files).  Also included are numerous
     32 helper libraries which implement DWARF, ELF, and machine-specific ELF
     33 handling.
     34 
     35 %package devel
     36 Summary: Development libraries to handle compiled objects.
     37 Group: Development/Tools
     38 Requires: elfutils = %{version}-%{release}
     39 Requires: elfutils-libelf-devel = %{version}-%{release}
     40 
     41 %description devel
     42 The elfutils-devel package contains the libraries to create
     43 applications for handling compiled objects.  libebl provides some
     44 higher-level ELF access functionality.  libdw provides access to
     45 the DWARF debugging information.  libasm provides a programmable
     46 assembler interface.
     47 
     48 %package devel-static
     49 Summary: Static archives to handle compiled objects.
     50 Group: Development/Tools
     51 Requires: elfutils-devel = %{version}-%{release}
     52 
     53 %description devel-static
     54 The elfutils-devel-static archive contains the static archives
     55 with the code the handle compiled objects.
     56 
     57 %package libelf
     58 Summary: Library to read and write ELF files.
     59 Group: Development/Tools
     60 
     61 %description libelf
     62 The elfutils-libelf package provides a DSO which allows reading and
     63 writing ELF files on a high level.  Third party programs depend on
     64 this package to read internals of ELF files.  The programs of the
     65 elfutils package use it also to generate new ELF files.
     66 
     67 %package libelf-devel
     68 Summary: Development support for libelf
     69 Group: Development/Tools
     70 Requires: elfutils-libelf = %{version}-%{release}
     71 Conflicts: libelf-devel
     72 
     73 %description libelf-devel
     74 The elfutils-libelf-devel package contains the libraries to create
     75 applications for handling compiled objects.  libelf allows you to
     76 access the internals of the ELF object file format, so you can see the
     77 different sections of an ELF file.
     78 
     79 %package libelf-devel-static
     80 Summary: Static archive of libelf
     81 Group: Development/Tools
     82 Requires: elfutils-libelf-devel = %{version}-%{release}
     83 Conflicts: libelf-devel
     84 
     85 %description libelf-devel-static
     86 The elfutils-libelf-static package contains the static archive
     87 for libelf.
     88 
     89 %prep
     90 %setup -q
     91 
     92 %build
     93 %configure --program-prefix=%{_programprefix}
     94 make
     95 
     96 %install
     97 rm -rf ${RPM_BUILD_ROOT}
     98 mkdir -p ${RPM_BUILD_ROOT}%{_prefix}
     99 
    100 %makeinstall
    101 
    102 chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
    103 chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
    104 
    105 # XXX Nuke unpackaged files
    106 { cd ${RPM_BUILD_ROOT}
    107   rm -f .%{_bindir}/eu-ld
    108   rm -f .%{_includedir}/elfutils/libasm.h
    109   rm -f .%{_libdir}/libasm.so
    110   rm -f .%{_libdir}/libasm.a
    111 }
    112 
    113 %check
    114 make check
    115 
    116 %clean
    117 rm -rf ${RPM_BUILD_ROOT}
    118 
    119 %post -p /sbin/ldconfig
    120 
    121 %postun -p /sbin/ldconfig
    122 
    123 %post libelf -p /sbin/ldconfig
    124 
    125 %postun libelf -p /sbin/ldconfig
    126 
    127 %files
    128 %defattr(-,root,root)
    129 %doc README TODO
    130 %{_bindir}/eu-elflint
    131 %{_bindir}/eu-nm
    132 %{_bindir}/eu-readelf
    133 %{_bindir}/eu-size
    134 %{_bindir}/eu-strip
    135 %{_bindir}/eu-findtextrel
    136 %{_bindir}/eu-addr2line
    137 %{_bindir}/eu-elfcmp
    138 %{_bindir}/eu-ranlib
    139 %{_bindir}/eu-strings
    140 %{_bindir}/eu-objdump
    141 %{_bindir}/eu-ar
    142 %{_bindir}/eu-unstrip
    143 %{_bindir}/eu-make-debug-archive
    144 #%{_bindir}/eu-ld
    145 %{_libdir}/libasm-%{version}.so
    146 %{_libdir}/libdw-%{version}.so
    147 %{_libdir}/libasm.so.*
    148 %{_libdir}/libdw.so.*
    149 %dir %{_libdir}/elfutils
    150 %{_libdir}/elfutils/lib*.so
    151 
    152 %files devel
    153 %defattr(-,root,root)
    154 %{_includedir}/dwarf.h
    155 %dir %{_includedir}/elfutils
    156 %{_includedir}/elfutils/elf-knowledge.h
    157 #%{_includedir}/elfutils/libasm.h
    158 %{_includedir}/elfutils/libebl.h
    159 %{_includedir}/elfutils/libdw.h
    160 %{_includedir}/elfutils/libdwfl.h
    161 %{_libdir}/libebl.a
    162 #%{_libdir}/libasm.so
    163 %{_libdir}/libdw.so
    164 
    165 %files devel-static
    166 %{_libdir}/libdw.a
    167 #%{_libdir}/libasm.a
    168 
    169 %files libelf
    170 %defattr(-,root,root)
    171 %{_libdir}/libelf-%{version}.so
    172 %{_libdir}/libelf.so.*
    173 
    174 %files libelf-devel
    175 %defattr(-,root,root)
    176 %{_includedir}/libelf.h
    177 %{_includedir}/gelf.h
    178 %{_includedir}/nlist.h
    179 %{_libdir}/libelf.so
    180 
    181 %files libelf-devel-static
    182 %{_libdir}/libelf.a
    183 
    184 %changelog
    185 * Wed Dec 31 2008 Roland McGrath <roland@redhat.com> 0.138-1
    186 - Install <elfutils/version.h> header file for applications to use in
    187   source version compatibility checks.
    188 - libebl: backend fixes for i386 TLS relocs; backend support for
    189   NT_386_IOPERM
    190 - libcpu: disassembler fixes
    191 - libdwfl: bug fixes
    192 - libelf: bug fixes
    193 - nm: bug fixes for handling corrupt input files
    194 
    195 * Tue Aug 26 2008 Ulrich Drepper <drepper@redhat.com> 0.137-1
    196 - Minor fixes for unreleased 0.136 release.
    197 
    198 * Mon Aug 25 2008 Ulrich Drepper <drepper@redhat.com> 0.136-1
    199 - libdwfl: bug fixes; new segment interfaces;	 all the libdwfl-based
    200  tools now support --core=COREFILE option
    201 
    202 * Mon May 12 2008 Ulrich Drepper <drepper@redhat.com> 0.135-1
    203 - libdwfl: bug fixes
    204 - strip: changed handling of ET_REL files wrt symbol tables and relocs
    205 
    206 * Tue Apr  8 2008 Ulrich Drepper <drepper@redhat.com> 0.134-1
    207 - elflint: backend improvements for sparc, alpha
    208 - libdwfl, libelf: bug fixes
    209 
    210 * Sat Mar  1 2008 Ulrich Drepper <drepper@redhat.com> 0.133-1
    211 - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
    212 - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
    213 - libdwfl: bug fixes and optimization in relocation handling
    214 - elfcmp: bug fix for non-allocated section handling
    215 - ld: implement newer features of binutils linker.
    216 
    217 * Mon Jan 21 2008 Ulrich Drepper <drepper@redhat.com> 0.132-1
    218 - libcpu: Implement x86 and x86-64 disassembler.
    219 - libasm: Add interface for disassembler.
    220 - all programs: add debugging of branch prediction.
    221 - libelf: new function elf_scnshndx.
    222 
    223 * Sun Nov 11 2007 Ulrich Drepper <drepper@redhat.com> 0.131-1
    224 - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now depreca
    225 ted;       bug fixes for oddly-formatted DWARF
    226 - libdwfl: bug fixes in offline archive support, symbol table handling;
    227 	 apply partial relocations for dwfl_module_address_section on
    228 ET_REL
    229 - libebl: powerpc backend support for Altivec registers
    230 
    231 * Mon Oct 15 2007 Ulrich Drepper <drepper@redhat.com> 0.130-1
    232 - readelf: -p option can take an argument like -x for one section,
    233 	 or no argument (as before) for all SHF_STRINGS sections;
    234 	 new option --archive-index (or -c);	 improved -n output fo
    235 r core files, on many machines
    236 - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
    237 	new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
    238 - readelf, elflint: handle SHT_NOTE sections without requiring phdrs
    239 - elflint: stricter checks on debug sections
    240 - libdwfl: new functions dwfl_build_id_find_elf, dwfl_build_id_find_debu
    241 ginfo,	 dwfl_module_build_id, dwfl_module_report_build_id;	 suppo
    242 rt dynamic symbol tables found via phdrs;	 dwfl_standard_find_de
    243 buginfo now uses build IDs when available
    244 - unstrip: new option --list (or -n)
    245 - libebl: backend improvements for sparc, alpha, powerpc
    246 
    247 * Tue Aug 14 2007 Ulrich Drepper <drepper@redhat.com> 0.129-1
    248 - readelf: new options --hex-dump (or -x), --strings (or -p)
    249 - addr2line: new option --symbols (or -S)
    250 
    251 * Wed Apr 18 2007 Ulrich Drepper <drepper@redhat.com> 0.127-1
    252 - libdw: new function dwarf_getsrcdirs
    253 - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
    254 	 dwfl_module_address_section
    255 
    256 * Mon Feb  5 2007 Ulrich Drepper <drepper@redhat.com> 0.126-1
    257 - new program: ar
    258 
    259 * Mon Dec 18 2006 Ulrich Drepper <drepper@redhat.com> 0.125-1
    260 - elflint: Compare DT_GNU_HASH tests.
    261 - move archives into -static RPMs
    262 - libelf, elflint: better support for core file handling
    263 
    264 * Tue Oct 10 2006 Ulrich Drepper <drepper@redhat.com> 0.124-1
    265 - libebl: sparc backend support for return value location
    266 - libebl, libdwfl: backend register name support extended with more info
    267 - libelf, libdw: bug fixes for unaligned accesses on machines that care
    268 - readelf, elflint: trivial bugs fixed
    269 
    270 * Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
    271 - libebl: Backend build fixes, thanks to Stepan Kasal.
    272 - libebl: ia64 backend support for register names, return value location
    273 - libdwfl: Handle truncated linux kernel module section names.
    274 - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
    275 - elflint: Fix checks to permit --hash-style=gnu format.
    276 
    277 * Wed Jul 12 2006 Ulrich Drepper <drepper@redhat.com> 0.122-1
    278 - libebl: add function to test for relative relocation
    279 - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
    280 - elflint, readelf: add support for DT_GNU_HASHlibelf: add elf_gnu_hash
    281 - elflint, readelf: add support for 64-bit SysV-style hash tables
    282 - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
    283 
    284 * Wed Jun 14 2006  <drepper@redhat.com> 0.121-1
    285 - libelf: bug fixes for rewriting existing files when using mmap.
    286 - make all installed headers usable in C++ code.
    287 - readelf: better output format.
    288 - elflint: fix tests of dynamic section content.
    289 - ld: Implement --as-needed, --execstack, PT_GNU_STACK.  Many small patc
    290 hes.
    291 - libdw, libdwfl: handle files without aranges info.
    292 
    293 * Tue Apr  4 2006 Ulrich Drepper <drepper@redhat.com> 0.120-1
    294 - Bug fixes.
    295 - dwarf.h updated for DWARF 3.0 final specification.
    296 - libdwfl: New function dwfl_version.
    297 - The license is now GPL for most files.  The libelf, libebl, libdw,and
    298 libdwfl libraries have additional exceptions.  Add reference toOIN.
    299 
    300 * Thu Jan 12 2006 Roland McGrath <roland@redhat.com> 0.119-1
    301 - elflint: more tests.
    302 - libdwfl: New function dwfl_module_register_names.
    303 - libebl: New backend hook for register names.
    304 
    305 * Tue Dec  6 2005 Ulrich Drepper <drepper@redhat.com> 0.118-1
    306 - elflint: more tests.
    307 - libdwfl: New function dwfl_module_register_names.
    308 - libebl: New backend hook for register names.
    309 
    310 * Thu Nov 17 2005 Ulrich Drepper <drepper@redhat.com> 0.117-1
    311 - libdwfl: New function dwfl_module_return_value_location.
    312 - libebl: Backend improvements for several CPUs.
    313 
    314 * Mon Oct 31 2005 Ulrich Drepper <drepper@redhat.com> 0.116-1
    315 - libdw: New functions dwarf_ranges, dwarf_entrypc, dwarf_diecu,       d
    316 warf_entry_breakpoints.  Removed Dwarf_Func type and functions       d
    317 warf_func_name, dwarf_func_lowpc, dwarf_func_highpc,       dwarf_func_
    318 entrypc, dwarf_func_die; dwarf_getfuncs callback now uses       Dwarf_
    319 Die, and dwarf_func_file, dwarf_func_line, dwarf_func_col       replac
    320 ed by dwarf_decl_file, dwarf_decl_line, dwarf_decl_column;       dwarf
    321 _func_inline, dwarf_func_inline_instances now take Dwarf_Die.       Ty
    322 pe Dwarf_Loc renamed to Dwarf_Op; dwarf_getloclist,       dwarf_addrlo
    323 clists renamed dwarf_getlocation, dwarf_getlocation_addr.
    324 
    325 * Fri Sep  2 2005 Ulrich Drepper <drepper@redhat.com> 0.115-1
    326 - libelf: speed-ups of non-mmap reading.
    327 - strings: New program.
    328 - Implement --enable-gcov option for configure.
    329 - libdw: New function dwarf_getscopes_die.
    330 
    331 * Wed Aug 24 2005 Ulrich Drepper <drepper@redhat.com> 0.114-1
    332 - libelf: new function elf_getaroff
    333 - libdw: Added dwarf_func_die, dwarf_func_inline, dwarf_func_inline_inst
    334 ances.
    335 - libdwfl: New functions dwfl_report_offline, dwfl_offline_section_addre
    336 ss,	 dwfl_linux_kernel_report_offline.
    337 - ranlib: new program
    338 
    339 * Mon Aug 15 2005 Ulrich Drepper <drepper@redhat.com> 0.114-1
    340 - libelf: new function elf_getaroff
    341 - ranlib: new program
    342 
    343 * Wed Aug 10 2005 Ulrich Drepper <@redhat.com> 0.113-1
    344 - elflint: relax a bit. Allow version definitions for defined symbols ag
    345 ainstDSO versions also for symbols in nobits sections.  Allow .rodata
    346 sectionto have STRINGS and MERGE flag set.
    347 - strip: add some more compatibility with binutils.
    348 
    349 * Sat Aug  6 2005 Ulrich Drepper <@redhat.com> 0.113-1
    350 - elflint: relax a bit. Allow version definitions for defined symbols ag
    351 ainstDSO versions also for symbols in nobits sections.  Allow .rodata
    352 sectionto have STRINGS and MERGE flag set.
    353 
    354 * Sat Aug  6 2005 Ulrich Drepper <@redhat.com> 0.113-1
    355 - elflint: relax a bit. Allow version definitions for defined symbols ag
    356 ainstDSO versions also for symbols in nobits sections.
    357 
    358 * Fri Aug  5 2005 Ulrich Drepper <@redhat.com> 0.112-1
    359 - elfcmp: some more relaxation.
    360 - elflint: many more tests, especially regarding to symbol versioning.
    361 - libelf: Add elfXX_offscn and gelf_offscn.
    362 - libasm: asm_begin interface changes.
    363 - libebl: Add three new interfaces to directly access machine, class, an
    364 ddata encoding information.
    365 - objdump: New program.  Just the beginning.
    366 
    367 * Thu Jul 28 2005 Ulrich Drepper <@redhat.com> 0.111-1
    368 - libdw: now contains all of libdwfl.  The latter is not installed anymore.
    369 - elfcmp: little usability tweak, name and index of differing section is
    370  printed.
    371 
    372 * Sun Jul 24 2005 Ulrich Drepper <@redhat.com> 0.110-1
    373 - libelf: fix a numbe rof problems with elf_update
    374 - elfcmp: fix a few bugs.  Compare gaps.
    375 - Fix a few PLT problems and mudflap build issues.
    376 - libebl: Don't expose Ebl structure definition in libebl.h.  It's now p
    377 rivate.
    378 
    379 * Thu Jul 21 2005 Ulrich Drepper <@redhat.com> 0.109-1
    380 - libebl: Check for matching modules.
    381 - elflint: Check that copy relocations only happen for OBJECT or NOTYPE
    382 symbols.
    383 - elfcmp: New program.
    384 - libdwfl: New library.
    385 
    386 * Mon May  9 2005 Ulrich Drepper <@redhat.com> 0.108-1
    387 - strip: fix bug introduced in last change
    388 - libdw: records returned by dwarf_getsrclines are now sorted by address
    389 
    390 * Sun May  8 2005 Ulrich Drepper <@redhat.com> 0.108-1
    391 - strip: fix bug introduced in last change
    392 
    393 * Sun May  8 2005 Ulrich Drepper <@redhat.com> 0.107-1
    394 - readelf: improve DWARF output format
    395 - strip: support Linux kernel modules
    396 
    397 * Fri Apr 29 2005 Ulrich Drepper <drepper@redhat.com> 0.107-1
    398 - readelf: improve DWARF output format
    399 
    400 * Mon Apr  4 2005 Ulrich Drepper <drepper@redhat.com> 0.106-1
    401 - libdw: Updated dwarf.h from DWARF3 speclibdw: add new funtions dwarf_f
    402 unc_entrypc, dwarf_func_file, dwarf_func_line,dwarf_func_col, dwarf_ge
    403 tsrc_file
    404 
    405 * Fri Apr  1 2005 Ulrich Drepper <drepper@redhat.com> 0.105-1
    406 - addr2line: New program
    407 - libdw: add new functions: dwarf_addrdie, dwarf_macro_*, dwarf_getfuncs
    408 ,dwarf_func_*.
    409 - findtextrel: use dwarf_addrdie
    410 
    411 * Mon Mar 28 2005 Ulrich Drepper <drepper@redhat.com> 0.104-1
    412 - findtextrel: New program.
    413 
    414 * Mon Mar 21 2005 Ulrich Drepper <drepper@redhat.com> 0.103-1
    415 - libdw: Fix using libdw.h with gcc < 4 and C++ code.  Compiler bug.
    416 
    417 * Tue Feb 22 2005 Ulrich Drepper <drepper@redhat.com> 0.102-1
    418 - More Makefile and spec file cleanups.
    419 
    420 * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
    421 - upgrade to 0.94
    422 
    423 * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
    424 - upgrade to 0.93
    425 
    426 * Thu Jan  8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
    427 - full version
    428 - macroized spec file for GPL or OSL builds
    429 - include only libelf under GPL plus wrapper scripts
    430 
    431 * Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
    432 - macroized spec file for GPL or OSL builds
    433 
    434 * Wed Jan  7 2004 Ulrich Drepper <drepper@redhat.com>
    435 - split elfutils-devel into two packages.
    436 
    437 * Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
    438 - include only libelf under GPL plus wrapper scripts
    439 
    440 * Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
    441 - readelf, not readline, in %%description (#111214).
    442 
    443 * Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
    444 - update to 0.89 (fix eu-strip)
    445 
    446 * Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
    447 - update to 0.86 (fix eu-strip on s390x/alpha)
    448 - libebl is an archive now; remove references to DSO
    449 
    450 * Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
    451 - upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
    452 
    453 * Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
    454 - upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
    455 
    456 * Wed Jul  9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
    457 - upgrade to 0.82 (strip tests fixed on big-endian).
    458 
    459 * Tue Jul  8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
    460 - upgrade to 0.81 (strip excludes unused symtable entries, test borked).
    461 
    462 * Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
    463 - upgrade to 0.80 (debugedit changes for kernel in progress).
    464 
    465 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
    466 - rebuilt
    467 
    468 * Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
    469 - upgrade to 0.79 (correct formats for size_t, more of libdw "works").
    470 
    471 * Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
    472 - upgrade to 0.78 (libdwarf bugfix, libdw additions).
    473 
    474 * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
    475 - debuginfo rebuild
    476 
    477 * Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
    478 - use the correct way of identifying the section via the sh_info link.
    479 
    480 * Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
    481 - update to 0.75 (eu-strip -g fix)
    482 
    483 * Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
    484 - update to 0.74 (fix for writing with some non-dirty sections)
    485 
    486 * Thu Feb  6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
    487 - another -0.73 update (with sparc fixes).
    488 - do "make check" in %%check, not %%install, section.
    489 
    490 * Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
    491 - update to 0.73 (with s390 fixes).
    492 
    493 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
    494 - rebuilt
    495 
    496 * Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
    497 - fix arguments to gelf_getsymshndx and elf_getshstrndx
    498 - fix other warnings
    499 - reenable checks on s390x
    500 
    501 * Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
    502 - temporarily disable checks on s390x, until someone has
    503   time to look at it
    504 
    505 * Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
    506 - update to 0.72
    507 
    508 * Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
    509 - update to 0.71
    510 
    511 * Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
    512 - update to 0.69.
    513 - add "make check" and segfault avoidance patch.
    514 - elfutils-libelf needs to run ldconfig.
    515 
    516 * Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
    517 - update to 0.68.
    518 
    519 * Fri Dec  6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
    520 - update to 0.67.
    521 
    522 * Tue Dec  3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
    523 - update to 0.65.
    524 
    525 * Mon Dec  2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
    526 - update to 0.64.
    527 
    528 * Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
    529 - split packages further into elfutils-libelf
    530 
    531 * Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
    532 - update to 0.63.
    533 
    534 * Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
    535 - Adjust for dropping libtool
    536 
    537 * Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
    538 - update to 0.59
    539 
    540 * Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
    541 - update to 0.56
    542 
    543 * Thu Nov  7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
    544 - update to 0.54
    545 
    546 * Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
    547 - update to 0.53
    548 - drop x86_64 hack, ICE fixed in gcc-3.2-11.
    549 
    550 * Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
    551 - get beehive to punch a rhpkg generated package.
    552 
    553 * Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
    554 - build in 8.0.1.
    555 - x86_64: avoid gcc-3.2 ICE on x86_64 for now.
    556 
    557 * Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
    558 - Add libelf-devel to conflicts for elfutils-devel
    559 
    560 * Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
    561 - Split into runtime and devel package
    562 
    563 * Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
    564 - integrate into official sources
    565 
    566 * Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
    567 - Swaddle.
    568