Home | History | Annotate | Download | only in rpm
      1 %define	RELEASE	1
      2 %define rel     %{?CUSTOM_RELEASE} %{!?CUSTOM_RELEASE:%RELEASE}
      3 %define	prefix	/usr
      4 
      5 Name: %NAME
      6 Summary: An encoder/decoder for the VCDIFF (RFC 3284) format
      7 Version: %VERSION
      8 Release: %rel
      9 Group: Development/Libraries
     10 URL: http://code.google.com/p/open-vcdiff
     11 License: Apache 2.0
     12 Vendor: Google
     13 Packager: Google Inc. <opensource@google.com>
     14 Source: http://%{NAME}.googlecode.com/files/%{NAME}-%{VERSION}.tar.gz
     15 Distribution: Redhat 7 and above.
     16 Buildroot: %{_tmppath}/%{name}-root
     17 Prefix: %prefix
     18 
     19 %description
     20 A library that provides an encoder and decoder for the VCDIFF
     21 (RFC 3284) format.  Please see http://www.ietf.org/rfc/rfc3284.txt .
     22 
     23 %package devel
     24 Summary: An encoder/decoder for the VCDIFF (RFC 3284) format
     25 Group: Development/Libraries
     26 Requires: %{NAME} = %{VERSION}
     27 
     28 %description devel
     29 The %name-devel package contains static and debug libraries and header files
     30 for developing applications that use the %name package.
     31 
     32 %changelog
     33     * Mon Jun 16 2008 <opensource@google.com>
     34     - First draft
     35 
     36 %prep
     37 %setup
     38 
     39 %build
     40 ./configure
     41 make prefix=%prefix
     42 
     43 %install
     44 rm -rf $RPM_BUILD_ROOT
     45 make prefix=$RPM_BUILD_ROOT%{prefix} install
     46 
     47 %clean
     48 rm -rf $RPM_BUILD_ROOT
     49 
     50 %files
     51 %defattr(-,root,root)
     52 
     53 ## Mark all installed files within /usr/share/doc/{package name} as
     54 ## documentation.  This depends on the following two lines appearing in
     55 ## Makefile.am:
     56 ##     docdir = $(prefix)/share/doc/$(PACKAGE)-$(VERSION)
     57 ##     dist_doc_DATA = AUTHORS COPYING ChangeLog INSTALL NEWS README
     58 %docdir %{prefix}/share/doc/%{NAME}-%{VERSION}
     59 %{prefix}/share/doc/%{NAME}-%{VERSION}/*
     60 
     61 %docdir %{prefix}/share/man/man1/vcdiff.1*
     62 %{prefix}/share/man/man1/vcdiff.1*
     63 
     64 %{prefix}/bin/vcdiff
     65 %{prefix}/lib/libvcdcom.so.0
     66 %{prefix}/lib/libvcdcom.so.0.0.0
     67 %{prefix}/lib/libvcdenc.so.0
     68 %{prefix}/lib/libvcdenc.so.0.0.0
     69 %{prefix}/lib/libvcddec.so.0
     70 %{prefix}/lib/libvcddec.so.0.0.0
     71 
     72 %files devel
     73 %defattr(-,root,root)
     74 
     75 %{prefix}/include/google
     76 %{prefix}/lib/libvcdcom.a
     77 %{prefix}/lib/libvcdcom.la
     78 %{prefix}/lib/libvcdcom.so
     79 %{prefix}/lib/libvcdenc.a
     80 %{prefix}/lib/libvcdenc.la
     81 %{prefix}/lib/libvcdenc.so
     82 %{prefix}/lib/libvcddec.a
     83 %{prefix}/lib/libvcddec.la
     84 %{prefix}/lib/libvcddec.so
     85 
     86