Home | History | Annotate | Download | only in 0.153
      1 # -*- rpm-spec-*-
      2 Summary: A collection of utilities and DSOs to handle compiled objects
      3 Name: elfutils
      4 Version: 0.153
      5 Release: 1
      6 License: GPLv2 with exceptions
      7 Group: Development/Tools
      8 Source: elfutils-%{version}.tar.bz2
      9 Obsoletes: libelf libelf-devel
     10 Requires: elfutils-libelf = %{version}-%{release}
     11 Requires: glibc >= 2.7
     12 Requires: libstdc++
     13 
     14 # ExcludeArch: xxx
     15 
     16 BuildRoot: %{_tmppath}/%{name}-root
     17 BuildRequires: gcc >= 4.1.2-33
     18 BuildRequires: glibc >= 2.7
     19 BuildRequires: bison >= 1.875
     20 BuildRequires: flex >= 2.5.4a
     21 BuildRequires: bzip2
     22 BuildRequires: m4
     23 BuildRequires: gettext
     24 BuildRequires: zlib-devel
     25 BuildRequires: bzip2-devel
     26 BuildRequires: xz-devel
     27 BuildRequires: gcc-c++
     28 
     29 %define _gnu %{nil}
     30 %define _programprefix eu-
     31 
     32 %description
     33 Elfutils is a collection of utilities, including ld (a linker),
     34 nm (for listing symbols from object files), size (for listing the
     35 section sizes of an object or archive file), strip (for discarding
     36 symbols), readelf (to see the raw ELF file structures), and elflint
     37 (to check for well-formed ELF files).  Also included are numerous
     38 helper libraries which implement DWARF, ELF, and machine-specific ELF
     39 handling.
     40 
     41 %package devel
     42 Summary: Development libraries to handle compiled objects.
     43 Group: Development/Tools
     44 Requires: elfutils = %{version}-%{release}
     45 Requires: elfutils-libelf-devel = %{version}-%{release}
     46 
     47 %description devel
     48 The elfutils-devel package contains the libraries to create
     49 applications for handling compiled objects.  libebl provides some
     50 higher-level ELF access functionality.  libdw provides access to
     51 the DWARF debugging information.  libasm provides a programmable
     52 assembler interface.
     53 
     54 %package devel-static
     55 Summary: Static archives to handle compiled objects.
     56 Group: Development/Tools
     57 Requires: elfutils-devel = %{version}-%{release}
     58 
     59 %description devel-static
     60 The elfutils-devel-static archive contains the static archives
     61 with the code the handle compiled objects.
     62 
     63 %package libelf
     64 Summary: Library to read and write ELF files.
     65 Group: Development/Tools
     66 
     67 %description libelf
     68 The elfutils-libelf package provides a DSO which allows reading and
     69 writing ELF files on a high level.  Third party programs depend on
     70 this package to read internals of ELF files.  The programs of the
     71 elfutils package use it also to generate new ELF files.
     72 
     73 %package libelf-devel
     74 Summary: Development support for libelf
     75 Group: Development/Tools
     76 Requires: elfutils-libelf = %{version}-%{release}
     77 Conflicts: libelf-devel
     78 
     79 %description libelf-devel
     80 The elfutils-libelf-devel package contains the libraries to create
     81 applications for handling compiled objects.  libelf allows you to
     82 access the internals of the ELF object file format, so you can see the
     83 different sections of an ELF file.
     84 
     85 %package libelf-devel-static
     86 Summary: Static archive of libelf
     87 Group: Development/Tools
     88 Requires: elfutils-libelf-devel = %{version}-%{release}
     89 Conflicts: libelf-devel
     90 
     91 %description libelf-devel-static
     92 The elfutils-libelf-static package contains the static archive
     93 for libelf.
     94 
     95 %prep
     96 %setup -q
     97 
     98 %build
     99 %configure --program-prefix=%{_programprefix}
    100 make
    101 
    102 %install
    103 rm -rf ${RPM_BUILD_ROOT}
    104 mkdir -p ${RPM_BUILD_ROOT}%{_prefix}
    105 
    106 %makeinstall
    107 
    108 chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
    109 chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
    110 
    111 # XXX Nuke unpackaged files
    112 { cd ${RPM_BUILD_ROOT}
    113   rm -f .%{_bindir}/eu-ld
    114   rm -f .%{_includedir}/elfutils/libasm.h
    115   rm -f .%{_libdir}/libasm.so
    116   rm -f .%{_libdir}/libasm.a
    117 }
    118 
    119 %check
    120 make check
    121 
    122 %clean
    123 rm -rf ${RPM_BUILD_ROOT}
    124 
    125 %post -p /sbin/ldconfig
    126 
    127 %postun -p /sbin/ldconfig
    128 
    129 %post libelf -p /sbin/ldconfig
    130 
    131 %postun libelf -p /sbin/ldconfig
    132 
    133 %files
    134 %defattr(-,root,root)
    135 %doc README TODO
    136 %{_bindir}/eu-elflint
    137 %{_bindir}/eu-nm
    138 %{_bindir}/eu-readelf
    139 %{_bindir}/eu-size
    140 %{_bindir}/eu-strip
    141 %{_bindir}/eu-findtextrel
    142 %{_bindir}/eu-addr2line
    143 %{_bindir}/eu-elfcmp
    144 %{_bindir}/eu-ranlib
    145 %{_bindir}/eu-strings
    146 %{_bindir}/eu-objdump
    147 %{_bindir}/eu-ar
    148 %{_bindir}/eu-unstrip
    149 %{_bindir}/eu-make-debug-archive
    150 #%{_bindir}/eu-ld
    151 %{_libdir}/libasm-%{version}.so
    152 %{_libdir}/libdw-%{version}.so
    153 %{_libdir}/libasm.so.*
    154 %{_libdir}/libdw.so.*
    155 %dir %{_libdir}/elfutils
    156 %{_libdir}/elfutils/lib*.so
    157 
    158 %files devel
    159 %defattr(-,root,root)
    160 %{_includedir}/dwarf.h
    161 %dir %{_includedir}/elfutils
    162 %{_includedir}/elfutils/elf-knowledge.h
    163 #%{_includedir}/elfutils/libasm.h
    164 %{_includedir}/elfutils/libebl.h
    165 %{_includedir}/elfutils/libdw.h
    166 %{_includedir}/elfutils/libdwfl.h
    167 %{_libdir}/libebl.a
    168 #%{_libdir}/libasm.so
    169 %{_libdir}/libdw.so
    170 
    171 %files devel-static
    172 %{_libdir}/libdw.a
    173 #%{_libdir}/libasm.a
    174 
    175 %files libelf
    176 %defattr(-,root,root)
    177 %{_libdir}/libelf-%{version}.so
    178 %{_libdir}/libelf.so.*
    179 %{_datadir}/locale/*/LC_MESSAGES/elfutils.mo
    180 
    181 %files libelf-devel
    182 %defattr(-,root,root)
    183 %{_includedir}/libelf.h
    184 %{_includedir}/gelf.h
    185 %{_includedir}/nlist.h
    186 %{_includedir}/elfutils/version.h
    187 %{_libdir}/libelf.so
    188 
    189 %files libelf-devel-static
    190 %{_libdir}/libelf.a
    191 
    192 %changelog
    193 * Thu Feb 23 2012 Mark Wielaard <mjw@redhat.com> 0.153-1
    194 - libdw: Support reading .zdebug_* DWARF sections compressed via zlib.
    195 - libdwfl: Speed up dwfl_module_addrsym.
    196 - nm: Support C++ demangling.
    197 - ar: Support D modifier for "deterministic output" with no 
    198   uid/gid/mtime info.     The U modifier is the inverse.     elfutils 
    199   can be configured with the --enable-deterministic-archives     option 
    200   to make the D behavior the default when U is not specified.
    201 - ranlib: Support -D and -U flags with same meaning.
    202 - readelf: Improve output of -wline. Add support for printing SDT elf 
    203   notes.          Add printing of .gdb_index section. 	 Support for 
    204   typed DWARF stack, call_site and entry_value.
    205 - strip: Add --reloc-debug-sections option.        Improved SHT_GROUP 
    206   sections handling.
    207 
    208 * Tue Feb 15 2011  <drepper@gmail.com> 0.152-1
    209 - Various build and warning nits fixed for newest GCC and Autoconf.
    210 - libdwfl: Yet another prelink-related fix for another regression.
    211   	 Look for Linux kernel images in files named with compression
    212   suffixes.
    213 - elfcmp: New flag --ignore-build-id to ignore differing build ID
    214   bits. 	New flag -l/--verbose to print all differences.
    215 
    216 * Wed Jan 12 2011  <drepper@gmail.com> 0.151-1
    217 - libdwfl: Fix for more prelink cases with separate debug file.
    218 - strip: New flag --strip-sections to remove section headers entirely.
    219 
    220 * Mon Nov 22 2010  <drepper@gmail.com> 0.150-1
    221 - libdw: Fix for handling huge .debug_aranges section.
    222 - libdwfl: Fix for handling prelinked DSO with separate debug file.
    223 - findtextrel: Fix diagnostics to work with usual section ordering.
    224 - libebl: i386 backend fix for multi-register integer return value
    225   location.
    226 
    227 * Mon Sep 13 2010  <drepper@redhat.com> 0.149-1
    228 - libdw: Decode new DW_OP_GNU_implicit_pointer operation;        new
    229   function dwarf_getlocation_implicit_pointer.
    230 - libdwfl: New function dwfl_dwarf_line.
    231 - addr2line: New flag -F/--flags to print more DWARF line information
    232   details.
    233 - strip: -g recognizes .gdb_index as a debugging section.
    234 
    235 * Mon Jun 28 2010  <drepper@redhat.com> 0.148-1
    236 - libdw: Accept DWARF 4 format: new functions dwarf_next_unit,
    237   dwarf_offdie_types.        New functions dwarf_lineisa,
    238   dwarf_linediscriminator, dwarf_lineop_index.
    239 - libdwfl: Fixes in core-file handling, support cores from PIEs.
    240   	 When working from build IDs, don't open a named file that
    241   mismatches.
    242 - readelf: Handle DWARF 4 formats.
    243 
    244 * Mon May  3 2010 Ulrich Drepper <drepper (at] redhat.com> 0.147-1
    245 - libdw: Fixes in CFI handling, best possible handling of bogus CFA
    246   ops.
    247 - libdwfl: Ignore R_*_NONE relocs, works around old (binutils) ld -r
    248   bugs.
    249 
    250 * Wed Apr 21 2010  <drepper (at] redhat.com> 0.146-1
    251 - libdwfl: New function dwfl_core_file_report.
    252 
    253 * Tue Feb 23 2010 Ulrich Drepper <drepper (at] redhat.com> 0.145-1
    254 - Fix build with --disable-dependency-tracking.
    255 - Fix build with most recent glibc headers.
    256 - libelf: More robust to bogus section headers.
    257 - libdw: Fix CFI decoding.
    258 - libdwfl: Fix address bias returned by CFI accessors. 	 Fix core
    259   file module layout identification.
    260 - readelf: Fix CFI decoding.
    261 
    262 * Thu Jan 14 2010  <drepper (at] redhat.com> 0.144-1
    263 - libelf: New function elf_getphdrnum. 	Now support using more than
    264   65536 program headers in a file.
    265 - libdw: New function dwarf_aggregate_size for computing (constant)
    266   type        sizes, including array_type cases with nontrivial
    267   calculation.
    268 - readelf: Don't give errors for missing info under -a.
    269   Handle Linux "VMCOREINFO" notes under -n.
    270 
    271 * Mon Sep 21 2009  <drepper@redhat.com> 0.143-1
    272 - libdw: Various convenience functions for individual attributes now
    273   use dwarf_attr_integrate to look up indirect inherited
    274   attributes.  Location expression handling now supports
    275   DW_OP_implicit_value.
    276 - libdwfl: Support automatic decompression of files in XZ format,
    277   and of Linux kernel images made with bzip2 or LZMA (as well
    278   as gzip).
    279 
    280 * Mon Jun 29 2009  <drepper@redhat.com> 0.142-1
    281 - libelf: Add elf_getshdrnum alias for elf_getshnum and elf_getshdrstrndx alias
    282   for elf_getshstrndx and deprecate original names.  Sun screwed up
    283   their implementation and asked for a solution.
    284 - libebl: Add support for STB_GNU_UNIQUE.
    285 - elflint: Add support for STB_GNU_UNIQUE.
    286 - readelf: Add -N option, speeds up DWARF printing without address->name lookups.
    287 - libdw: Add support for decoding DWARF CFI into location description form.
    288   Handle some new DWARF 3 expression operations previously omitted.
    289   Basic handling of some new encodings slated for DWARF
    290 
    291 * Thu Apr 23 2009 Ulrich Drepper <drepper@redhat.com> 0.141-1
    292 - libebl: sparc backend fixes; 	some more arm backend support
    293 - libdwfl: fix dwfl_module_build_id for prelinked DSO case;
    294   fixes in core file support; 	 dwfl_module_getsym interface
    295   improved for non-address symbols
    296 - strip: fix infinite loop on strange inputs with -f
    297 - addr2line: take -j/--section=NAME option for binutils compatibility
    298   	   (same effect as '(NAME)0x123' syntax already supported)
    299 
    300 * Mon Feb 16 2009 Ulrich Drepper <drepper@redhat.com> 0.140-1
    301 - libelf: Fix regression in creation of section header
    302 - libdwfl: Less strict behavior if DWARF reader ist just used to
    303   display data
    304 
    305 * Thu Jan 22 2009 Ulrich Drepper <drepper@redhat.com> 0.139-1
    306 - libcpu: Add Intel SSE4 disassembler support
    307 - readelf: Implement call frame information and exception handling
    308   dumping.          Add -e option.  Enable it implicitly for -a.
    309 - elflint: Check PT_GNU_EH_FRAME program header entry.
    310 - libdwfl: Support automatic gzip/bzip2 decompression of ELF files.
    311 
    312 * Wed Dec 31 2008 Roland McGrath <roland@redhat.com> 0.138-1
    313 - Install <elfutils/version.h> header file for applications to use in
    314   source version compatibility checks.
    315 - libebl: backend fixes for i386 TLS relocs; backend support for
    316   NT_386_IOPERM
    317 - libcpu: disassembler fixes
    318 - libdwfl: bug fixes
    319 - libelf: bug fixes
    320 - nm: bug fixes for handling corrupt input files
    321 
    322 * Tue Aug 26 2008 Ulrich Drepper <drepper@redhat.com> 0.137-1
    323 - Minor fixes for unreleased 0.136 release.
    324 
    325 * Mon Aug 25 2008 Ulrich Drepper <drepper@redhat.com> 0.136-1
    326 - libdwfl: bug fixes; new segment interfaces;	 all the libdwfl-based
    327  tools now support --core=COREFILE option
    328 
    329 * Mon May 12 2008 Ulrich Drepper <drepper@redhat.com> 0.135-1
    330 - libdwfl: bug fixes
    331 - strip: changed handling of ET_REL files wrt symbol tables and relocs
    332 
    333 * Tue Apr  8 2008 Ulrich Drepper <drepper@redhat.com> 0.134-1
    334 - elflint: backend improvements for sparc, alpha
    335 - libdwfl, libelf: bug fixes
    336 
    337 * Sat Mar  1 2008 Ulrich Drepper <drepper@redhat.com> 0.133-1
    338 - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
    339 - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
    340 - libdwfl: bug fixes and optimization in relocation handling
    341 - elfcmp: bug fix for non-allocated section handling
    342 - ld: implement newer features of binutils linker.
    343 
    344 * Mon Jan 21 2008 Ulrich Drepper <drepper@redhat.com> 0.132-1
    345 - libcpu: Implement x86 and x86-64 disassembler.
    346 - libasm: Add interface for disassembler.
    347 - all programs: add debugging of branch prediction.
    348 - libelf: new function elf_scnshndx.
    349 
    350 * Sun Nov 11 2007 Ulrich Drepper <drepper@redhat.com> 0.131-1
    351 - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now depreca
    352 ted;       bug fixes for oddly-formatted DWARF
    353 - libdwfl: bug fixes in offline archive support, symbol table handling;
    354 	 apply partial relocations for dwfl_module_address_section on
    355 ET_REL
    356 - libebl: powerpc backend support for Altivec registers
    357 
    358 * Mon Oct 15 2007 Ulrich Drepper <drepper@redhat.com> 0.130-1
    359 - readelf: -p option can take an argument like -x for one section,
    360 	 or no argument (as before) for all SHF_STRINGS sections;
    361 	 new option --archive-index (or -c);	 improved -n output fo
    362 r core files, on many machines
    363 - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
    364 	new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
    365 - readelf, elflint: handle SHT_NOTE sections without requiring phdrs
    366 - elflint: stricter checks on debug sections
    367 - libdwfl: new functions dwfl_build_id_find_elf, dwfl_build_id_find_debu
    368 ginfo,	 dwfl_module_build_id, dwfl_module_report_build_id;	 suppo
    369 rt dynamic symbol tables found via phdrs;	 dwfl_standard_find_de
    370 buginfo now uses build IDs when available
    371 - unstrip: new option --list (or -n)
    372 - libebl: backend improvements for sparc, alpha, powerpc
    373 
    374 * Tue Aug 14 2007 Ulrich Drepper <drepper@redhat.com> 0.129-1
    375 - readelf: new options --hex-dump (or -x), --strings (or -p)
    376 - addr2line: new option --symbols (or -S)
    377 
    378 * Wed Apr 18 2007 Ulrich Drepper <drepper@redhat.com> 0.127-1
    379 - libdw: new function dwarf_getsrcdirs
    380 - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
    381 	 dwfl_module_address_section
    382 
    383 * Mon Feb  5 2007 Ulrich Drepper <drepper@redhat.com> 0.126-1
    384 - new program: ar
    385 
    386 * Mon Dec 18 2006 Ulrich Drepper <drepper@redhat.com> 0.125-1
    387 - elflint: Compare DT_GNU_HASH tests.
    388 - move archives into -static RPMs
    389 - libelf, elflint: better support for core file handling
    390 
    391 * Tue Oct 10 2006 Ulrich Drepper <drepper@redhat.com> 0.124-1
    392 - libebl: sparc backend support for return value location
    393 - libebl, libdwfl: backend register name support extended with more info
    394 - libelf, libdw: bug fixes for unaligned accesses on machines that care
    395 - readelf, elflint: trivial bugs fixed
    396 
    397 * Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
    398 - libebl: Backend build fixes, thanks to Stepan Kasal.
    399 - libebl: ia64 backend support for register names, return value location
    400 - libdwfl: Handle truncated linux kernel module section names.
    401 - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
    402 - elflint: Fix checks to permit --hash-style=gnu format.
    403 
    404 * Wed Jul 12 2006 Ulrich Drepper <drepper@redhat.com> 0.122-1
    405 - libebl: add function to test for relative relocation
    406 - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
    407 - elflint, readelf: add support for DT_GNU_HASHlibelf: add elf_gnu_hash
    408 - elflint, readelf: add support for 64-bit SysV-style hash tables
    409 - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
    410 
    411 * Wed Jun 14 2006  <drepper@redhat.com> 0.121-1
    412 - libelf: bug fixes for rewriting existing files when using mmap.
    413 - make all installed headers usable in C++ code.
    414 - readelf: better output format.
    415 - elflint: fix tests of dynamic section content.
    416 - ld: Implement --as-needed, --execstack, PT_GNU_STACK.  Many small patc
    417 hes.
    418 - libdw, libdwfl: handle files without aranges info.
    419 
    420 * Tue Apr  4 2006 Ulrich Drepper <drepper@redhat.com> 0.120-1
    421 - Bug fixes.
    422 - dwarf.h updated for DWARF 3.0 final specification.
    423 - libdwfl: New function dwfl_version.
    424 - The license is now GPL for most files.  The libelf, libebl, libdw,and
    425 libdwfl libraries have additional exceptions.  Add reference toOIN.
    426 
    427 * Thu Jan 12 2006 Roland McGrath <roland@redhat.com> 0.119-1
    428 - elflint: more tests.
    429 - libdwfl: New function dwfl_module_register_names.
    430 - libebl: New backend hook for register names.
    431 
    432 * Tue Dec  6 2005 Ulrich Drepper <drepper@redhat.com> 0.118-1
    433 - elflint: more tests.
    434 - libdwfl: New function dwfl_module_register_names.
    435 - libebl: New backend hook for register names.
    436 
    437 * Thu Nov 17 2005 Ulrich Drepper <drepper@redhat.com> 0.117-1
    438 - libdwfl: New function dwfl_module_return_value_location.
    439 - libebl: Backend improvements for several CPUs.
    440 
    441 * Mon Oct 31 2005 Ulrich Drepper <drepper@redhat.com> 0.116-1
    442 - libdw: New functions dwarf_ranges, dwarf_entrypc, dwarf_diecu,       d
    443 warf_entry_breakpoints.  Removed Dwarf_Func type and functions       d
    444 warf_func_name, dwarf_func_lowpc, dwarf_func_highpc,       dwarf_func_
    445 entrypc, dwarf_func_die; dwarf_getfuncs callback now uses       Dwarf_
    446 Die, and dwarf_func_file, dwarf_func_line, dwarf_func_col       replac
    447 ed by dwarf_decl_file, dwarf_decl_line, dwarf_decl_column;       dwarf
    448 _func_inline, dwarf_func_inline_instances now take Dwarf_Die.       Ty
    449 pe Dwarf_Loc renamed to Dwarf_Op; dwarf_getloclist,       dwarf_addrlo
    450 clists renamed dwarf_getlocation, dwarf_getlocation_addr.
    451 
    452 * Fri Sep  2 2005 Ulrich Drepper <drepper@redhat.com> 0.115-1
    453 - libelf: speed-ups of non-mmap reading.
    454 - strings: New program.
    455 - Implement --enable-gcov option for configure.
    456 - libdw: New function dwarf_getscopes_die.
    457 
    458 * Wed Aug 24 2005 Ulrich Drepper <drepper@redhat.com> 0.114-1
    459 - libelf: new function elf_getaroff
    460 - libdw: Added dwarf_func_die, dwarf_func_inline, dwarf_func_inline_inst
    461 ances.
    462 - libdwfl: New functions dwfl_report_offline, dwfl_offline_section_addre
    463 ss,	 dwfl_linux_kernel_report_offline.
    464 - ranlib: new program
    465 
    466 * Mon Aug 15 2005 Ulrich Drepper <drepper@redhat.com> 0.114-1
    467 - libelf: new function elf_getaroff
    468 - ranlib: new program
    469 
    470 * Wed Aug 10 2005 Ulrich Drepper <@redhat.com> 0.113-1
    471 - elflint: relax a bit. Allow version definitions for defined symbols ag
    472 ainstDSO versions also for symbols in nobits sections.  Allow .rodata
    473 sectionto have STRINGS and MERGE flag set.
    474 - strip: add some more compatibility with binutils.
    475 
    476 * Sat Aug  6 2005 Ulrich Drepper <@redhat.com> 0.113-1
    477 - elflint: relax a bit. Allow version definitions for defined symbols ag
    478 ainstDSO versions also for symbols in nobits sections.  Allow .rodata
    479 sectionto have STRINGS and MERGE flag set.
    480 
    481 * Sat Aug  6 2005 Ulrich Drepper <@redhat.com> 0.113-1
    482 - elflint: relax a bit. Allow version definitions for defined symbols ag
    483 ainstDSO versions also for symbols in nobits sections.
    484 
    485 * Fri Aug  5 2005 Ulrich Drepper <@redhat.com> 0.112-1
    486 - elfcmp: some more relaxation.
    487 - elflint: many more tests, especially regarding to symbol versioning.
    488 - libelf: Add elfXX_offscn and gelf_offscn.
    489 - libasm: asm_begin interface changes.
    490 - libebl: Add three new interfaces to directly access machine, class, an
    491 ddata encoding information.
    492 - objdump: New program.  Just the beginning.
    493 
    494 * Thu Jul 28 2005 Ulrich Drepper <@redhat.com> 0.111-1
    495 - libdw: now contains all of libdwfl.  The latter is not installed anymore.
    496 - elfcmp: little usability tweak, name and index of differing section is
    497  printed.
    498 
    499 * Sun Jul 24 2005 Ulrich Drepper <@redhat.com> 0.110-1
    500 - libelf: fix a numbe rof problems with elf_update
    501 - elfcmp: fix a few bugs.  Compare gaps.
    502 - Fix a few PLT problems and mudflap build issues.
    503 - libebl: Don't expose Ebl structure definition in libebl.h.  It's now p
    504 rivate.
    505 
    506 * Thu Jul 21 2005 Ulrich Drepper <@redhat.com> 0.109-1
    507 - libebl: Check for matching modules.
    508 - elflint: Check that copy relocations only happen for OBJECT or NOTYPE
    509 symbols.
    510 - elfcmp: New program.
    511 - libdwfl: New library.
    512 
    513 * Mon May  9 2005 Ulrich Drepper <@redhat.com> 0.108-1
    514 - strip: fix bug introduced in last change
    515 - libdw: records returned by dwarf_getsrclines are now sorted by address
    516 
    517 * Sun May  8 2005 Ulrich Drepper <@redhat.com> 0.108-1
    518 - strip: fix bug introduced in last change
    519 
    520 * Sun May  8 2005 Ulrich Drepper <@redhat.com> 0.107-1
    521 - readelf: improve DWARF output format
    522 - strip: support Linux kernel modules
    523 
    524 * Fri Apr 29 2005 Ulrich Drepper <drepper@redhat.com> 0.107-1
    525 - readelf: improve DWARF output format
    526 
    527 * Mon Apr  4 2005 Ulrich Drepper <drepper@redhat.com> 0.106-1
    528 - libdw: Updated dwarf.h from DWARF3 speclibdw: add new funtions dwarf_f
    529 unc_entrypc, dwarf_func_file, dwarf_func_line,dwarf_func_col, dwarf_ge
    530 tsrc_file
    531 
    532 * Fri Apr  1 2005 Ulrich Drepper <drepper@redhat.com> 0.105-1
    533 - addr2line: New program
    534 - libdw: add new functions: dwarf_addrdie, dwarf_macro_*, dwarf_getfuncs
    535 ,dwarf_func_*.
    536 - findtextrel: use dwarf_addrdie
    537 
    538 * Mon Mar 28 2005 Ulrich Drepper <drepper@redhat.com> 0.104-1
    539 - findtextrel: New program.
    540 
    541 * Mon Mar 21 2005 Ulrich Drepper <drepper@redhat.com> 0.103-1
    542 - libdw: Fix using libdw.h with gcc < 4 and C++ code.  Compiler bug.
    543 
    544 * Tue Feb 22 2005 Ulrich Drepper <drepper@redhat.com> 0.102-1
    545 - More Makefile and spec file cleanups.
    546 
    547 * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
    548 - upgrade to 0.94
    549 
    550 * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
    551 - upgrade to 0.93
    552 
    553 * Thu Jan  8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
    554 - full version
    555 - macroized spec file for GPL or OSL builds
    556 - include only libelf under GPL plus wrapper scripts
    557 
    558 * Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
    559 - macroized spec file for GPL or OSL builds
    560 
    561 * Wed Jan  7 2004 Ulrich Drepper <drepper@redhat.com>
    562 - split elfutils-devel into two packages.
    563 
    564 * Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
    565 - include only libelf under GPL plus wrapper scripts
    566 
    567 * Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
    568 - readelf, not readline, in %%description (#111214).
    569 
    570 * Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
    571 - update to 0.89 (fix eu-strip)
    572 
    573 * Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
    574 - update to 0.86 (fix eu-strip on s390x/alpha)
    575 - libebl is an archive now; remove references to DSO
    576 
    577 * Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
    578 - upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
    579 
    580 * Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
    581 - upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
    582 
    583 * Wed Jul  9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
    584 - upgrade to 0.82 (strip tests fixed on big-endian).
    585 
    586 * Tue Jul  8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
    587 - upgrade to 0.81 (strip excludes unused symtable entries, test borked).
    588 
    589 * Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
    590 - upgrade to 0.80 (debugedit changes for kernel in progress).
    591 
    592 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
    593 - rebuilt
    594 
    595 * Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
    596 - upgrade to 0.79 (correct formats for size_t, more of libdw "works").
    597 
    598 * Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
    599 - upgrade to 0.78 (libdwarf bugfix, libdw additions).
    600 
    601 * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
    602 - debuginfo rebuild
    603 
    604 * Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
    605 - use the correct way of identifying the section via the sh_info link.
    606 
    607 * Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
    608 - update to 0.75 (eu-strip -g fix)
    609 
    610 * Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
    611 - update to 0.74 (fix for writing with some non-dirty sections)
    612 
    613 * Thu Feb  6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
    614 - another -0.73 update (with sparc fixes).
    615 - do "make check" in %%check, not %%install, section.
    616 
    617 * Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
    618 - update to 0.73 (with s390 fixes).
    619 
    620 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
    621 - rebuilt
    622 
    623 * Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
    624 - fix arguments to gelf_getsymshndx and elf_getshstrndx
    625 - fix other warnings
    626 - reenable checks on s390x
    627 
    628 * Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
    629 - temporarily disable checks on s390x, until someone has
    630   time to look at it
    631 
    632 * Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
    633 - update to 0.72
    634 
    635 * Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
    636 - update to 0.71
    637 
    638 * Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
    639 - update to 0.69.
    640 - add "make check" and segfault avoidance patch.
    641 - elfutils-libelf needs to run ldconfig.
    642 
    643 * Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
    644 - update to 0.68.
    645 
    646 * Fri Dec  6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
    647 - update to 0.67.
    648 
    649 * Tue Dec  3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
    650 - update to 0.65.
    651 
    652 * Mon Dec  2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
    653 - update to 0.64.
    654 
    655 * Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
    656 - split packages further into elfutils-libelf
    657 
    658 * Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
    659 - update to 0.63.
    660 
    661 * Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
    662 - Adjust for dropping libtool
    663 
    664 * Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
    665 - update to 0.59
    666 
    667 * Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
    668 - update to 0.56
    669 
    670 * Thu Nov  7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
    671 - update to 0.54
    672 
    673 * Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
    674 - update to 0.53
    675 - drop x86_64 hack, ICE fixed in gcc-3.2-11.
    676 
    677 * Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
    678 - get beehive to punch a rhpkg generated package.
    679 
    680 * Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
    681 - build in 8.0.1.
    682 - x86_64: avoid gcc-3.2 ICE on x86_64 for now.
    683 
    684 * Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
    685 - Add libelf-devel to conflicts for elfutils-devel
    686 
    687 * Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
    688 - Split into runtime and devel package
    689 
    690 * Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
    691 - integrate into official sources
    692 
    693 * Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
    694 - Swaddle.
    695