Home | History | Annotate | Download | only in docs
      1 Name
      2 
      3     MESA_resize_buffers
      4 
      5 Name Strings
      6 
      7     GL_MESA_resize_buffers
      8 
      9 Contact
     10 
     11     Brian Paul (brian.paul 'at' tungstengraphics.com)
     12 
     13 Status
     14 
     15     Shipping (since Mesa version 2.2)
     16 
     17 Version
     18 
     19 
     20 Number
     21 
     22     196
     23 
     24 Dependencies
     25 
     26     Mesa 2.2 or later is required.
     27 
     28 Overview
     29 
     30     Mesa is often used as a client library with no integration with
     31     the computer's window system (an X server, for example).  And since
     32     Mesa does not have an event loop nor window system callbacks, it
     33     cannot properly respond to window system events.  In particular,
     34     Mesa cannot automatically detect when a window has been resized.
     35 
     36     Mesa's glViewport command queries the current window size and updates
     37     its internal data structors accordingly.  This normally works fine
     38     since most applications call glViewport in response to window size
     39     changes.
     40 
     41     In some situations, however, the application may not call glViewport
     42     when a window size changes but would still like Mesa to adjust to
     43     the new window size.  This extension exports a new function to solve
     44     this problem.
     45 
     46 New Procedures and Functions
     47 
     48     void glResizeBuffersMESA( void )
     49 
     50 New Tokens
     51 
     52     none
     53 
     54 Additions to the OpenGL Specification (no particular section)
     55 
     56     The glResizeBuffersMESA command may be called when the client
     57     determines that a window has been resized.  Calling
     58     glResizeBuffersMESA causes Mesa to query the current window size
     59     and adjust its internal data structures.  This may include
     60     reallocating depth, stencil, alpha and accumulation buffers.
     61 
     62 Additions to the AGL/GLX/WGL Specifications
     63 
     64     None
     65 
     66 Errors
     67 
     68     INVALID_OPERATION is generated if glResizeBuffersMESA is called between
     69     Begin and End.
     70 
     71 New State
     72 
     73     None.
     74 
     75 New Implementation Dependent State
     76 
     77     None.
     78 
     79 Revision History
     80 
     81   * Revision 1.0 - Initial specification
     82