Home | History | Annotate | Download | only in iputils
      1 #
      2 # This spec file is for _testing_.
      3 #
      4 
      5 %define ssdate 20121221
      6 Summary: The ping program for checking to see if network hosts are alive.
      7 Name: iputils
      8 Version: s%{ssdate}
      9 Release: 1local
     10 License: GPLv2+
     11 Group: System Environment/Daemons
     12 Source0: iputils-s%{ssdate}.tar.bz2
     13 Prefix: %{_prefix}
     14 BuildRoot: %{_tmppath}/%{name}-root
     15 #BuildPrereq: docbook-dtd31-sgml, perl
     16 Requires: kernel >= 2.4.7
     17 
     18 %description
     19 The iputils package contains ping, a basic networking tool.  The ping
     20 command sends a series of ICMP protocol ECHO_REQUEST packets to a
     21 specified network host and can tell you if that machine is alive and
     22 receiving network traffic.
     23 
     24 %prep
     25 %setup -q %{name}
     26 
     27 %build
     28 make
     29 make ninfod
     30 make man
     31 make html
     32 
     33 %install
     34 rm -fr ${RPM_BUILD_ROOT}
     35 mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
     36 mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
     37 mkdir -p $RPM_BUILD_ROOT/%{_unitdir}
     38 
     39 install -c clockdiff            ${RPM_BUILD_ROOT}%{_sbindir}/
     40 install -cp arping              ${RPM_BUILD_ROOT}%{_sbindir}/
     41 install -cp ping                ${RPM_BUILD_ROOT}%{_bindir}/
     42 install -cp rdisc               ${RPM_BUILD_ROOT}%{_sbindir}/
     43 install -cp ping6               ${RPM_BUILD_ROOT}%{_bindir}/
     44 install -cp tracepath           ${RPM_BUILD_ROOT}%{_bindir}/
     45 install -cp tracepath6          ${RPM_BUILD_ROOT}%{_bindir}/
     46 install -cp ninfod/ninfod       ${RPM_BUILD_ROOT}%{_sbindir}/
     47 
     48 mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
     49 ln -sf ../bin/ping6 ${RPM_BUILD_ROOT}%{_sbindir}
     50 ln -sf ../bin/tracepath ${RPM_BUILD_ROOT}%{_sbindir}
     51 ln -sf ../bin/tracepath6 ${RPM_BUILD_ROOT}%{_sbindir}
     52 
     53 mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man8
     54 install -cp doc/clockdiff.8     ${RPM_BUILD_ROOT}%{_mandir}/man8/
     55 install -cp doc/arping.8        ${RPM_BUILD_ROOT}%{_mandir}/man8/
     56 install -cp doc/ping.8          ${RPM_BUILD_ROOT}%{_mandir}/man8/
     57 install -cp doc/rdisc.8         ${RPM_BUILD_ROOT}%{_mandir}/man8/
     58 install -cp doc/tracepath.8     ${RPM_BUILD_ROOT}%{_mandir}/man8/
     59 install -cp doc/ninfod.8        ${RPM_BUILD_ROOT}%{_mandir}/man8/
     60 ln -s ping.8.gz ${RPM_BUILD_ROOT}%{_mandir}/man8/ping6.8.gz
     61 ln -s tracepath.8.gz ${RPM_BUILD_ROOT}%{_mandir}/man8/tracepath6.8.gz
     62 
     63 iconv -f ISO88591 -t UTF8 RELNOTES -o RELNOTES.tmp
     64 touch -r RELNOTES RELNOTES.tmp
     65 mv -f RELNOTES.tmp RELNOTES
     66 
     67 %clean
     68 rm -rf ${RPM_BUILD_ROOT}
     69 
     70 %files
     71 %doc RELNOTES
     72 %attr(0755,root,root) %caps(cap_net_raw=ep) %{_sbindir}/clockdiff
     73 #%attr(4755,root,root) %{_sbindir}/clockdiff
     74 %attr(0755,root,root) %caps(cap_net_raw=ep) %{_sbindir}/arping
     75 #%attr(4755,root,root) %{_sbindir}/arping
     76 %attr(0755,root,root) %caps(cap_net_raw=ep cap_net_admin=ep) %{_bindir}/ping
     77 #%attr(4755,root,root) %{_bindir}/ping
     78 %attr(0755,root,root) %caps(cap_net_raw=ep cap_net_admin=ep) %{_bindir}/ping6
     79 #%attr(4755,root,root) %{_bindir}/ping6
     80 %{_sbindir}/rdisc
     81 %{_bindir}/tracepath
     82 %{_bindir}/tracepath6
     83 %{_sbindir}/ping6
     84 %{_sbindir}/tracepath
     85 %{_sbindir}/tracepath6
     86 %{_sbindir}/ninfod
     87 %attr(644,root,root) %{_mandir}/man8/*
     88 
     89 %changelog
     90 * Fri Nov 30 2012 YOSHIFUJI Hideaki <yoshfuji@linux-ipv6.org>
     91   Partically sync with current Fedora's specfile.
     92 * Sat Feb 23 2001 Alexey Kuznetsov <kuznet (at] ms2.inr.ac.ru>
     93   Taken iputils rpm from ASPLinux-7.2 as pattern.
     94