Home | History | Annotate | Download | only in temp.class.spec.mfunc
      1 // RUN: %clang_cc1 -fsyntax-only -verify %s
      2 
      3 template<typename T, int N>
      4 struct A;
      5 
      6 template<typename T> // expected-note{{previous template declaration}}
      7 struct A<T*, 2> {
      8   void f0();
      9   void f1();
     10   void f2();
     11 };
     12 
     13 template<>
     14 struct A<int, 1> {
     15   void g0();
     16 };
     17 
     18 // FIXME: We should probably give more precise diagnostics here, but the
     19 // diagnostics we give aren't terrible.
     20 // FIXME: why not point to the first parameter that's "too many"?
     21 template<typename T, int N> // expected-error{{too many template parameters}}
     22 void A<T*, 2>::f0() { }
     23 
     24 template<typename T, int N>
     25 void A<T, N>::f1() { } // expected-error{{out-of-line definition}}
     26