Home | History | Annotate | Download | only in egl
      1 EGLint eglGetError ( void )
      2 EGLDisplay eglGetDisplay ( EGLNativeDisplayType display_id )
      3 EGLBoolean eglInitialize ( EGLDisplay dpy, EGLint *major, EGLint *minor )
      4 EGLBoolean eglTerminate ( EGLDisplay dpy )
      5 const char * eglQueryString ( EGLDisplay dpy, EGLint name )
      6 EGLBoolean eglGetConfigs ( EGLDisplay dpy, EGLConfig *configs, EGLint config_size, EGLint *num_config )
      7 EGLBoolean eglChooseConfig ( EGLDisplay dpy, const EGLint *attrib_list, EGLConfig *configs, EGLint config_size, EGLint *num_config )
      8 EGLBoolean eglGetConfigAttrib ( EGLDisplay dpy, EGLConfig config, EGLint attribute, EGLint *value )
      9 EGLSurface eglCreateWindowSurface ( EGLDisplay dpy, EGLConfig config, EGLNativeWindowType win, const EGLint *attrib_list )
     10 EGLSurface eglCreatePbufferSurface ( EGLDisplay dpy, EGLConfig config, const EGLint *attrib_list )
     11 EGLSurface eglCreatePixmapSurface ( EGLDisplay dpy, EGLConfig config, EGLNativePixmapType pixmap, const EGLint *attrib_list )
     12 EGLBoolean eglDestroySurface ( EGLDisplay dpy, EGLSurface surface )
     13 EGLBoolean eglQuerySurface ( EGLDisplay dpy, EGLSurface surface, EGLint attribute, EGLint *value )
     14 EGLBoolean eglBindAPI ( EGLenum api )
     15 EGLenum eglQueryAPI ( void )
     16 EGLBoolean eglWaitClient ( void )
     17 EGLBoolean eglReleaseThread ( void )
     18 EGLSurface eglCreatePbufferFromClientBuffer ( EGLDisplay dpy, EGLenum buftype, EGLClientBuffer buffer, EGLConfig config, const EGLint *attrib_list )
     19 EGLBoolean eglSurfaceAttrib ( EGLDisplay dpy, EGLSurface surface, EGLint attribute, EGLint value )
     20 EGLBoolean eglBindTexImage ( EGLDisplay dpy, EGLSurface surface, EGLint buffer )
     21 EGLBoolean eglReleaseTexImage ( EGLDisplay dpy, EGLSurface surface, EGLint buffer )
     22 EGLBoolean eglSwapInterval ( EGLDisplay dpy, EGLint interval )
     23 EGLContext eglCreateContext ( EGLDisplay dpy, EGLConfig config, EGLContext share_context, const EGLint *attrib_list )
     24 EGLBoolean eglDestroyContext ( EGLDisplay dpy, EGLContext ctx )
     25 EGLBoolean eglMakeCurrent ( EGLDisplay dpy, EGLSurface draw, EGLSurface read, EGLContext ctx )
     26 EGLContext eglGetCurrentContext ( void )
     27 EGLSurface eglGetCurrentSurface ( EGLint readdraw )
     28 EGLDisplay eglGetCurrentDisplay ( void )
     29 EGLBoolean eglQueryContext ( EGLDisplay dpy, EGLContext ctx, EGLint attribute, EGLint *value )
     30 EGLBoolean eglWaitGL ( void )
     31 EGLBoolean eglWaitNative ( EGLint engine )
     32 EGLBoolean eglSwapBuffers ( EGLDisplay dpy, EGLSurface surface )
     33 EGLBoolean eglCopyBuffers ( EGLDisplay dpy, EGLSurface surface, EGLNativePixmapType target )
     34