Home | History | Annotate | Download | only in dcl.typedef
      1 // RUN: %clang_cc1 -verify %s
      2 
      3 struct S {
      4   typedef struct A {} A; // expected-note {{previous definition is here}}
      5   typedef struct B B;
      6   typedef A A; // expected-error {{redefinition of 'A'}}
      7 
      8   struct C { };
      9   typedef struct C OtherC;
     10   typedef OtherC C;
     11 
     12   typedef struct D { } D2;
     13   typedef D2 D;
     14 };
     15 
     16