Home | History | Annotate | Download | only in dcl.spec.concept
      1 // RUN:  %clang_cc1 -std=c++14 -fconcepts-ts -x c++ -verify %s
      2 
      3 template<typename T>
      4 concept bool fcpv(void) { return true; }
      5 
      6 template<typename T>
      7 concept bool fcpi(int i = 0) { return true; } // expected-error {{function concept cannot have any parameters}}
      8 
      9 template<typename... Ts>
     10 concept bool fcpp(Ts... ts) { return true; } // expected-error {{function concept cannot have any parameters}}
     11 
     12 template<typename T>
     13 concept bool fcpva(...) { return true; } // expected-error {{function concept cannot have any parameters}}
     14