Home | History | Annotate | Download | only in debian
      1 define(MULTIARCH_HEADERS,ifdef(`DO_MULTIARCH',
      2 Multi-Arch: same
      3 Pre-Depends: ${misc:Pre-Depends},REMOVE_ME))dnl
      4 define(UTIL_LINUX_NG_DEFINES,
      5 ifdef(`UTIL_LINUX_NG', ``libblkid-dev (>= 2.16), uuid-dev (>= 2.16),''))dnl
      6 define(DIETLIBC_DEFINES,
      7 ifdef(`DIETLIBC', ``dietlibc-dev (>> 0.30) [alpha amd64 arm hppa i386 ia64 powerpc ppc64 s390 sparc],''))dnl
      8 Source: e2fsprogs
      9 Section: admin
     10 Priority: required
     11 Maintainer: Theodore Y. Ts'o <tytso (a] mit.edu>
     12 Build-Depends: gettext, texinfo, pkg-config, DIETLIBC_DEFINES gcc-multilib [mips mipsel], debhelper (>= 7.0), UTIL_LINUX_NG_DEFINES m4
     13 Standards-Version: 3.9.5
     14 Homepage: http://e2fsprogs.sourceforge.net
     15 
     16 ifdef(`E2FSCK_STATIC',``
     17 Package: e2fsck-static
     18 Priority: optional
     19 Depends: ${shlibs:Depends}, ${misc:Depends}
     20 Recommends: sash | bash-static | zsh-static | busybox-static | zsh30-static
     21 Architecture: any
     22 Description: statically-linked version of the ext2/ext3/ext4 filesystem checker
     23  This may be of some help to you if your filesystem gets corrupted enough
     24  to break the shared libraries used by the dynamically linked checker.
     25  .
     26  This binary takes much more space than its dynamic counterpart located
     27  in e2fsprogs, though.
     28  .
     29  You may want to install a statically-linked shell as well, to be able
     30  to run this program if something like your C library gets corrupted.
     31 '')dnl
     32 
     33 Package: libcomerr2
     34 Section: libs
     35 Provides: libcomerr-kth-compat
     36 Depends: ${shlibs:Depends}, ${misc:Depends}
     37 Replaces: e2fsprogs (<< 1.34-1)
     38 Architecture: any
     39 MULTIARCH_HEADERS
     40 Description: common error description library
     41  libcomerr is an attempt to present a common error-handling mechanism to
     42  manipulate the most common form of error code in a fashion that does not
     43  have the problems identified with mechanisms commonly in use.
     44 
     45 Package: comerr-dev
     46 Section: libdevel
     47 Priority: extra
     48 Depends: libc6-dev | libc-dev, libcomerr2 (= ${mainBinary}), ${misc:Depends}
     49 Suggests: doc-base
     50 Replaces: e2fslibs-dev (<< 1.33-2), libkrb5-dev (<< 1.3)
     51 Architecture: any
     52 Description: common error description library - headers and static libraries
     53  libcom_err is an attempt to present a common error-handling mechanism to
     54  manipulate the most common form of error code in a fashion that does not
     55  have the problems identified with mechanisms commonly in use.
     56  .
     57  This package contains the development environment for the com_err library.
     58 
     59 Package: libss2
     60 Section: libs
     61 Depends: libcomerr2, ${shlibs:Depends}, ${misc:Depends}
     62 Replaces: e2fsprogs (<< 1.34-1)
     63 Architecture: any
     64 MULTIARCH_HEADERS
     65 Description: command-line interface parsing library
     66  libss provides a simple command-line interface parser which will
     67  accept input from the user, parse the command into an argv argument
     68  vector, and then dispatch it to a handler function.
     69  . 
     70  It was originally inspired by the Multics SubSystem library.
     71 
     72 Package: ss-dev
     73 Section: libdevel
     74 Priority: extra
     75 Depends: libc6-dev | libc-dev, libss2 (= ${mainBinary}), comerr-dev, ${misc:Depends}
     76 Architecture: any
     77 Description: command-line interface parsing library - headers and static libraries
     78  This package includes a tool that parses a command table to generate
     79  a simple command-line interface parser, the include files needed to
     80  compile and use it, and the static libs.
     81  . 
     82  It was originally inspired by the Multics SubSystem library.
     83  .
     84  This package contains the development environment for the ss library.
     85 ifdef(`UTIL_LINUX_NG',,``
     86 Package: libuuid1
     87 Section: libs
     88 Depends: passwd, ${shlibs:Depends}, ${misc:Depends}
     89 Recommends: uuid-runtime
     90 Replaces: e2fsprogs (<< 1.34-1)
     91 Architecture: any
     92 MULTIARCH_HEADERS
     93 Description: Universally Unique ID library
     94  The libuuid library generates and parses 128-bit universally unique
     95  ids (UUIDs).  A UUID is an identifier that is unique across both
     96  space and time, with respect to the space of all UUIDs.  A UUID can
     97  be used for multiple purposes, from tagging objects with an extremely
     98  short lifetime, to reliably identifying very persistent objects
     99  across a network.
    100  .
    101  See RFC 4122 for more information.  
    102 
    103 Package: uuid-runtime
    104 Section: libs
    105 Priority: optional
    106 Depends: passwd, libuuid1 (>> 1.40.3-1), ${shlibs:Depends}, ${misc:Depends}
    107 Replaces: e2fsprogs (<= 1.40.3-1ubuntu1)
    108 Architecture: any
    109 Description: runtime components for the Universally Unique ID library
    110  The libuuid library generates and parses 128-bit universally unique
    111  ids (UUIDs).  A UUID is an identifier that is unique across both
    112  space and time, with respect to the space of all UUIDs.  A UUID can
    113  be used for multiple purposes, from tagging objects with an extremely
    114  short lifetime, to reliably identifying very persistent objects
    115  across a network.
    116  .
    117  See RFC 4122 for more information.  
    118  .
    119  This package contains the uuidgen program and the uuidd daemon.
    120  .
    121  The uuidd daemon is used to generate UUIDs, especially time-based
    122  UUIDs, in a secure and guaranteed-unique fashion, even in the face
    123  of large numbers of threads trying to grab UUIDs running on
    124  different CPUs. It is used by libuuid as well as the uuidgen
    125  program.
    126 
    127 Package: libuuid1-udeb
    128 XC-Package-Type: udeb
    129 Section: debian-installer
    130 Priority: optional
    131 Depends: ${shlibs:Depends}
    132 Architecture: any
    133 Description: stripped down universally unique id library, for debian-installer
    134  libuuid generates and parses 128-bit universally unique ids (UUIDs).
    135  See RFC 4122 for more information.
    136  .
    137  This is a minimal package for debian-installer.
    138 
    139 Package: uuid-dev
    140 Section: libdevel
    141 Priority: extra
    142 Depends: libc6-dev | libc-dev, libuuid1 (= ${mainBinary}), ${misc:Depends}
    143 Replaces: e2fslibs-dev (<< 1.15)
    144 Architecture: any
    145 Description: universally unique id library - headers and static libraries
    146  libuuid generates and parses 128-bit universally unique ids (UUIDs).
    147  See RFC 4122 for more information.
    148  .
    149  This package contains the development environment for the uuid library.
    150 
    151 Package: libblkid1
    152 Section: libs
    153 Depends: ${shlibs:Depends}, ${misc:Depends}
    154 Architecture: any
    155 Description: block device id library
    156  The blkid library which allows system programs like fsck and 
    157  mount to quickly and easily find block devices by filesystem UUID and 
    158  LABEL.  This allows system administrators to avoid specifying 
    159  filesystems by hard-coded device names, but via a logical naming 
    160  system instead.
    161 
    162 Package: libblkid1-udeb
    163 XC-Package-Type: udeb
    164 Section: debian-installer
    165 Priority: optional
    166 Depends: ${shlibs:Depends}, ${misc:Depends}
    167 Architecture: any
    168 Description: stripped down block device id library, for debian-installer
    169  The blkid library which allows system programs like fsck and 
    170  mount to quickly and easily find block devices by filesystem UUID and 
    171  LABEL.  This allows system administrators to avoid specifiying 
    172  filesystems by hard-coded device names, but via a logical naming 
    173  system instead.
    174  .
    175  This is a minimal package for debian-installer.
    176 
    177 Package: libblkid-dev
    178 Section: libdevel
    179 Priority: extra
    180 Depends: libc6-dev | libc-dev, libblkid1 (= ${binary:Version}), ${misc:Depends}
    181 Architecture: any
    182 Description: block device id library - headers and static libraries
    183  The blkid library which allows system programs like fsck and 
    184  mount to quickly and easily find block devices by filesystem UUID and 
    185  LABEL.  This allows system administrators to avoid specifiying 
    186  filesystems by hard-coded device names, but via a logical naming 
    187  system instead.
    188  .
    189  This package contains the development environment for the blkid library.
    190 '')dnl
    191 
    192 Package: e2fsprogs-udeb
    193 XC-Package-Type: udeb
    194 Section: debian-installer
    195 Priority: optional
    196 Depends: ${shlibs:Depends}, ${misc:Depends}
    197 Architecture: any
    198 Description: stripped-down versions of e2fsprogs, for debian-installer
    199  This package is an e2fsprogs package built for a reduced size, so that
    200  it can help to save space in debian-installer.
    201  .
    202  Don't attempt to install this package, it has no support for a couple of
    203  features you surely want.  Anyway it should refuse to install.
    204 
    205 Package: e2fslibs
    206 Section: libs
    207 Depends: ${shlibs:Depends}, ${misc:Depends}
    208 Replaces: e2fsprogs (<< 1.34-1)
    209 Provides: libext2fs2, libe2p2
    210 Architecture: any
    211 MULTIARCH_HEADERS
    212 Description: ext2/ext3/ext4 file system libraries
    213  The ext2, ext3 and ext4 file systems are successors of the original ext
    214  ("extended") file system. They are the main file system types used for
    215  hard disks on Debian and other Linux systems.
    216  .
    217  This package provides the ext2fs and e2p libraries, for userspace software
    218  that directly accesses extended file systems. Programs that use libext2fs
    219  include e2fsck, mke2fs, and tune2fs. Programs that use libe2p include
    220  dumpe2fs, chattr, and lsattr.
    221 
    222 Package: e2fslibs-dev
    223 Section: libdevel
    224 Priority: extra
    225 Depends: libc6-dev | libc-dev, comerr-dev, e2fslibs (= ${binary:Version}), ${misc:Depends}
    226 Suggests: doc-base
    227 Provides: ext2fs-dev, e2p-dev
    228 Replaces: libkrb5-dev (<< 1.3)
    229 Architecture: any
    230 Description: ext2/ext3/ext4 file system libraries - headers and static libraries
    231  The ext2, ext3 and ext4 file systems are successors of the original ext
    232  ("extended") file system. They are the main file system types used for
    233  hard disks on Debian and other Linux systems.
    234  .
    235  This package contains the development environment for the ext2fs and e2p 
    236  libraries.
    237 
    238 Package: e2fsprogs
    239 Essential: yes
    240 ifdef(`UTIL_LINUX_NG',
    241 ``Pre-Depends: ${shlibs:Depends}, ${misc:Depends}, util-linux (>= 2.15~rc1-1)
    242 '',
    243 ``Pre-Depends: ${shlibs:Depends}, ${misc:Depends}
    244 '')dnl
    245 Multi-Arch: foreign
    246 Suggests: gpart, parted, e2fsck-static
    247 Conflicts: dump (<< 0.4b4-4), quota (<< 1.55-8.1), initscripts (<< 2.85-4), sysvinit (<< 2.85-4)
    248 Replaces: hurd (<= 20040301-1), libblkid1 (<< 1.38+1.39-WIP-2005.12.10-2), libuuid1 (<< 1.38+1.39-WIP-2005.12.10-2)
    249 Architecture: any
    250 Description: ext2/ext3/ext4 file system utilities
    251  The ext2, ext3 and ext4 file systems are successors of the original ext
    252  ("extended") file system. They are the main file system types used for
    253  hard disks on Debian and other Linux systems.
    254  .
    255  This package contains programs for creating, checking, and maintaining
    256  ext2/3/4-based file systems.
    257 
    258 Package: e2fsprogs-dbg
    259 Section: debug
    260 Priority: extra
    261 Depends: e2fsprogs (= ${binary:Version}), ${misc:Depends}
    262 Architecture: any
    263 Description: debugging information for e2fsprogs
    264  This package includes the debug information useful for debugging e2fsprogs
    265  and its libraries, contained in the e2fsprogs and e2fsck-static packages.
    266  The debug information is used for execution tracing and core
    267  dump analysis. 
    268 ifdef(`UTIL_LINUX_NG',,``
    269 Package: uuid-runtime-dbg
    270 Section: debug
    271 Priority: extra
    272 Depends: uuid-runtime (= ${binary:Version}), ${misc:Depends}
    273 Architecture: any
    274 Description: debugging information for uuid-runtime
    275  This package includes the debug information useful for debugging the
    276  uuid runtime programs, contained in the uuid-runtime package.
    277  The debugging information is used for execution tracing and core
    278  dump analysis.
    279 '')dnl
    280 
    281 Package: e2fslibs-dbg
    282 Section: debug
    283 Priority: extra
    284 Depends: e2fslibs (= ${binary:Version}), ${misc:Depends}
    285 Architecture: any
    286 Description: debugging information for e2fslibs
    287  This package includes the debug information useful for debugging the
    288  ext2fs and e2p libraries, contained in the e2fslibs package.  The debug
    289  information is used for execution tracing and core dump analysis.
    290 
    291 Package: libcomerr2-dbg
    292 Section: debug
    293 Priority: extra
    294 Depends: libcomerr2 (= ${binary:Version}), ${misc:Depends}
    295 Architecture: any
    296 Description: debugging information for libcomerr2
    297  This package includes the debug information useful for debugging the
    298  com_err library, contained in the libcomerr2 package.  The debugging
    299  information is used for execution tracing and core dump analysis.
    300 
    301 Package: libss2-dbg
    302 Section: debug
    303 Priority: extra
    304 Depends: libss2 (= ${binary:Version}), ${misc:Depends}
    305 Architecture: any
    306 Description: debugging information for libss2
    307  This package includes the debug information useful for debugging the
    308  ss library, contained in the libss2 package.  The debug information
    309  is used for execution tracing and core dump analysis.
    310 ifdef(`UTIL_LINUX_NG',,``
    311 Package: libblkid1-dbg
    312 Section: debug
    313 Priority: extra
    314 Depends: libblkid1 (= ${binary:Version}), ${misc:Depends}
    315 Architecture: any
    316 Description: debugging information for libblkid1
    317  This package includes the debug information useful for debugging the
    318  blkid library, contained in the libblkid1 package.  The debug
    319  information is used for execution tracing and core dump analysis.
    320 
    321 Package: libuuid1-dbg
    322 Section: debug
    323 Priority: extra
    324 Depends: libuuid1 (= ${binary:Version}), ${misc:Depends}
    325 Architecture: any
    326 Description: debugging information for libuuid1
    327  This package includes the debug information useful for debugging the
    328  UUID library, contained in the libuuid1 package.  The debug
    329  information is used for execution tracing and core dump analysis.
    330 '')dnl
    331