Home | History | Annotate | Download | only in debian
      1 define(MULTIARCH_HEADERS,ifdef(`DO_MULTIARCH',
      2 Multi-Arch: same
      3 Pre-Depends: ${misc:Pre-Depends},REMOVE_ME))dnl
      4 define(UTIL_LINUX_NG_DEFINES,
      5 ifdef(`UTIL_LINUX_NG', ``libblkid-dev (>= 2.16), uuid-dev (>= 2.16),''))dnl
      6 Source: e2fsprogs
      7 Section: admin
      8 Priority: required
      9 Maintainer: Theodore Y. Ts'o <tytso (a] mit.edu>
     10 Build-Depends: gettext, texinfo, pkg-config, gcc-multilib [mips mipsel], libfuse-dev [linux-any kfreebsd-any], libattr1-dev, debhelper (>= 9.0), UTIL_LINUX_NG_DEFINES m4
     11 Standards-Version: 3.9.8
     12 Homepage: http://e2fsprogs.sourceforge.net
     13 
     14 ifdef(`FUSE2FS',``
     15 Package: fuse2fs
     16 Priority: optional
     17 Depends: ${shlibs:Depends}, ${misc:Depends}
     18 Architecture: linux-any kfreebsd-any
     19 Description: ext2 / ext3 / ext4 file system driver for FUSE
     20  fuse2fs is a FUSE file system client that supports reading and
     21  writing from devices or image files containing ext2, ext3, and ext4
     22  file systems.
     23 '')dnl
     24 
     25 ifdef(`E2FSCK_STATIC',``
     26 Package: e2fsck-static
     27 Priority: optional
     28 Depends: ${misc:Depends}
     29 Recommends: sash | bash-static | zsh-static | busybox-static | zsh30-static
     30 Architecture: any
     31 Description: statically-linked version of the ext2/ext3/ext4 filesystem checker
     32  This may be of some help to you if your filesystem gets corrupted enough
     33  to break the shared libraries used by the dynamically linked checker.
     34  .
     35  This binary takes much more space than its dynamic counterpart located
     36  in e2fsprogs, though.
     37  .
     38  You may want to install a statically-linked shell as well, to be able
     39  to run this program if something like your C library gets corrupted.
     40 '')dnl
     41 
     42 Package: libcomerr2
     43 Section: libs
     44 Provides: libcomerr-kth-compat
     45 Depends: ${shlibs:Depends}, ${misc:Depends}
     46 Replaces: e2fsprogs (<< 1.34-1)
     47 Architecture: any
     48 MULTIARCH_HEADERS
     49 Description: common error description library
     50  libcomerr is an attempt to present a common error-handling mechanism to
     51  manipulate the most common form of error code in a fashion that does not
     52  have the problems identified with mechanisms commonly in use.
     53 
     54 Package: comerr-dev
     55 Section: libdevel
     56 Priority: extra
     57 Depends: libc6-dev | libc-dev, libcomerr2 (= ${mainBinary}), ${misc:Depends}
     58 Suggests: doc-base
     59 Replaces: e2fslibs-dev (<< 1.33-2), libkrb5-dev (<< 1.3)
     60 Architecture: any
     61 Description: common error description library - headers and static libraries
     62  libcom_err is an attempt to present a common error-handling mechanism to
     63  manipulate the most common form of error code in a fashion that does not
     64  have the problems identified with mechanisms commonly in use.
     65  .
     66  This package contains the development environment for the com_err library.
     67 
     68 Package: libss2
     69 Section: libs
     70 Depends: libcomerr2, ${shlibs:Depends}, ${misc:Depends}
     71 Replaces: e2fsprogs (<< 1.34-1)
     72 Architecture: any
     73 MULTIARCH_HEADERS
     74 Description: command-line interface parsing library
     75  libss provides a simple command-line interface parser which will
     76  accept input from the user, parse the command into an argv argument
     77  vector, and then dispatch it to a handler function.
     78  .
     79  It was originally inspired by the Multics SubSystem library.
     80 
     81 Package: ss-dev
     82 Section: libdevel
     83 Priority: extra
     84 Depends: libc6-dev | libc-dev, libss2 (= ${mainBinary}), comerr-dev, ${misc:Depends}
     85 Architecture: any
     86 Description: command-line interface parsing library - headers and static libraries
     87  This package includes a tool that parses a command table to generate
     88  a simple command-line interface parser, the include files needed to
     89  compile and use it, and the static libs.
     90  .
     91  It was originally inspired by the Multics SubSystem library.
     92  .
     93  This package contains the development environment for the ss library.
     94 ifdef(`UTIL_LINUX_NG',,``
     95 Package: libuuid1
     96 Section: libs
     97 Depends: passwd, ${shlibs:Depends}, ${misc:Depends}
     98 Recommends: uuid-runtime
     99 Replaces: e2fsprogs (<< 1.34-1)
    100 Architecture: any
    101 MULTIARCH_HEADERS
    102 Description: Universally Unique ID library
    103  The libuuid library generates and parses 128-bit universally unique
    104  ids (UUIDs).  A UUID is an identifier that is unique across both
    105  space and time, with respect to the space of all UUIDs.  A UUID can
    106  be used for multiple purposes, from tagging objects with an extremely
    107  short lifetime, to reliably identifying very persistent objects
    108  across a network.
    109  .
    110  See RFC 4122 for more information.  
    111 
    112 Package: uuid-runtime
    113 Section: libs
    114 Priority: optional
    115 Depends: passwd, libuuid1 (>> 1.40.3-1), ${shlibs:Depends}, ${misc:Depends}
    116 Replaces: e2fsprogs (<= 1.40.3-1ubuntu1)
    117 Architecture: any
    118 Description: runtime components for the Universally Unique ID library
    119  The libuuid library generates and parses 128-bit universally unique
    120  ids (UUIDs).  A UUID is an identifier that is unique across both
    121  space and time, with respect to the space of all UUIDs.  A UUID can
    122  be used for multiple purposes, from tagging objects with an extremely
    123  short lifetime, to reliably identifying very persistent objects
    124  across a network.
    125  .
    126  See RFC 4122 for more information.  
    127  .
    128  This package contains the uuidgen program and the uuidd daemon.
    129  .
    130  The uuidd daemon is used to generate UUIDs, especially time-based
    131  UUIDs, in a secure and guaranteed-unique fashion, even in the face
    132  of large numbers of threads trying to grab UUIDs running on
    133  different CPUs. It is used by libuuid as well as the uuidgen
    134  program.
    135 
    136 ifdef(`UDEB_PKGS',``
    137 Package: libuuid1-udeb
    138 Package-Type: udeb
    139 Section: debian-installer
    140 Priority: optional
    141 Depends: ${shlibs:Depends}
    142 Architecture: any
    143 Description: stripped down universally unique id library, for debian-installer
    144  libuuid generates and parses 128-bit universally unique ids (UUIDs).
    145  See RFC 4122 for more information.
    146  .
    147  This is a minimal package for debian-installer.
    148 '')dnl
    149 
    150 Package: uuid-dev
    151 Section: libdevel
    152 Priority: extra
    153 Depends: libc6-dev | libc-dev, libuuid1 (= ${mainBinary}), ${misc:Depends}
    154 Replaces: e2fslibs-dev (<< 1.15)
    155 Architecture: any
    156 Description: universally unique id library - headers and static libraries
    157  libuuid generates and parses 128-bit universally unique ids (UUIDs).
    158  See RFC 4122 for more information.
    159  .
    160  This package contains the development environment for the uuid library.
    161 
    162 Package: libblkid1
    163 Section: libs
    164 Depends: ${shlibs:Depends}, ${misc:Depends}
    165 Architecture: any
    166 Description: block device id library
    167  The blkid library which allows system programs like fsck and 
    168  mount to quickly and easily find block devices by filesystem UUID and 
    169  LABEL.  This allows system administrators to avoid specifying 
    170  filesystems by hard-coded device names, but via a logical naming 
    171  system instead.
    172 
    173 ifdef(`UDEB_PKGS',``
    174 Package: libblkid1-udeb
    175 Package-Type: udeb
    176 Section: debian-installer
    177 Priority: optional
    178 Depends: ${shlibs:Depends}, ${misc:Depends}
    179 Architecture: any
    180 Description: stripped down block device id library, for debian-installer
    181  The blkid library which allows system programs like fsck and 
    182  mount to quickly and easily find block devices by filesystem UUID and 
    183  LABEL.  This allows system administrators to avoid specifiying 
    184  filesystems by hard-coded device names, but via a logical naming 
    185  system instead.
    186  .
    187  This is a minimal package for debian-installer.
    188 '')dnl
    189 
    190 Package: libblkid-dev
    191 Section: libdevel
    192 Priority: extra
    193 Depends: libc6-dev | libc-dev, libblkid1 (= ${binary:Version}), ${misc:Depends}
    194 Architecture: any
    195 Description: block device id library - headers and static libraries
    196  The blkid library which allows system programs like fsck and 
    197  mount to quickly and easily find block devices by filesystem UUID and 
    198  LABEL.  This allows system administrators to avoid specifiying 
    199  filesystems by hard-coded device names, but via a logical naming 
    200  system instead.
    201  .
    202  This package contains the development environment for the blkid library.
    203 '')dnl
    204 
    205 ifdef(`UDEB_PKGS',``
    206 Package: e2fsprogs-udeb
    207 Package-Type: udeb
    208 Section: debian-installer
    209 Priority: optional
    210 Depends: ${shlibs:Depends}, ${misc:Depends}
    211 Architecture: any
    212 Description: stripped-down versions of e2fsprogs, for debian-installer
    213  This package is an e2fsprogs package built for a reduced size, so that
    214  it can help to save space in debian-installer.
    215  .
    216  Don'''``t attempt to install this package, it has no support for a couple of
    217  features you surely want.  Anyway it should refuse to install.
    218 '')dnl
    219 
    220 Package: e2fslibs
    221 Section: libs
    222 Depends: ${shlibs:Depends}, ${misc:Depends}
    223 Replaces: e2fsprogs (<< 1.34-1)
    224 Provides: libext2fs2, libe2p2
    225 Architecture: any
    226 MULTIARCH_HEADERS
    227 Description: ext2/ext3/ext4 file system libraries
    228  The ext2, ext3 and ext4 file systems are successors of the original ext
    229  ("extended") file system. They are the main file system types used for
    230  hard disks on Debian and other Linux systems.
    231  .
    232  This package provides the ext2fs and e2p libraries, for userspace software
    233  that directly accesses extended file systems. Programs that use libext2fs
    234  include e2fsck, mke2fs, and tune2fs. Programs that use libe2p include
    235  dumpe2fs, chattr, and lsattr.
    236 
    237 Package: e2fslibs-dev
    238 Section: libdevel
    239 Priority: extra
    240 Depends: libc6-dev | libc-dev, comerr-dev, e2fslibs (= ${binary:Version}), ${misc:Depends}
    241 Suggests: doc-base
    242 Provides: ext2fs-dev, e2p-dev
    243 Replaces: libkrb5-dev (<< 1.3)
    244 Architecture: any
    245 Description: ext2/ext3/ext4 file system libraries - headers and static libraries
    246  The ext2, ext3 and ext4 file systems are successors of the original ext
    247  ("extended") file system. They are the main file system types used for
    248  hard disks on Debian and other Linux systems.
    249  .
    250  This package contains the development environment for the ext2fs and e2p 
    251  libraries.
    252 
    253 Package: e2fsprogs
    254 Essential: yes
    255 ifdef(`UTIL_LINUX_NG',
    256 ``Pre-Depends: ${shlibs:Depends}, ${misc:Depends}, util-linux (>= 2.15~rc1-1)
    257 '',
    258 ``Pre-Depends: ${shlibs:Depends}, ${misc:Depends}
    259 '')dnl
    260 Multi-Arch: foreign
    261 Suggests: gpart, parted, fuse2fs, e2fsck-static
    262 Conflicts: dump (<< 0.4b4-4), quota (<< 1.55-8.1), initscripts (<< 2.85-4), sysvinit (<< 2.85-4)
    263 Replaces: hurd (<= 20040301-1), libblkid1 (<< 1.38+1.39-WIP-2005.12.10-2), libuuid1 (<< 1.38+1.39-WIP-2005.12.10-2)
    264 Architecture: any
    265 Description: ext2/ext3/ext4 file system utilities
    266  The ext2, ext3 and ext4 file systems are successors of the original ext
    267  ("extended") file system. They are the main file system types used for
    268  hard disks on Debian and other Linux systems.
    269  .
    270  This package contains programs for creating, checking, and maintaining
    271  ext2/3/4-based file systems.  It also includes the "badblocks" program,
    272  which can be used to scan for bad blocks on a disk or other storage device.
    273 ifdef(`USE_DBGSYM',,``
    274 Package: e2fsprogs-dbg
    275 Section: debug
    276 Priority: extra
    277 Depends: e2fsprogs (= ${binary:Version}), ${misc:Depends}
    278 Architecture: any
    279 Description: debugging information for e2fsprogs
    280  This package includes the debug information useful for debugging e2fsprogs
    281  and its libraries, contained in the e2fsprogs and e2fsck-static packages.
    282  The debug information is used for execution tracing and core
    283  dump analysis.
    284 '')
    285 ifdef(`USE_DBGSYM',,ifdef(`UTIL_LINUX_NG',,``
    286 Package: uuid-runtime-dbg
    287 Section: debug
    288 Priority: extra
    289 Depends: uuid-runtime (= ${binary:Version}), ${misc:Depends}
    290 Architecture: any
    291 Description: debugging information for uuid-runtime
    292  This package includes the debug information useful for debugging the
    293  uuid runtime programs, contained in the uuid-runtime package.
    294  The debugging information is used for execution tracing and core
    295  dump analysis.
    296 ''))dnl
    297 ifdef(`USE_DBGSYM',,``
    298 Package: e2fslibs-dbg
    299 Section: debug
    300 Priority: extra
    301 Depends: e2fslibs (= ${binary:Version}), ${misc:Depends}
    302 Architecture: any
    303 Description: debugging information for e2fslibs
    304  This package includes the debug information useful for debugging the
    305  ext2fs and e2p libraries, contained in the e2fslibs package.  The debug
    306  information is used for execution tracing and core dump analysis.
    307 
    308 Package: libcomerr2-dbg
    309 Section: debug
    310 Priority: extra
    311 Depends: libcomerr2 (= ${binary:Version}), ${misc:Depends}
    312 Architecture: any
    313 Description: debugging information for libcomerr2
    314  This package includes the debug information useful for debugging the
    315  com_err library, contained in the libcomerr2 package.  The debugging
    316  information is used for execution tracing and core dump analysis.
    317 
    318 Package: libss2-dbg
    319 Section: debug
    320 Priority: extra
    321 Depends: libss2 (= ${binary:Version}), ${misc:Depends}
    322 Architecture: any
    323 Description: debugging information for libss2
    324  This package includes the debug information useful for debugging the
    325  ss library, contained in the libss2 package.  The debug information
    326  is used for execution tracing and core dump analysis.
    327 '')dnl
    328 ifdef(`USE_DBGSYM',,ifdef(`UTIL_LINUX_NG',,``
    329 Package: libblkid1-dbg
    330 Section: debug
    331 Priority: extra
    332 Depends: libblkid1 (= ${binary:Version}), ${misc:Depends}
    333 Architecture: any
    334 Description: debugging information for libblkid1
    335  This package includes the debug information useful for debugging the
    336  blkid library, contained in the libblkid1 package.  The debug
    337  information is used for execution tracing and core dump analysis.
    338 
    339 Package: libuuid1-dbg
    340 Section: debug
    341 Priority: extra
    342 Depends: libuuid1 (= ${binary:Version}), ${misc:Depends}
    343 Architecture: any
    344 Description: debugging information for libuuid1
    345  This package includes the debug information useful for debugging the
    346  UUID library, contained in the libuuid1 package.  The debug
    347  information is used for execution tracing and core dump analysis.
    348 ''))dnl
    349