Home | History | Annotate | Download | only in script_api
      1 #
      2 # Copyright (C) 2015 The Android Open Source Project
      3 #
      4 # Licensed under the Apache License, Version 2.0 (the "License");
      5 # you may not use this file except in compliance with the License.
      6 # You may obtain a copy of the License at
      7 #
      8 #      http://www.apache.org/licenses/LICENSE-2.0
      9 #
     10 # Unless required by applicable law or agreed to in writing, software
     11 # distributed under the License is distributed on an "AS IS" BASIS,
     12 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
     13 # See the License for the specific language governing permissions and
     14 # limitations under the License.
     15 #
     16 
     17 header:
     18 summary: Debugging Functions
     19 description:
     20  The functions below are intended to be used during application developement.
     21  They should not be used in shipping applications.
     22 include:
     23  #define RS_DEBUG(a) rsDebug(#a, a)
     24  #define RS_DEBUG_MARKER rsDebug(__FILE__, __LINE__)
     25 end:
     26 
     27 function: rsDebug
     28 t: i32, u32, i64, u64, f64
     29 ret: void
     30 arg: const char* message
     31 arg: #1 a
     32 summary: Log a message and values
     33 description:
     34  This function prints a message to the standard log, followed by the provided values.
     35 
     36  This function is intended for debugging only and should not be used in shipping
     37  applications.
     38 test: none
     39 end:
     40 
     41 function: rsDebug
     42 version: 17
     43 w: 2, 3, 4
     44 t: i32, u32, i64, u64
     45 ret: void
     46 arg: const char* message
     47 arg: #2#1 a
     48 test: none
     49 end:
     50 
     51 function: rsDebug
     52 version: 23
     53 w: 2, 3, 4
     54 t: f64
     55 ret: void
     56 arg: const char* message
     57 arg: #2#1 a
     58 test: none
     59 end:
     60 
     61 function: rsDebug
     62 w: 1, 2, 3, 4
     63 ret: void
     64 arg: const char* message
     65 arg: float#1 a
     66 test: none
     67 end:
     68 
     69 function: rsDebug
     70 version: 24
     71 w: 1, 2, 3, 4
     72 ret: void
     73 arg: const char* message
     74 arg: half#1 a
     75 test: none
     76 end:
     77 
     78 function: rsDebug
     79 version: 17
     80 w: 1, 2, 3, 4
     81 t: i8, u8, i16, u16
     82 ret: void
     83 arg: const char* message
     84 arg: #2#1 a
     85 test: none
     86 end:
     87 
     88 function: rsDebug
     89 ret: void
     90 arg: const char* message
     91 arg: float a
     92 arg: float b
     93 test: none
     94 end:
     95 
     96 function: rsDebug
     97 ret: void
     98 arg: const char* message
     99 arg: float a
    100 arg: float b
    101 arg: float c
    102 test: none
    103 end:
    104 
    105 function: rsDebug
    106 ret: void
    107 arg: const char* message
    108 arg: float a
    109 arg: float b
    110 arg: float c
    111 arg: float d
    112 test: none
    113 end:
    114 
    115 function: rsDebug
    116 ret: void
    117 arg: const char* message
    118 arg: long long a
    119 test: none
    120 end:
    121 
    122 function: rsDebug
    123 ret: void
    124 arg: const char* message
    125 arg: unsigned long long a
    126 test: none
    127 end:
    128 
    129 function: rsDebug
    130 ret: void
    131 arg: const char* message
    132 arg: const void* a
    133 test: none
    134 end:
    135 
    136 function: rsDebug
    137 ret: void
    138 arg: const char* message
    139 arg: const rs_matrix4x4* a
    140 test: none
    141 end:
    142 
    143 function: rsDebug
    144 ret: void
    145 arg: const char* message
    146 arg: const rs_matrix3x3* a
    147 test: none
    148 end:
    149 
    150 function: rsDebug
    151 ret: void
    152 arg: const char* message
    153 arg: const rs_matrix2x2* a
    154 test: none
    155 end:
    156 
    157 #define RS_DEBUG(a) rsDebug(#a, a)
    158 #define RS_DEBUG_MARKER rsDebug(__FILE__, __LINE__)
    159