Home | History | Annotate | Download | only in except.spec
      1 // RUN: %clang_cc1 -std=c++11 -fexceptions -fcxx-exceptions -fsyntax-only -verify %s
      2 // expected-no-diagnostics
      3 
      4 // This is the "let the user shoot themselves in the foot" clause.
      5 void f() noexcept {
      6   throw 0; // no-error
      7 }
      8 void g() throw() {
      9   throw 0; // no-error
     10 }
     11 void h() throw(int) {
     12   throw 0.0; // no-error
     13 }
     14