Home | History | Annotate | Download | only in temp.deduct.partial
      1 // RUN: %clang_cc1 -std=c++11 -fsyntax-only -verify %s
      2 // expected-no-diagnostics
      3 
      4 template<typename T> int &f0(T&);
      5 template<typename T> float &f0(T&&);
      6 
      7 // Core issue 1164
      8 void test_f0(int i) {
      9   int &ir0 = f0(i);
     10   float &fr0 = f0(5);
     11 }
     12