Home | History | Annotate | Download | only in temp.deduct.type
      1 // RUN: %clang_cc1 -std=c++11 -fsyntax-only -verify %s
      2 // expected-no-diagnostics
      3 
      4 // FIXME: More bullets to go!
      5 
      6 template<typename T, typename U>
      7 struct has_nondeduced_pack_test {
      8   static const bool value = false;
      9 };
     10 
     11 template<typename R, typename FirstType, typename ...Types>
     12 struct has_nondeduced_pack_test<R(FirstType, Types..., int),
     13                                 R(FirstType, Types...)> {
     14   static const bool value = true;
     15 };
     16 
     17 // - A function parameter pack that does not occur at the end of the
     18 //   parameter-declaration-clause.
     19 int check_nondeduced_pack_test0[
     20                    has_nondeduced_pack_test<int(float, double, int),
     21                                             int(float, double)>::value? 1 : -1];
     22 
     23 
     24