Home | History | Annotate | Download | only in script_api
      1 #
      2 # Copyright (C) 2015 The Android Open Source Project
      3 #
      4 # Licensed under the Apache License, Version 2.0 (the "License");
      5 # you may not use this file except in compliance with the License.
      6 # You may obtain a copy of the License at
      7 #
      8 #      http://www.apache.org/licenses/LICENSE-2.0
      9 #
     10 # Unless required by applicable law or agreed to in writing, software
     11 # distributed under the License is distributed on an "AS IS" BASIS,
     12 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
     13 # See the License for the specific language governing permissions and
     14 # limitations under the License.
     15 #
     16 
     17 header:
     18 summary: Graphics Functions and Types
     19 description:
     20  The graphics subsystem of RenderScript was removed at API level 23.
     21 include:
     22  #ifdef __LP64__
     23  // TODO We need to fix some of the builds before enabling this error:
     24  // #error "RenderScript graphics is deprecated and not supported in 64bit mode."
     25  #endif
     26 
     27  // TODO we seem to assume order for the other headers too.
     28  #include "rs_object_types.rsh"
     29 end:
     30 
     31 type: rs_blend_src_func
     32 version: 16 22
     33 size: 32
     34 enum:
     35 value: RS_BLEND_SRC_ZERO = 0
     36 value: RS_BLEND_SRC_ONE = 1
     37 value: RS_BLEND_SRC_DST_COLOR = 2
     38 value: RS_BLEND_SRC_ONE_MINUS_DST_COLOR = 3
     39 value: RS_BLEND_SRC_SRC_ALPHA = 4
     40 value: RS_BLEND_SRC_ONE_MINUS_SRC_ALPHA = 5
     41 value: RS_BLEND_SRC_DST_ALPHA = 6
     42 value: RS_BLEND_SRC_ONE_MINUS_DST_ALPHA = 7
     43 value: RS_BLEND_SRC_SRC_ALPHA_SATURATE = 8
     44 value: RS_BLEND_SRC_INVALID = 100
     45 deprecated: 22
     46 summary: Blend source function
     47 description:
     48 end:
     49 
     50 type: rs_blend_dst_func
     51 version: 16 22
     52 size: 32
     53 enum:
     54 value: RS_BLEND_DST_ZERO = 0
     55 value: RS_BLEND_DST_ONE = 1
     56 value: RS_BLEND_DST_SRC_COLOR = 2
     57 value: RS_BLEND_DST_ONE_MINUS_SRC_COLOR = 3
     58 value: RS_BLEND_DST_SRC_ALPHA = 4
     59 value: RS_BLEND_DST_ONE_MINUS_SRC_ALPHA = 5
     60 value: RS_BLEND_DST_DST_ALPHA = 6
     61 value: RS_BLEND_DST_ONE_MINUS_DST_ALPHA = 7
     62 value: RS_BLEND_DST_INVALID = 100
     63 deprecated: 22
     64 summary: Blend destination function
     65 description:
     66 end:
     67 
     68 type: rs_cull_mode
     69 version: 16 22
     70 size: 32
     71 enum:
     72 value: RS_CULL_BACK = 0
     73 value: RS_CULL_FRONT = 1
     74 value: RS_CULL_NONE = 2
     75 value: RS_CULL_INVALID = 100
     76 deprecated: 22
     77 summary: Culling mode
     78 description:
     79 end:
     80 
     81 type: rs_depth_func
     82 version: 16 22
     83 size: 32
     84 enum:
     85 value: RS_DEPTH_FUNC_ALWAYS = 0, "Always drawn"
     86 value: RS_DEPTH_FUNC_LESS = 1, "Drawn if the incoming depth value is less than that in the depth buffer"
     87 value: RS_DEPTH_FUNC_LEQUAL = 2, "Drawn if the incoming depth value is less or equal to that in the depth buffer"
     88 value: RS_DEPTH_FUNC_GREATER = 3, "Drawn if the incoming depth value is greater than that in the depth buffer"
     89 value: RS_DEPTH_FUNC_GEQUAL = 4, "Drawn if the incoming depth value is greater or equal to that in the depth buffer"
     90 value: RS_DEPTH_FUNC_EQUAL = 5, "Drawn if the incoming depth value is equal to that in the depth buffer"
     91 value: RS_DEPTH_FUNC_NOTEQUAL = 6, "Drawn if the incoming depth value is not equal to that in the depth buffer"
     92 value: RS_DEPTH_FUNC_INVALID = 100, "Invalid depth function"
     93 deprecated: 22
     94 summary: Depth function
     95 description:
     96  Specifies conditional drawing depending on the comparison of the incoming
     97  depth to that found in the depth buffer.
     98 end:
     99 
    100 type: rs_primitive
    101 version: 16 22
    102 size: 32
    103 enum:
    104 value: RS_PRIMITIVE_POINT = 0, "Vertex data will be rendered as a series of points"
    105 value: RS_PRIMITIVE_LINE = 1, "Vertex pairs will be rendered as lines"
    106 value: RS_PRIMITIVE_LINE_STRIP = 2, "Vertex data will be rendered as a connected line strip"
    107 value: RS_PRIMITIVE_TRIANGLE = 3, "Vertices will be rendered as individual triangles"
    108 value: RS_PRIMITIVE_TRIANGLE_STRIP = 4, "Vertices will be rendered as a connected triangle strip defined by the first three vertices with each additional triangle defined by a new vertex"
    109 value: RS_PRIMITIVE_TRIANGLE_FAN = 5, "Vertices will be rendered as a sequence of triangles that all share first vertex as the origin"
    110 value: RS_PRIMITIVE_INVALID = 100, "Invalid primitive"
    111 deprecated: 22
    112 summary: How to intepret mesh vertex data
    113 description:
    114  Describes the way mesh vertex data is interpreted when rendering
    115 end:
    116 
    117 type: rs_font
    118 version: 9 22
    119 size: 32
    120 rs_object:
    121 deprecated: 22
    122 summary: Handle to a Font
    123 description:
    124  Opaque handle to a RenderScript font object.
    125  See: android.renderscript.Font
    126 end:
    127 
    128 
    129 type: rs_mesh
    130 version: 9 22
    131 size: 32
    132 rs_object:
    133 deprecated: 22
    134 summary: Handle to a Mesh
    135 description:
    136  Opaque handle to a RenderScript mesh object.
    137  See: android.renderscript.Mesh
    138 end:
    139 
    140 type: rs_program_fragment
    141 version: 9 22
    142 size: 32
    143 rs_object:
    144 deprecated: 22
    145 summary: Handle to a ProgramFragment
    146 description:
    147  Opaque handle to a RenderScript ProgramFragment object.
    148  See: android.renderscript.ProgramFragment
    149 end:
    150 
    151 type: rs_program_vertex
    152 version: 9 22
    153 size: 32
    154 rs_object:
    155 deprecated: 22
    156 summary: Handle to a ProgramVertex
    157 description:
    158  Opaque handle to a RenderScript ProgramVertex object.
    159  See: android.renderscript.ProgramVertex
    160 end:
    161 
    162 type: rs_program_raster
    163 version: 9 22
    164 size: 32
    165 rs_object:
    166 deprecated: 22
    167 summary: Handle to a ProgramRaster
    168 description:
    169  Opaque handle to a RenderScript ProgramRaster object.
    170  See: android.renderscript.ProgramRaster
    171 end:
    172 
    173 type: rs_program_store
    174 version: 9 22
    175 size: 32
    176 rs_object:
    177 deprecated: 22
    178 summary: Handle to a ProgramStore
    179 description:
    180  Opaque handle to a RenderScript ProgramStore object.
    181  See: android.renderscript.ProgramStore
    182 end:
    183 
    184 function: rsClearObject
    185 version: 9 22
    186 size: 32
    187 t: rs_mesh, rs_program_fragment, rs_program_vertex, rs_program_raster, rs_program_store, rs_font
    188 ret: void
    189 arg: #1* dst
    190 test: none
    191 end:
    192 
    193 function: rsIsObject
    194 version: 9 22
    195 size: 32
    196 t: rs_mesh, rs_program_fragment, rs_program_vertex, rs_program_raster, rs_program_store, rs_font
    197 ret: bool
    198 arg: #1 v
    199 test: none
    200 end:
    201 
    202 function: rsSetObject
    203 version: 9 22
    204 size: 32
    205 t: rs_mesh, rs_program_fragment, rs_program_vertex, rs_program_raster, rs_program_store, rs_font
    206 ret: void
    207 arg: #1* dst
    208 arg: #1 src
    209 test: none
    210 end:
    211 
    212 function: rsgAllocationSyncAll
    213 version: 9 22
    214 size: 32
    215 ret: void
    216 arg: rs_allocation alloc
    217 deprecated: 22
    218 summary: Sync the contents of an allocation
    219 description:
    220  Sync the contents of an allocation.
    221 
    222  If the source is specified, sync from memory space specified by source.
    223 
    224  If the source is not specified, sync from its SCRIPT memory space to its HW
    225  memory spaces.
    226 test: none
    227 end:
    228 
    229 function: rsgAllocationSyncAll
    230 version: 14 22
    231 size: 32
    232 ret: void
    233 arg: rs_allocation alloc
    234 arg: rs_allocation_usage_type source
    235 test: none
    236 end:
    237 
    238 function: rsgBindColorTarget
    239 version: 14 22
    240 size: 32
    241 ret: void
    242 arg: rs_allocation colorTarget
    243 arg: uint slot
    244 deprecated: 22
    245 summary: Set the color target
    246 description:
    247  Set the color target used for all subsequent rendering calls
    248 test: none
    249 end:
    250 
    251 function: rsgBindConstant
    252 version: 9 22
    253 size: 32
    254 ret: void
    255 arg: rs_program_fragment ps, "program fragment object"
    256 arg: uint slot, "index of the constant buffer on the program"
    257 arg: rs_allocation c, "constants to bind"
    258 deprecated: 22
    259 summary: Bind a constant allocation
    260 description:
    261  Bind a new Allocation object to a ProgramFragment or ProgramVertex.
    262  The Allocation must be a valid constant input for the Program.
    263 test: none
    264 end:
    265 
    266 function: rsgBindConstant
    267 version: 9 22
    268 size: 32
    269 ret: void
    270 arg: rs_program_vertex pv, "program vertex object"
    271 arg: uint slot
    272 arg: rs_allocation c
    273 test: none
    274 end:
    275 
    276 function: rsgBindDepthTarget
    277 version: 14 22
    278 size: 32
    279 ret: void
    280 arg: rs_allocation depthTarget
    281 deprecated: 22
    282 summary: Set the depth target
    283 description:
    284  Set the depth target used for all subsequent rendering calls
    285 test: none
    286 end:
    287 
    288 function: rsgBindFont
    289 version: 9 22
    290 size: 32
    291 ret: void
    292 arg: rs_font font, "object to bind"
    293 deprecated: 22
    294 summary: Bind a font object
    295 description:
    296  Binds the font object to be used for all subsequent font rendering calls
    297 test: none
    298 end:
    299 
    300 function: rsgBindProgramFragment
    301 version: 9 22
    302 size: 32
    303 ret: void
    304 arg: rs_program_fragment pf
    305 deprecated: 22
    306 summary: Bind a ProgramFragment
    307 description:
    308  Bind a new ProgramFragment to the rendering context.
    309 test: none
    310 end:
    311 
    312 function: rsgBindProgramRaster
    313 version: 9 22
    314 size: 32
    315 ret: void
    316 arg: rs_program_raster pr
    317 deprecated: 22
    318 summary: Bind a ProgramRaster
    319 description:
    320  Bind a new ProgramRaster to the rendering context.
    321 test: none
    322 end:
    323 
    324 function: rsgBindProgramStore
    325 version: 9 22
    326 size: 32
    327 ret: void
    328 arg: rs_program_store ps
    329 deprecated: 22
    330 summary: Bind a ProgramStore
    331 description:
    332  Bind a new ProgramStore to the rendering context.
    333 test: none
    334 end:
    335 
    336 function: rsgBindProgramVertex
    337 version: 9 22
    338 size: 32
    339 ret: void
    340 arg: rs_program_vertex pv
    341 deprecated: 22
    342 summary: Bind a ProgramVertex
    343 description:
    344  Bind a new ProgramVertex to the rendering context.
    345 test: none
    346 end:
    347 
    348 function: rsgBindSampler
    349 version: 9 22
    350 size: 32
    351 ret: void
    352 arg: rs_program_fragment fragment
    353 arg: uint slot
    354 arg: rs_sampler sampler
    355 deprecated: 22
    356 summary: Bind a sampler
    357 description:
    358  Bind a new Sampler object to a ProgramFragment.  The sampler will
    359  operate on the texture bound at the matching slot.
    360 test: none
    361 end:
    362 
    363 function: rsgBindTexture
    364 version: 9 22
    365 size: 32
    366 ret: void
    367 arg: rs_program_fragment v
    368 arg: uint slot
    369 arg: rs_allocation alloc
    370 deprecated: 22
    371 summary: Bind a texture allocation
    372 description:
    373  Bind a new Allocation object to a ProgramFragment.  The
    374  Allocation must be a valid texture for the Program.  The sampling
    375  of the texture will be controled by the Sampler bound at the
    376  matching slot.
    377 test: none
    378 end:
    379 
    380 function: rsgClearAllRenderTargets
    381 version: 14 22
    382 size: 32
    383 ret: void
    384 deprecated: 22
    385 summary: Clear all color and depth targets
    386 description:
    387  Clear all color and depth targets and resume rendering into
    388  the framebuffer
    389 test: none
    390 end:
    391 
    392 function: rsgClearColor
    393 version: 9 22
    394 size: 32
    395 ret: void
    396 arg: float r
    397 arg: float g
    398 arg: float b
    399 arg: float a
    400 deprecated: 22
    401 summary: Clear the specified color from the surface
    402 description:
    403  Clears the rendering surface to the specified color.
    404 test: none
    405 end:
    406 
    407 function: rsgClearColorTarget
    408 version: 14 22
    409 size: 32
    410 ret: void
    411 arg: uint slot
    412 deprecated: 22
    413 summary: Clear the color target
    414 description:
    415  Clear the previously set color target
    416 test: none
    417 end:
    418 
    419 function: rsgClearDepth
    420 version: 9 22
    421 size: 32
    422 ret: void
    423 arg: float value
    424 deprecated: 22
    425 summary: Clear the depth surface
    426 description:
    427  Clears the depth suface to the specified value.
    428 test: none
    429 end:
    430 
    431 function: rsgClearDepthTarget
    432 version: 14 22
    433 size: 32
    434 ret: void
    435 deprecated: 22
    436 summary: Clear the depth target
    437 description:
    438  Clear the previously set depth target
    439 test: none
    440 end:
    441 
    442 function: rsgDrawMesh
    443 version: 9 22
    444 size: 32
    445 ret: void
    446 arg: rs_mesh ism, "mesh object to render"
    447 deprecated: 22
    448 summary: Draw a mesh
    449 description:
    450  Draw a mesh using the current context state.
    451 
    452  If primitiveIndex is specified, draw part of a mesh using the current context state.
    453 
    454  If start and len are also specified, draw specified index range of part of a mesh using the current context state.
    455 
    456  Otherwise the whole mesh is rendered.
    457 test: none
    458 end:
    459 
    460 function: rsgDrawMesh
    461 version: 9 22
    462 size: 32
    463 ret: void
    464 arg: rs_mesh ism
    465 arg: uint primitiveIndex, "for meshes that contain multiple primitive groups this parameter specifies the index of the group to draw."
    466 test: none
    467 end:
    468 
    469 function: rsgDrawMesh
    470 version: 9 22
    471 size: 32
    472 ret: void
    473 arg: rs_mesh ism
    474 arg: uint primitiveIndex
    475 arg: uint start, "starting index in the range"
    476 arg: uint len, "number of indices to draw"
    477 test: none
    478 end:
    479 
    480 function: rsgDrawQuad
    481 version: 9 22
    482 size: 32
    483 ret: void
    484 arg: float x1
    485 arg: float y1
    486 arg: float z1
    487 arg: float x2
    488 arg: float y2
    489 arg: float z2
    490 arg: float x3
    491 arg: float y3
    492 arg: float z3
    493 arg: float x4
    494 arg: float y4
    495 arg: float z4
    496 deprecated: 22
    497 summary: Draw a quad
    498 description:
    499  Low performance utility function for drawing a simple quad.  Not intended for
    500  drawing large quantities of geometry.
    501 test: none
    502 end:
    503 
    504 function: rsgDrawQuadTexCoords
    505 version: 9 22
    506 size: 32
    507 ret: void
    508 arg: float x1
    509 arg: float y1
    510 arg: float z1
    511 arg: float u1
    512 arg: float v1
    513 arg: float x2
    514 arg: float y2
    515 arg: float z2
    516 arg: float u2
    517 arg: float v2
    518 arg: float x3
    519 arg: float y3
    520 arg: float z3
    521 arg: float u3
    522 arg: float v3
    523 arg: float x4
    524 arg: float y4
    525 arg: float z4
    526 arg: float u4
    527 arg: float v4
    528 deprecated: 22
    529 summary: Draw a textured quad
    530 description:
    531  Low performance utility function for drawing a textured quad.  Not intended
    532  for drawing large quantities of geometry.
    533 test: none
    534 end:
    535 
    536 function: rsgDrawRect
    537 version: 9 22
    538 size: 32
    539 ret: void
    540 arg: float x1
    541 arg: float y1
    542 arg: float x2
    543 arg: float y2
    544 arg: float z
    545 deprecated: 22
    546 summary: Draw a rectangle
    547 description:
    548  Low performance utility function for drawing a simple rectangle.  Not
    549  intended for drawing large quantities of geometry.
    550 test: none
    551 end:
    552 
    553 function: rsgDrawSpriteScreenspace
    554 version: 9 22
    555 size: 32
    556 ret: void
    557 arg: float x
    558 arg: float y
    559 arg: float z
    560 arg: float w
    561 arg: float h
    562 deprecated: 22
    563 summary: Draw rectangles in screenspace
    564 description:
    565  Low performance function for drawing rectangles in screenspace.  This
    566  function uses the default passthough ProgramVertex.  Any bound ProgramVertex
    567  is ignored.  This function has considerable overhead and should not be used
    568  for drawing in shipping applications.
    569 test: none
    570 end:
    571 
    572 function: rsgDrawText
    573 version: 9 22
    574 size: 32
    575 ret: void
    576 arg: const char* text
    577 arg: int x
    578 arg: int y
    579 deprecated: 22
    580 summary: Draw a text string
    581 description:
    582  Draws text given a string and location
    583 test: none
    584 end:
    585 
    586 function: rsgDrawText
    587 version: 9 22
    588 size: 32
    589 ret: void
    590 arg: rs_allocation alloc
    591 arg: int x
    592 arg: int y
    593 test: none
    594 end:
    595 
    596 function: rsgFinish
    597 version: 14 22
    598 size: 32
    599 ret: uint
    600 deprecated: 22
    601 summary: End rendering commands
    602 description:
    603  Force RenderScript to finish all rendering commands
    604 test: none
    605 end:
    606 
    607 function: rsgFontColor
    608 version: 9 22
    609 size: 32
    610 ret: void
    611 arg: float r, "red component"
    612 arg: float g, "green component"
    613 arg: float b, "blue component"
    614 arg: float a, "alpha component"
    615 deprecated: 22
    616 summary: Set the font color
    617 description:
    618  Sets the font color for all subsequent rendering calls
    619 test: none
    620 end:
    621 
    622 function: rsgGetHeight
    623 version: 9 22
    624 size: 32
    625 ret: uint
    626 deprecated: 22
    627 summary: Get the surface height
    628 description:
    629  Get the height of the current rendering surface.
    630 test: none
    631 end:
    632 
    633 function: rsgGetWidth
    634 version: 9 22
    635 size: 32
    636 ret: uint
    637 deprecated: 22
    638 summary: Get the surface width
    639 description:
    640  Get the width of the current rendering surface.
    641 test: none
    642 end:
    643 
    644 function: rsgMeasureText
    645 version: 9 22
    646 size: 32
    647 ret: void
    648 arg: const char* text
    649 arg: int* left
    650 arg: int* right
    651 arg: int* top
    652 arg: int* bottom
    653 deprecated: 22
    654 summary: Get the bounding box for a text string
    655 description:
    656  Returns the bounding box of the text relative to (0, 0)
    657  Any of left, right, top, bottom could be NULL
    658 test: none
    659 end:
    660 
    661 function: rsgMeasureText
    662 version: 9 22
    663 size: 32
    664 ret: void
    665 arg: rs_allocation alloc
    666 arg: int* left
    667 arg: int* right
    668 arg: int* top
    669 arg: int* bottom
    670 test: none
    671 end:
    672 
    673 function: rsgMeshComputeBoundingBox
    674 version: 9 22
    675 size: 32
    676 ret: void
    677 arg: rs_mesh mesh
    678 arg: float* minX
    679 arg: float* minY
    680 arg: float* min
    681 arg: float* maxX
    682 arg: float* maxY
    683 arg: float* maxZ
    684 deprecated: 22
    685 summary: Compute a bounding box
    686 description:
    687  Computes an axis aligned bounding box of a mesh object
    688 test: none
    689 end:
    690 
    691 function: rsgMeshComputeBoundingBox
    692 version: 9 22
    693 size: 32
    694 ret: void
    695 arg: rs_mesh mesh
    696 arg: float3* bBoxMin
    697 arg: float3* bBoxMax
    698 inline:
    699  float x1, y1, z1, x2, y2, z2;
    700  rsgMeshComputeBoundingBox(mesh, &x1, &y1, &z1, &x2, &y2, &z2);
    701  bBoxMin->x = x1;
    702  bBoxMin->y = y1;
    703  bBoxMin->z = z1;
    704  bBoxMax->x = x2;
    705  bBoxMax->y = y2;
    706  bBoxMax->z = z2;
    707 test: none
    708 end:
    709 
    710 function: rsgMeshGetIndexAllocation
    711 version: 16 22
    712 size: 32
    713 ret: rs_allocation, "allocation containing index data"
    714 arg: rs_mesh m, "mesh to get data from"
    715 arg: uint32_t index, "index of the index allocation"
    716 deprecated: 22
    717 summary: Return an allocation containing index data
    718 description:
    719  Returns an allocation containing index data or a null
    720  allocation if only the primitive is specified
    721 test: none
    722 end:
    723 
    724 function: rsgMeshGetPrimitive
    725 version: 16 22
    726 size: 32
    727 ret: rs_primitive, "primitive describing how the mesh is rendered"
    728 arg: rs_mesh m, "mesh to get data from"
    729 arg: uint32_t index, "index of the primitive"
    730 deprecated: 22
    731 summary: Return the primitive
    732 description:
    733  Returns the primitive describing how a part of the mesh is
    734  rendered
    735 test: none
    736 end:
    737 
    738 function: rsgMeshGetPrimitiveCount
    739 version: 16 22
    740 size: 32
    741 ret: uint32_t, "number of primitive groups in the mesh. This would include simple primitives as well as allocations containing index data"
    742 arg: rs_mesh m, "mesh to get data from"
    743 deprecated: 22
    744 summary: Return the number of index sets
    745 description:
    746  Meshes could have multiple index sets, this function returns
    747  the number.
    748 test: none
    749 end:
    750 
    751 function: rsgMeshGetVertexAllocation
    752 version: 16 22
    753 size: 32
    754 ret: rs_allocation, "allocation containing vertex data"
    755 arg: rs_mesh m, "mesh to get data from"
    756 arg: uint32_t index, "index of the vertex allocation"
    757 deprecated: 22
    758 summary: Return a vertex allocation
    759 description:
    760  Returns an allocation that is part of the mesh and contains
    761  vertex data, e.g. positions, normals, texcoords
    762 test: none
    763 end:
    764 
    765 function: rsgMeshGetVertexAllocationCount
    766 version: 16 22
    767 size: 32
    768 ret: uint32_t, "number of allocations in the mesh that contain vertex data"
    769 arg: rs_mesh m, "mesh to get data from"
    770 deprecated: 22
    771 summary: Return the number of vertex allocations
    772 description:
    773  Returns the number of allocations in the mesh that contain
    774  vertex data
    775 test: none
    776 end:
    777 
    778 function: rsgProgramFragmentConstantColor
    779 version: 9 22
    780 size: 32
    781 ret: void
    782 arg: rs_program_fragment pf
    783 arg: float r
    784 arg: float g
    785 arg: float b
    786 arg: float a
    787 deprecated: 22
    788 summary: Set the constant color for a fixed function emulation program
    789 description:
    790  Set the constant color for a fixed function emulation program.
    791 test: none
    792 end:
    793 
    794 function: rsgProgramVertexGetProjectionMatrix
    795 version: 9 22
    796 size: 32
    797 ret: void
    798 arg: rs_matrix4x4* proj, "matrix to store the current projection matrix into"
    799 deprecated: 22
    800 summary: Get the projection matrix for a fixed function vertex program
    801 description:
    802  Get the projection matrix for a currently bound fixed function
    803  vertex program. Calling this function with a custom vertex shader
    804  would result in an error.
    805 test: none
    806 end:
    807 
    808 function: rsgProgramVertexLoadModelMatrix
    809 version: 9 22
    810 size: 32
    811 ret: void
    812 arg: const rs_matrix4x4* model, "model matrix"
    813 deprecated: 22
    814 summary: Load the model matrix for a bound fixed function vertex program
    815 description:
    816  Load the model matrix for a currently bound fixed function
    817  vertex program. Calling this function with a custom vertex shader
    818  would result in an error.
    819 test: none
    820 end:
    821 
    822 function: rsgProgramVertexLoadProjectionMatrix
    823 version: 9 22
    824 size: 32
    825 ret: void
    826 arg: const rs_matrix4x4* proj, "projection matrix"
    827 deprecated: 22
    828 summary: Load the projection matrix for a bound fixed function vertex program
    829 description:
    830  Load the projection matrix for a currently bound fixed function
    831  vertex program. Calling this function with a custom vertex shader
    832  would result in an error.
    833 test: none
    834 end:
    835 
    836 function: rsgProgramVertexLoadTextureMatrix
    837 version: 9 22
    838 size: 32
    839 ret: void
    840 arg: const rs_matrix4x4* tex, "texture matrix"
    841 deprecated: 22
    842 summary:  Load the texture matrix for a bound fixed function vertex program
    843 description:
    844  Load the texture matrix for a currently bound fixed function
    845  vertex program. Calling this function with a custom vertex shader
    846  would result in an error.
    847 test: none
    848 end:
    849 
    850 function: rsgProgramRasterGetCullMode
    851 version: 16 22
    852 size: 32
    853 ret: rs_cull_mode
    854 arg: rs_program_raster pr, "program raster to query"
    855 deprecated: 22
    856 summary: Get program raster cull mode
    857 description:
    858  Get program raster cull mode
    859 test: none
    860 end:
    861 
    862 function: rsgProgramRasterIsPointSpriteEnabled
    863 version: 16 22
    864 size: 32
    865 ret: bool
    866 arg: rs_program_raster pr, "program raster to query"
    867 deprecated: 22
    868 summary: Get program raster point sprite state
    869 description:
    870  Get program raster point sprite state
    871 test: none
    872 end:
    873 
    874 function: rsgProgramStoreGetBlendDstFunc
    875 version: 16 22
    876 size: 32
    877 ret: rs_blend_dst_func
    878 arg: rs_program_store ps, "program store to query"
    879 deprecated: 22
    880 summary: Get program store blend destination function
    881 description:
    882  Get program store blend destination function
    883 test: none
    884 end:
    885 
    886 function: rsgProgramStoreGetBlendSrcFunc
    887 version: 16 22
    888 size: 32
    889 ret: rs_blend_src_func
    890 arg: rs_program_store ps, "program store to query"
    891 deprecated: 22
    892 summary: Get program store blend source function
    893 description:
    894  Get program store blend source function
    895 test: none
    896 end:
    897 
    898 function: rsgProgramStoreGetDepthFunc
    899 version: 16 22
    900 size: 32
    901 ret: rs_depth_func
    902 arg: rs_program_store ps, "program store to query"
    903 deprecated: 22
    904 summary: Get program store depth function
    905 description:
    906  Get program store depth function
    907 test: none
    908 end:
    909 
    910 function: rsgProgramStoreIsColorMaskAlphaEnabled
    911 version: 16 22
    912 size: 32
    913 ret: bool
    914 arg: rs_program_store ps, "program store to query"
    915 deprecated: 22
    916 summary: Get program store alpha component color mask
    917 description:
    918  Get program store alpha component color mask
    919 test: none
    920 end:
    921 
    922 function: rsgProgramStoreIsColorMaskBlueEnabled
    923 version: 16 22
    924 size: 32
    925 ret: bool
    926 arg: rs_program_store ps, "program store to query"
    927 deprecated: 22
    928 summary: Get program store blur component color mask
    929 description:
    930  Get program store blur component color mask
    931 test: none
    932 end:
    933 
    934 function: rsgProgramStoreIsColorMaskGreenEnabled
    935 version: 16 22
    936 size: 32
    937 ret: bool
    938 arg: rs_program_store ps, "program store to query"
    939 deprecated: 22
    940 summary: Get program store green component color mask
    941 description:
    942  Get program store green component color mask
    943 test: none
    944 end:
    945 
    946 function: rsgProgramStoreIsColorMaskRedEnabled
    947 version: 16 22
    948 size: 32
    949 ret: bool
    950 arg: rs_program_store ps, "program store to query"
    951 deprecated: 22
    952 summary: Get program store red component color mask
    953 description:
    954  Get program store red component color mask
    955 test: none
    956 end:
    957 
    958 function: rsgProgramStoreIsDepthMaskEnabled
    959 version: 16 22
    960 size: 32
    961 ret: bool
    962 arg: rs_program_store ps, "program store to query"
    963 deprecated: 22
    964 summary: Get program store depth mask
    965 description:
    966  Get program store depth mask
    967 test: none
    968 end:
    969 
    970 function: rsgProgramStoreIsDitherEnabled
    971 version: 16 22
    972 size: 32
    973 ret: bool
    974 arg: rs_program_store ps, "program store to query"
    975 deprecated: 22
    976 summary: Get program store dither state
    977 description:
    978  Get program store dither state
    979 test: none
    980 end:
    981