Home | History | Annotate | Download | only in gles11
      1 void glActiveTexture ( GLenum texture )
      2 void glAttachShader ( GLuint program, GLuint shader )
      3 void glBindAttribLocation ( GLuint program, GLuint index, const char *name )
      4 void glBindBuffer ( GLenum target, GLuint buffer )
      5 void glBindFramebuffer ( GLenum target, GLuint framebuffer )
      6 void glBindRenderbuffer ( GLenum target, GLuint renderbuffer )
      7 void glBindTexture ( GLenum target, GLuint texture )
      8 void glBlendColor ( GLclampf red, GLclampf green, GLclampf blue, GLclampf alpha )
      9 void glBlendEquation ( GLenum mode )
     10 void glBlendEquationSeparate ( GLenum modeRGB, GLenum modeAlpha )
     11 void glBlendFunc ( GLenum sfactor, GLenum dfactor )
     12 void glBlendFuncSeparate ( GLenum srcRGB, GLenum dstRGB, GLenum srcAlpha, GLenum dstAlpha )
     13 void glBufferData ( GLenum target, GLsizeiptr size, const GLvoid *data, GLenum usage )
     14 void glBufferSubData ( GLenum target, GLintptr offset, GLsizeiptr size, const GLvoid *data )
     15 GLenum glCheckFramebufferStatus ( GLenum target )
     16 void glClear ( GLbitfield mask )
     17 void glClearColor ( GLclampf red, GLclampf green, GLclampf blue, GLclampf alpha )
     18 void glClearDepthf ( GLclampf depth )
     19 void glClearStencil ( GLint s )
     20 void glColorMask ( GLboolean red, GLboolean green, GLboolean blue, GLboolean alpha )
     21 void glCompileShader ( GLuint shader )
     22 void glCompressedTexImage2D ( GLenum target, GLint level, GLenum internalformat, GLsizei width, GLsizei height, GLint border, GLsizei imageSize, const GLvoid *data )
     23 void glCompressedTexSubImage2D ( GLenum target, GLint level, GLint xoffset, GLint yoffset, GLsizei width, GLsizei height, GLenum format, GLsizei imageSize, const GLvoid *data )
     24 void glCopyTexImage2D ( GLenum target, GLint level, GLenum internalformat, GLint x, GLint y, GLsizei width, GLsizei height, GLint border )
     25 void glCopyTexSubImage2D ( GLenum target, GLint level, GLint xoffset, GLint yoffset, GLint x, GLint y, GLsizei width, GLsizei height )
     26 GLuint glCreateProgram ( void )
     27 GLuint glCreateShader ( GLenum type )
     28 void glCullFace ( GLenum mode )
     29 void glDeleteBuffers ( GLsizei n, const GLuint *buffers )
     30 void glDeleteFramebuffers ( GLsizei n, const GLuint *framebuffers )
     31 void glDeleteProgram ( GLuint program )
     32 void glDeleteRenderbuffers ( GLsizei n, const GLuint *renderbuffers )
     33 void glDeleteShader ( GLuint shader )
     34 void glDeleteTextures ( GLsizei n, const GLuint *textures )
     35 void glDepthFunc ( GLenum func )
     36 void glDepthMask ( GLboolean flag )
     37 void glDepthRangef ( GLclampf zNear, GLclampf zFar )
     38 void glDetachShader ( GLuint program, GLuint shader )
     39 void glDisable ( GLenum cap )
     40 void glDisableVertexAttribArray ( GLuint index )
     41 void glDrawArrays ( GLenum mode, GLint first, GLsizei count )
     42 void glDrawElements ( GLenum mode, GLsizei count, GLenum type, GLint offset )
     43 void glDrawElements ( GLenum mode, GLsizei count, GLenum type, const GLvoid *indices )
     44 void glEnable ( GLenum cap )
     45 void glEnableVertexAttribArray ( GLuint index )
     46 void glFinish ( void )
     47 void glFlush ( void )
     48 void glFramebufferRenderbuffer ( GLenum target, GLenum attachment, GLenum renderbuffertarget, GLuint renderbuffer )
     49 void glFramebufferTexture2D ( GLenum target, GLenum attachment, GLenum textarget, GLuint texture, GLint level )
     50 void glFrontFace ( GLenum mode )
     51 void glGenBuffers ( GLsizei n, GLuint *buffers )
     52 void glGenerateMipmap ( GLenum target )
     53 void glGenFramebuffers ( GLsizei n, GLuint *framebuffers )
     54 void glGenRenderbuffers ( GLsizei n, GLuint *renderbuffers )
     55 void glGenTextures ( GLsizei n, GLuint *textures )
     56 void glGetActiveAttrib ( GLuint program, GLuint index, GLsizei bufsize, GLsizei *length, GLint *size, GLenum *type, char *name )
     57 void glGetActiveUniform ( GLuint program, GLuint index, GLsizei bufsize, GLsizei *length, GLint *size, GLenum *type, char *name )
     58 void glGetAttachedShaders ( GLuint program, GLsizei maxcount, GLsizei *count, GLuint *shaders )
     59 GLint glGetAttribLocation ( GLuint program, const char *name )
     60 void glGetBooleanv ( GLenum pname, GLboolean *params )
     61 void glGetBufferParameteriv ( GLenum target, GLenum pname, GLint *params )
     62 GLenum glGetError ( void )
     63 void glGetFloatv ( GLenum pname, GLfloat *params )
     64 void glGetFramebufferAttachmentParameteriv ( GLenum target, GLenum attachment, GLenum pname, GLint *params )
     65 void glGetIntegerv ( GLenum pname, GLint *params )
     66 void glGetProgramiv ( GLuint program, GLenum pname, GLint *params )
     67 void glGetProgramInfoLog ( GLuint program, GLsizei bufsize, GLsizei *length, char *infolog )
     68 void glGetRenderbufferParameteriv ( GLenum target, GLenum pname, GLint *params )
     69 void glGetShaderiv ( GLuint shader, GLenum pname, GLint *params )
     70 void glGetShaderInfoLog ( GLuint shader, GLsizei bufsize, GLsizei *length, char *infolog )
     71 void glGetShaderPrecisionFormat ( GLenum shadertype, GLenum precisiontype, GLint *range, GLint *precision )
     72 void glGetShaderSource ( GLuint shader, GLsizei bufsize, GLsizei *length, char *source )
     73 const GLubyte * glGetString ( GLenum name )
     74 void glGetTexParameterfv ( GLenum target, GLenum pname, GLfloat *params )
     75 void glGetTexParameteriv ( GLenum target, GLenum pname, GLint *params )
     76 void glGetUniformfv ( GLuint program, GLint location, GLfloat *params )
     77 void glGetUniformiv ( GLuint program, GLint location, GLint *params )
     78 GLint glGetUniformLocation ( GLuint program, const char *name )
     79 void glGetVertexAttribfv ( GLuint index, GLenum pname, GLfloat *params )
     80 void glGetVertexAttribiv ( GLuint index, GLenum pname, GLint *params )
     81 // void glGetVertexAttribPointerv ( GLuint index, GLenum pname, void **pointer )
     82 void glHint ( GLenum target, GLenum mode )
     83 GLboolean glIsBuffer ( GLuint buffer )
     84 GLboolean glIsEnabled ( GLenum cap )
     85 GLboolean glIsFramebuffer ( GLuint framebuffer )
     86 GLboolean glIsProgram ( GLuint program )
     87 GLboolean glIsRenderbuffer ( GLuint renderbuffer )
     88 GLboolean glIsShader ( GLuint shader )
     89 GLboolean glIsTexture ( GLuint texture )
     90 void glLineWidth ( GLfloat width )
     91 void glLinkProgram ( GLuint program )
     92 void glPixelStorei ( GLenum pname, GLint param )
     93 void glPolygonOffset ( GLfloat factor, GLfloat units )
     94 void glReadPixels ( GLint x, GLint y, GLsizei width, GLsizei height, GLenum format, GLenum type, GLvoid *pixels )
     95 void glReleaseShaderCompiler ( void )
     96 void glRenderbufferStorage ( GLenum target, GLenum internalformat, GLsizei width, GLsizei height )
     97 void glSampleCoverage ( GLclampf value, GLboolean invert )
     98 void glScissor ( GLint x, GLint y, GLsizei width, GLsizei height )
     99 void glShaderBinary ( GLsizei n, const GLuint *shaders, GLenum binaryformat, const GLvoid *binary, GLsizei length )
    100 void glShaderSource ( GLuint shader )
    101 void glStencilFunc ( GLenum func, GLint ref, GLuint mask )
    102 void glStencilFuncSeparate ( GLenum face, GLenum func, GLint ref, GLuint mask )
    103 void glStencilMask ( GLuint mask )
    104 void glStencilMaskSeparate ( GLenum face, GLuint mask )
    105 void glStencilOp ( GLenum fail, GLenum zfail, GLenum zpass )
    106 void glStencilOpSeparate ( GLenum face, GLenum fail, GLenum zfail, GLenum zpass )
    107 void glTexImage2D ( GLenum target, GLint level, GLint internalformat, GLsizei width, GLsizei height, GLint border, GLenum format, GLenum type, const GLvoid *pixels )
    108 void glTexParameterf ( GLenum target, GLenum pname, GLfloat param )
    109 void glTexParameterfv ( GLenum target, GLenum pname, const GLfloat *params )
    110 void glTexParameteri ( GLenum target, GLenum pname, GLint param )
    111 void glTexParameteriv ( GLenum target, GLenum pname, const GLint *params )
    112 void glTexSubImage2D ( GLenum target, GLint level, GLint xoffset, GLint yoffset, GLsizei width, GLsizei height, GLenum format, GLenum type, const GLvoid *pixels )
    113 void glUniform1f ( GLint location, GLfloat x )
    114 void glUniform1fv ( GLint location, GLsizei count, const GLfloat *v )
    115 void glUniform1i ( GLint location, GLint x )
    116 void glUniform1iv ( GLint location, GLsizei count, const GLint *v )
    117 void glUniform2f ( GLint location, GLfloat x, GLfloat y )
    118 void glUniform2fv ( GLint location, GLsizei count, const GLfloat *v )
    119 void glUniform2i ( GLint location, GLint x, GLint y )
    120 void glUniform2iv ( GLint location, GLsizei count, const GLint *v )
    121 void glUniform3f ( GLint location, GLfloat x, GLfloat y, GLfloat z )
    122 void glUniform3fv ( GLint location, GLsizei count, const GLfloat *v )
    123 void glUniform3i ( GLint location, GLint x, GLint y, GLint z )
    124 void glUniform3iv ( GLint location, GLsizei count, const GLint *v )
    125 void glUniform4f ( GLint location, GLfloat x, GLfloat y, GLfloat z, GLfloat w )
    126 void glUniform4fv ( GLint location, GLsizei count, const GLfloat *v )
    127 void glUniform4i ( GLint location, GLint x, GLint y, GLint z, GLint w )
    128 void glUniform4iv ( GLint location, GLsizei count, const GLint *v )
    129 void glUniformMatrix2fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
    130 void glUniformMatrix3fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
    131 void glUniformMatrix4fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
    132 void glUseProgram ( GLuint program )
    133 void glValidateProgram ( GLuint program )
    134 void glVertexAttrib1f ( GLuint indx, GLfloat x )
    135 void glVertexAttrib1fv ( GLuint indx, const GLfloat *values )
    136 void glVertexAttrib2f ( GLuint indx, GLfloat x, GLfloat y )
    137 void glVertexAttrib2fv ( GLuint indx, const GLfloat *values )
    138 void glVertexAttrib3f ( GLuint indx, GLfloat x, GLfloat y, GLfloat z )
    139 void glVertexAttrib3fv ( GLuint indx, const GLfloat *values )
    140 void glVertexAttrib4f ( GLuint indx, GLfloat x, GLfloat y, GLfloat z, GLfloat w )
    141 void glVertexAttrib4fv ( GLuint indx, const GLfloat *values )
    142 void glVertexAttribPointer ( GLuint indx, GLint size, GLenum type, GLboolean normalized, GLsizei stride, GLint offset )
    143 void glVertexAttribPointer ( GLuint indx, GLint size, GLenum type, GLboolean normalized, GLsizei stride, const GLvoid *ptr )
    144 void glViewport ( GLint x, GLint y, GLsizei width, GLsizei height )
    145