Home | History | Annotate | Download | only in gles11
      1 void glBlendEquationSeparateOES ( GLenum modeRGB, GLenum modeAlpha )
      2 void glBlendFuncSeparateOES ( GLenum srcRGB, GLenum dstRGB, GLenum srcAlpha, GLenum dstAlpha )
      3 void glBlendEquationOES ( GLenum mode )
      4 void glDrawTexsOES ( GLshort x, GLshort y, GLshort z, GLshort width, GLshort height )
      5 void glDrawTexiOES ( GLint x, GLint y, GLint z, GLint width, GLint height )
      6 void glDrawTexxOES ( GLfixed x, GLfixed y, GLfixed z, GLfixed width, GLfixed height )
      7 void glDrawTexsvOES ( const GLshort *coords )
      8 void glDrawTexivOES ( const GLint *coords )
      9 void glDrawTexxvOES ( const GLfixed *coords )
     10 void glDrawTexfOES ( GLfloat x, GLfloat y, GLfloat z, GLfloat width, GLfloat height )
     11 void glDrawTexfvOES ( const GLfloat *coords )
     12 void glEGLImageTargetTexture2DOES ( GLenum target, GLeglImageOES image )
     13 void glEGLImageTargetRenderbufferStorageOES ( GLenum target, GLeglImageOES image )
     14 void glAlphaFuncxOES ( GLenum func, GLclampx ref )
     15 void glClearColorxOES ( GLclampx red, GLclampx green, GLclampx blue, GLclampx alpha )
     16 void glClearDepthxOES ( GLclampx depth )
     17 void glClipPlanexOES ( GLenum plane, const GLfixed *equation )
     18 void glColor4xOES ( GLfixed red, GLfixed green, GLfixed blue, GLfixed alpha )
     19 void glDepthRangexOES ( GLclampx zNear, GLclampx zFar )
     20 void glFogxOES ( GLenum pname, GLfixed param )
     21 void glFogxvOES ( GLenum pname, const GLfixed *params )
     22 void glFrustumxOES ( GLfixed left, GLfixed right, GLfixed bottom, GLfixed top, GLfixed zNear, GLfixed zFar )
     23 void glGetClipPlanexOES ( GLenum pname, GLfixed *eqn )
     24 void glGetFixedvOES ( GLenum pname, GLfixed *params )
     25 void glGetLightxvOES ( GLenum light, GLenum pname, GLfixed *params )
     26 void glGetMaterialxvOES ( GLenum face, GLenum pname, GLfixed *params )
     27 void glGetTexEnvxvOES ( GLenum env, GLenum pname, GLfixed *params )
     28 void glGetTexParameterxvOES ( GLenum target, GLenum pname, GLfixed *params )
     29 void glLightModelxOES ( GLenum pname, GLfixed param )
     30 void glLightModelxvOES ( GLenum pname, const GLfixed *params )
     31 void glLightxOES ( GLenum light, GLenum pname, GLfixed param )
     32 void glLightxvOES ( GLenum light, GLenum pname, const GLfixed *params )
     33 void glLineWidthxOES ( GLfixed width )
     34 void glLoadMatrixxOES ( const GLfixed *m )
     35 void glMaterialxOES ( GLenum face, GLenum pname, GLfixed param )
     36 void glMaterialxvOES ( GLenum face, GLenum pname, const GLfixed *params )
     37 void glMultMatrixxOES ( const GLfixed *m )
     38 void glMultiTexCoord4xOES ( GLenum target, GLfixed s, GLfixed t, GLfixed r, GLfixed q )
     39 void glNormal3xOES ( GLfixed nx, GLfixed ny, GLfixed nz )
     40 void glOrthoxOES ( GLfixed left, GLfixed right, GLfixed bottom, GLfixed top, GLfixed zNear, GLfixed zFar )
     41 void glPointParameterxOES ( GLenum pname, GLfixed param )
     42 void glPointParameterxvOES ( GLenum pname, const GLfixed *params )
     43 void glPointSizexOES ( GLfixed size )
     44 void glPolygonOffsetxOES ( GLfixed factor, GLfixed units )
     45 void glRotatexOES ( GLfixed angle, GLfixed x, GLfixed y, GLfixed z )
     46 void glSampleCoveragexOES ( GLclampx value, GLboolean invert )
     47 void glScalexOES ( GLfixed x, GLfixed y, GLfixed z )
     48 void glTexEnvxOES ( GLenum target, GLenum pname, GLfixed param )
     49 void glTexEnvxvOES ( GLenum target, GLenum pname, const GLfixed *params )
     50 void glTexParameterxOES ( GLenum target, GLenum pname, GLfixed param )
     51 void glTexParameterxvOES ( GLenum target, GLenum pname, const GLfixed *params )
     52 void glTranslatexOES ( GLfixed x, GLfixed y, GLfixed z )
     53 GLboolean glIsRenderbufferOES ( GLuint renderbuffer )
     54 void glBindRenderbufferOES ( GLenum target, GLuint renderbuffer )
     55 void glDeleteRenderbuffersOES ( GLsizei n, const GLuint *renderbuffers )
     56 void glGenRenderbuffersOES ( GLsizei n, GLuint *renderbuffers )
     57 void glRenderbufferStorageOES ( GLenum target, GLenum internalformat, GLsizei width, GLsizei height )
     58 void glGetRenderbufferParameterivOES ( GLenum target, GLenum pname, GLint *params )
     59 GLboolean glIsFramebufferOES ( GLuint framebuffer )
     60 void glBindFramebufferOES ( GLenum target, GLuint framebuffer )
     61 void glDeleteFramebuffersOES ( GLsizei n, const GLuint *framebuffers )
     62 void glGenFramebuffersOES ( GLsizei n, GLuint *framebuffers )
     63 GLenum glCheckFramebufferStatusOES ( GLenum target )
     64 void glFramebufferRenderbufferOES ( GLenum target, GLenum attachment, GLenum renderbuffertarget, GLuint renderbuffer )
     65 void glFramebufferTexture2DOES ( GLenum target, GLenum attachment, GLenum textarget, GLuint texture, GLint level )
     66 void glGetFramebufferAttachmentParameterivOES ( GLenum target, GLenum attachment, GLenum pname, GLint *params )
     67 void glGenerateMipmapOES ( GLenum target )
     68 // Hard to export to Java:
     69 // void *glMapBufferOES ( GLenum target, GLenum access )
     70 // GLboolean glUnmapBufferOES ( GLenum target )
     71 // void glGetBufferPointervOES ( GLenum target, GLenum pname, void **params )
     72 void glCurrentPaletteMatrixOES ( GLuint matrixpaletteindex )
     73 void glLoadPaletteFromModelViewMatrixOES ( void )
     74 void glMatrixIndexPointerOES ( GLint size, GLenum type, GLsizei stride, const GLvoid *pointer )
     75 void glWeightPointerOES ( GLint size, GLenum type, GLsizei stride, const GLvoid *pointer )
     76 void glDepthRangefOES ( GLclampf zNear, GLclampf zFar )
     77 void glFrustumfOES ( GLfloat left, GLfloat right, GLfloat bottom, GLfloat top, GLfloat zNear, GLfloat zFar )
     78 void glOrthofOES ( GLfloat left, GLfloat right, GLfloat bottom, GLfloat top, GLfloat zNear, GLfloat zFar )
     79 void glClipPlanefOES ( GLenum plane, const GLfloat *equation )
     80 void glGetClipPlanefOES ( GLenum pname, GLfloat *eqn )
     81 void glClearDepthfOES ( GLclampf depth )
     82 void glTexGenfOES ( GLenum coord, GLenum pname, GLfloat param )
     83 void glTexGenfvOES ( GLenum coord, GLenum pname, const GLfloat *params )
     84 void glTexGeniOES ( GLenum coord, GLenum pname, GLint param )
     85 void glTexGenivOES ( GLenum coord, GLenum pname, const GLint *params )
     86 void glTexGenxOES ( GLenum coord, GLenum pname, GLfixed param )
     87 void glTexGenxvOES ( GLenum coord, GLenum pname, const GLfixed *params )
     88 void glGetTexGenfvOES ( GLenum coord, GLenum pname, GLfloat *params )
     89 void glGetTexGenivOES ( GLenum coord, GLenum pname, GLint *params )
     90 void glGetTexGenxvOES ( GLenum coord, GLenum pname, GLfixed *params )
     91